Previous 1 2 3 Next 42 Replies Latest reply: Oct 3, 2008 11:59 PM by Rup49 Go to original post
  • whydoineedtoenteranalias Level 1 Level 1 (0 points)
    We have domains at work, not workgroups. I'm sorry but I do not have sufficient interest in Windows network to know what these terms really mean. I have a Windows network logon but this is to a specific domain, the printers are in another domain. I still have no idea how to fix this problem
  • Eng Yew Level 1 Level 1 (0 points)
    Thank you! This worked for me and allowed me to print to my company's Windows printer.

    smb://Workgroup/ServerName/PrinterID

    My company uses a Windows domain and I just put the domain name in as the Workgroup

    Message was edited by: Eng Yew
  • Lancer Kind Level 1 Level 1 (0 points)
    I had this problem too. What I had trouble with was where to put the domain since our printers are part of an active domain. I found that the previous poster's information was incorrect. I had to do the following:

    Deleted the printers in question.
    I re-added the printers using the cups utility: http://localhost:631 using the URI: smb://domain/username:password@servername:port/printershare.
    OR perhaps expressed more traditionally:
    smb://<domain>/<username>:<password>@<servername>:<port>/<printershare>

    What I suggest is that you look at a printer share that USED to work before this latest 10.5.2 update, and write that URI down, then insert:
    domain/username:password@. That is what I did. If your print server isn't part of a domain and not using domain authentication, then you can skip the [<domain>> portion.

    Another thing that wasn't clear to me was that when you save the above settings, CUPS will ask for a username and password. That username/password has *nothing to do* with the domain username/password we've been discussing up to this point, but is the username/password for the administrator of the Mac (which typically is the same username/password that you log in with).

    Once those settings are saved to CUPS, then look at the Printers and click "print test page" and see if the test page prints. If it doesn't chances are there is some mistake in your URI.

    Good luck!

    This really is a poor workaround since it exposes your domain password in clear text of a dialog. Granted that you need to be logged in as administrator, but it's really disturbing to see it there.

    Let's hope the next update is soon and that Apple will add this test case to their regression test suit. (Fingers crossed.)

    ==>Lancer----


    <Edited by Moderator>
  • miguline Level 1 Level 1 (0 points)
    Thanks for the help. Of all the posts this one most fit my current setting. I added the username and password and it worked.

    Not a great work around but much better than not being able to print.
  • CAnneB Level 1 Level 1 (0 points)
    Thank you very much! This solution worked for me. Just hoping to not have server username/password info showing after 10.5.3 comes out.
  • Ashler Level 2 Level 2 (210 points)
    Tried every combination of the URI. Printer says "wrong Person" which is old HP speak for an authentication error.

    This use to all work... how can Windows network printing not be part of a test plan? Very poor.

    I used CUPS - never had to before - but I did this time... I selected WIndows SAMBA printing... is that correct?
  • Boul Level 1 Level 1 (0 points)
    Ooops!
    Sorry for not having answered earlier.
    It is not exactly the Fax/Printer pane you should customize, but the "add printer pane" that appears when willing to add a printer.
    Menu bar custumization is performed like in any other application.
    Just perform a right clik on the menu bar and choose "modify tool bar" in the pop-up window menu (in french : " Personnaliser la bar d'outils". I do not know the correspondance in english, sorry).
    Then drag and drop the required icon onto the tool bar.
  • Boul Level 1 Level 1 (0 points)
    In answer to dudebun : I accept email beer with pleasure. Meanwhile I will tast THE very best one (http://www.orval.be/an/products/brewery/brewery1.html)

    Just another point concerning this CUPS fix/workaround:
    - The problem is still present in 10.5.3!
    - Apparently, there is no need to add username and password. The full path including the workgroup is sufficient. At the first print, the system asks username and password that can then be added to the keychain by proper check box selection.
    So, for security reasons it could be a good idea to reinitialize Safari in order to clear all memorized reference to password and username.
  • llh1 Level 1 Level 1 (0 points)
    I had this same problem trying to print to my Windows printer. Installing the
    10.5.3 update fixed it for me. I did not use the workaround suggested earlier
    in the response string. I did have to re-enter my Windows login and password.
  • Anchann Level 1 Level 1 (10 points)
    What does one do when there is no Windows login and password? I am on a network at the school I work for, but I cannot connect to their networked printers. I have added them, but when I send something it disappears as if it was shot right past the printer. I do not need any login to access the internet here, just plug in and surf.
  • Scott Howe Level 1 Level 1 (125 points)
    I'm going to compose myself because I don't want Apple to close this thread as they tend to do when people complain too much about an issue that they don't fix but I'm really at my wits end with this problem. Leopard has just been a disaster for me at my place of employment. Nothing seems to fix this error for me and I'm getting so tired of it. If I could I would turn back time and never have installed Leopard at all but unfortunately I have no choice with the new Macs we are getting in. My situation is very similar to all: Windows print server, used to work flawlessly, throw Leopard in the mix, doesn't work anymore. I simply cannot believe that Apple will not address this. It's at 10.5.4 and this should be fixed by them. I realize the 10.5.3 fixed it for some people but not for me so there STILL is some issue somewhere, and it's Leopard and not anything else.

    Anymore feedback here? Anyone found another solution they can share? Insights?
  • Pagrash Level 1 Level 1 (70 points)
    To anyone who hasn't solved this with the above suggestions.
    Our location has minimum authentication set to NTLMv2 so we had this error when trying to print to 2003 servers. Our solution was to add the following three lines to the smb.conf file in the /etc/ folder on clients

    client ntlmv2 auth = yes
    security = domain
    password server = IP or FQDM of AD server:389

    Multiple servers separated by a comma can be added to the password server entry.

    Hope this helps
  • Rup49 Level 1 Level 1 (0 points)
    Added these lines to sam.conf on MacBook (Mac OS X 10.5.5) for printers on Windows XP Prof version:

    client ntlmv2 auth = yes
    security = server
    password server = 192.168.1.100

    Tried other suggestions, but I think only this was needed. You can contact me at rsa@istar.ca. This is my wife's computer. I stick to XP.

    bob
Previous 1 2 3 Next