Previous 1 2 3 Next 38 Replies Latest reply: Mar 11, 2008 11:46 AM by Daniel McCarthy Go to original post
  • decypher 44 Level 1 (80 points)
    This really ticks me off. This is a BIG problem, so you'd think Apple would come out with a fix, or at least acknowledge the problem and let us know that they are working on a fix.
  • William Lanni Level 1 (90 points)
    Would someone be willing to paste the fixes from MacFixit here? The links provided go to pages that require a paid subscription. I would hope that the Apple forums, of all places, would have solutions free.

    thanks
  • melgeo Level 1 (0 points)
    Quicktime will not play the video for my mp4 files, but Itunes will. Has anyone else tried this?
  • decypher 44 Level 1 (80 points)
    Yeah, they will still play in iTunes, which is weird, since it uses QT tech to do so.
  • Bewick Level 1 (0 points)
    Add me to the long list of people who are finding their mp4 video files no longer working after the last QuickTime update. I use a variety of soccer and referee related video clips that I have gathered from youtube google video and the like via Safari and then converted via iSquint. Everything was working wonderfully until this update. I have a 2Ghz Intel Core 2 Duo macbook running 10.4.11 and QuckTime Pro The mp4 files as others have found now only play audio. I can play the files in VLC just fine, but in a class room setting, it's a drag to have some clips play fine, and other I have to open in VLC. One other impact I have noticed, is that a couple of my lectures use powerpoint with embedded video clip, some of which are mp4. Now when I run slide show, and click on the imbedded mp4 video clip to run it, powerpoint quits. Don't know if it is related, but the slideshow worked perfectly until this update. This is a pain. It seems the only solution is to downgrade to 7.3
  • D. Fraser Level 3 (560 points)
    I ran into this with 7.3 Pro. When I upgraded to Leopard and 7.4, it started working correctly again. For those QT Pro users out there, try opening the Movie Properties window, select the 'Video Track' and then play around with the Transparency settings under the Visual Settings Tab. I think I changed the transparency to Composition and I was able to get normal playback in QT.

    I hope this could work for some of you. It worked for me.

    D.
  • sdlmdpc Level 1 (0 points)
    Download the version of QuickTime 7.3.1 for your OS at:
    http://www.apple.com/support/downloads/

    Panther: http://www.apple.com/support/downloads/quicktime731forpanther.html
    Tiger: http://www.apple.com/support/downloads/quicktime731fortiger.html
    Leopard: http://www.apple.com/support/downloads/quicktime731forleopard.html

    Then download Pacifist, give it Administrator privileges, and use it to install from those packages.

    Tell Pacifist to overwrite all existing files, and it will delete all those hundreds of files that I deleted manually using OS9, overwrite them with QT 7.3.1 versions, and QT will work properly again.
  • jwl3v Level 1 (20 points)
    Thanks for the suggestion about changing the video setting to composition. I opened one of the many videos with which I've had this problem (only audio plays via QT, but both video and audio play via iT).

    Recounting the problem (on G5, 2x2G, 4G RAM, 10.5.1; using registered QT Pro 7.4.0 (92)):
    (a) Only audio plays with some QT files.
    (b) Both audio and video play when file is imported into iTunes.
    (c) Problem appears to be file specific; may only occur on files downloaded via TubeSock,
    (d) but appears to occur for files downloaded recently as well as those downloaded earlier.
    (d) For affected files, iMovie imports only the audio, too (see example at http://johnl.edschool.virginia.edu/QTVideoProblem.mov).
    (e) Affected files have same problem when moved to another Mac using current QT (MBP 10.5.1).

    Sigh...so much for using these videos in this afternoon's class.

    Message was edited by: jwl3v
  • William Lanni Level 1 (90 points)
    I followed the instructions to reinstall 7.3.1 with Pacifist. MP4s are playing again. WMVs are not. I also re-installed Flip4Mac, but previously working wmv's now are not working. I supposed that's a new topic, as mp4s are.

    sigh.
  • troubledone Level 1 (0 points)
    I followed sdlmdpc's advice and my problem was solved, using the older version of QT. I only hope that the problem with QT is finally resolved I see that they have an update released 2-6-08 for QuickTime 7.4.1. I don't dare try it yet. Has anyone else attempted this? Thanks to everyone for the previous suggestions.
  • Tim3308 Level 3 (550 points)
    Update today does not work for me. Still mp4's will only play audio portion!
  • decypher 44 Level 1 (80 points)
    Same here. I tried everything (repair permissions, using Onyx, etc) and nothing will work. Maybe 7.4.2?
  • algerman Level 1 (10 points)
    Same here. Now using 7.3.1 as suggested, everything works fine: .mp4 files, quicklook, no need to uninstall any plugins. As a test, I tried to install 7.4.1 using Pacifist directly on top of the downgraded and working 7.3.1 (well, maybe it´s the installer...), nope... still refused to work, hey Apple, what´s up?!
    BTW: just to add to the mess, the .mp4 files created from Tubesock (2.0.3) does not play in QT 7.4 or 7.4.1 but plays fine in my iPod touch 8GB, just like on iTunes, go figure...
  • Klaus1 Level 8 (47,775 points)