Previous 1 2 Next 19 Replies Latest reply: Mar 3, 2008 7:52 PM by Jason Kim
dekket Level 1 (5 points)
Every time I start iTunes, the new firewall in Leopard asks me:
"Do you want the application "iTunes.app" to accept incoming network connections?"

I click Allow every time but it always asks me, and iTunes is listed in the firewall settings for allowed applications, but it's not working.

Anyone know how to fix this incredibly annoying issue?

G5 (early 2006), Mac OS X (10.5), Upgrade from Tiger
  • Indiana.Jonas Level 1 (0 points)
    I've been having the same problem since last night when I replaced the default iTunes icon using CandyBar. I just reverted to the default icon and the problem seems to be gone.
  • dekket Level 1 (5 points)
    Oh ok...
    I used to use Candybar back in Tiger, but haven't been using it in Leopard. Can't remember changing the icon though, and it looks like the real thing... Hmm I'll install candybar 3 and see if I can fix it that way.
  • dekket Level 1 (5 points)
    Hey that helped!
    Though, I had to load up Candybar in demo mode (don't have a license,) change the icon on iTunes, apply, and then remove/apply again in order for it to work. Strange to say the least since the iTunes icon was default...
  • Indiana.Jonas Level 1 (0 points)
    I'm glad that worked. Before I reverted to the original icon I took a look inside the iTunes package /contents/resources/ folder and there was a backup of the original icon put there by CandyBar. I suspect that may have been the problem but I can't imagine why.
  • The Raven Level 2 (245 points)
    I don't think CandyBar is the problem. I've been getting the message ever since the latest iTunes update...and I've never changed my iTunes icon with CandyBar.
  • CD3 Level 1 (30 points)
    I had the same problem.

    This solved it for me:

    System Preferences, Security, Firewall, allow all incoming connections.

    I'm assuming that as it says "Mac OS normally determines which programs are allowed incoming connections.....) is safe.

    iTunes is in that list, but by checking set access for specific services and allowing iTunes in the list to have incoming connections, I still got the "do you want to allow" dialogue every time.

    This is with the latest (yesterday) iTunes update.

    CD3
  • asmith.bassoon Level 1 (0 points)
    Hello,

    I've been having this problem as well since I upgraded to iTunes 7.6 yesterday, and I have never used candybar.

    I'm hesitant to set the system preferences to allow all incoming connections, for many and easily imaginable reasons.

    Has anyone discovered a different fix that addresses the root problem?
  • jeffpaff Level 1 (0 points)
    This is not really a solution, because you're basically just disabling the firewall by doing this, which is not a good idea.
  • WalrusC Level 1 (45 points)
    A temporary workaround is to disable sharing your music library in your iTunes preferences. This stops the pop-up. Hopefully someone will find a solution and/or Apple will release an update. I suggest dropping bug reports to Apple as they do not read these forums.
  • ItsKCMac Level 1 (25 points)
    None of these have fixed mine yet. I've also tried disabling the fetching of album artwork, turning off my Express so there's no AirTunes, removing podcasts, etc.

    I've been denying and so far everything is working.

    Maybe to keep from seeing the popup, I'll just click Allow and have it running all the time in the background. The internet is full of trustworthy people and it won't hurt to enable incoming connections.

    Unless we get some kind of explanation and if this connection is to be a permanent thing. This would be a BIG bug I would think.
  • The Raven Level 2 (245 points)
    The firewall also offers an "Allow only essential services" option which stops the message from popping up.
  • ItsKCMac Level 1 (25 points)
    What is so essential in this version of iTunes that it requires an open port? Is it the rental stuff?
  • WalrusC Level 1 (45 points)
    Hey guys, this has been discussed in another thread as well. An Apple rep replied and said they are looking into it.

    http://discussions.apple.com/thread.jspa?threadID=1342237&tstart=50
  • WalrusC Level 1 (45 points)
    Ok, we have a fix from Apple!

    Go download iTunes from the downloads section here at Apple and reinstall 7.6. It fixes the issue.
Previous 1 2 Next