Previous 1 2 3 Next 136 Replies Latest reply: Jun 4, 2009 9:31 AM by wyosteven
weRdxup Level 1 Level 1 (35 points)
On a MacBook Pro 15" 2.4 GHz Intel Core 2 Duo with 10.5.1:

Sometimes, after my MacBook goes to sleep, it will not wake up! I press every single key and tried closing and reopening the MacBook but the screen remains black. However the indicator light that pulstates while it is in sleep mode does turn off after the first attempt at trying to wake it up. After that if i close the MacBook again the light will not pulsate. I always end up having to manually shut down my MacBook and boot again. Has anybody else had this problem? It only occurs once in a while but is very annoying. Any ideas?

Powerbook G4 15", Mac OS X (10.5.1)
  • swankyknits Level 1 Level 1 (0 points)
    On my macbook pro this is almost always the result of letting the computer sleep when the battery is very low. Once it tells me I am on reserve power, if I don't plug in before it sleeps, it does not want to wake up. My rule of thumb with laptops is that you don't let them sleep for long periods of time, unless they are plugged into power. That's just my experience.
  • Grand Exhaulted Poobah Level 1 Level 1 (25 points)
    Its a leopard bug. Wife's computer locked up when it went to sleep. We turned off the rss visualizer screen saver and so far it hasn't had problems waking. Keeping fingers crossed.
  • Dolbec Level 1 Level 1 (0 points)
    I face the same problem everyday. It's very annoying. Anybody knows when Apple will bring a fix to it?
  • pickmynose Level 1 Level 1 (20 points)
    Have you tried turning on/off ext. peripherals to see if that wakes it?
  • Glenn Diaz Level 1 Level 1 (0 points)
    The MAc is going into a mode called safe sleep. There is a fix for it using the terminal. Here is a post on how to fix it.

    http://www.smalldog.com/newsarchive/techtails_display.php?id=314

    It's from 2006, but the problem is still relivent and needs to be addressed. Try it and see.
  • Curious-George Level 1 Level 1 (0 points)
    I downloaded the below link and it seemed to solve the problem for me.
    http://www.apple.com/support/downloads/macbookmacbookprosoftwareupdate11.html
  • 91gti_wolfsburg Level 1 Level 1 (0 points)
    I am having the same exact problem. Here is an excerpt from my system log when the freeze occurs.

    At 1-31 11:00:07 I open the lid. About a minute later I have to do a hard restart because the desktop will not come up. The Caps Lock and Num Lock keys both respond to input, so I have no idea what is going on here.

    Jan 31 10:44:00 dhcp243-158 kernel[0]: System Sleep
    Jan 31 11:00:07 kerry-carpenters-computer kernel[0]: System Wake
    Jan 31 10:44:00 dhcp243-158 configd[14]: setting hostname to "kerry-carpenters-computer.local"
    Jan 31 10:44:00 dhcp243-158 configd[14]: rtmsg: error writing to routing socket
    Jan 31 11:00:07: --- last message repeated 1 time ---
    Jan 31 11:00:07 dhcp243-158 configd[14]: setting hostname to "dhcp243-158.plymouth.edu"
    Jan 31 11:00:12 dhcp243-158 kernel[0]: AppleYukon2: 00000000,00000000 sk98osx_dnet - recovering from missed interrupt
    Jan 31 11:00:19 dhcp243-158 kernel[0]: AppleYukon2: 00000000,00000000 sk98osx_dnet - recovering from missed interrupt
    Jan 31 11:01:12 localhost kernel[0]: npvhash=4095
    Jan 31 11:01:09 localhost com.apple.launchctl.System[2]: launchctl: Dubious permissions on file (skipping): /Library/LaunchDaemons/uk.co.dssw.wakeassist.plist
    Jan 31 11:01:12 localhost com.apple.launchctl.System[2]: launchctl: Please convert the following to launchd: /etc/mach_init.d/AVCAssistant.plist
    Jan 31 11:01:12 localhost com.apple.launchctl.System[2]: launchctl: Please convert the following to launchd: /etc/mach_init.d/dashboardadvisoryd.plist
    Jan 31 11:01:12 localhost com.apple.launchd[1] (xxx.qnation.PeerGuardian.kextload): Unknown key: ServiceDescription
    Jan 31 11:01:12 localhost com.apple.launchd[1] (com.apple.mio.AVCAssistant): Conflict with job: 0x100830.AVCAssistant over Mach service: com.apple.mio.AVCAssistant
  • causeffect Level 1 Level 1 (0 points)
    After having this same sleep issue with my original 2006 Macbook I have done some looking around and am posting everything I have found so far. I have read trying a few things.

    1. reset the SMC
    2. install BatteryUpdate200701, MacBookMacBookProKbdSU, and MacBookSMCUpdate
    3. uncheck "Automatically reduce the brightness of the display before display sleep", in System Preferences/ Energy Saver/ Options/...
    4. I have read about making script changes made in Terminal, but am hesitant to take this route, since I am not sure how it will effect future OS X updates

    I did steps 1, 2 and 3. I will report back on their effects in a few days.

    Side note. An unusual thing I have noticed when repairing disk permissions using the Disk Utility software is getting the same errors every time. I found a page on the Apple website concerning this here: http://docs.info.apple.com/article.html?artnum=306925. Apple writes: "You can safely ignore these messages. They are accurate but not a cause for concern." huh...

    I am hoping the next OS X update will help with the permissions and sleep issues.
  • Rick Miller2 Level 1 Level 1 (5 points)
    I'm having this same problem.

    It only happens when the lid has been closed.
    It happens about 10% of the time.
    The hard drive spins on when opening. Then nothing.
    I have no peripherals.
    The battery is usually full.
    I have the latest OS updates (10.4.11)

    Is Apple suggesting I need to purchase 10.5 to solve this problem?
  • durrace Level 1 Level 1 (0 points)
    If it's any consolation, the same thing is happening on my Intel Core2Duo iMac. Oftern (not always) won't wake up from sleep. Mouse, keyboard (wireless), remote have no effect.
  • applehill Level 1 Level 1 (0 points)
    I'm having the same problem as everyone else. I have a iMac G5. It starts up sometimes but most of the time it just sits there with a black screen. I tried reinstalling my OS and after I installed all the updates about 2 weeks later it started again. I'm running Tiger on a first generation G5 iMac. Apple fix please. I ran the terminal code as suggested several post up. I let you know if it works. Like I said it's so intermittent that I'll have to wait a day or so to tell if the problem is gone or not.
  • applehill Level 1 Level 1 (0 points)
    Application Enhancer seems to be the problem. I upgraded to a newer version. The terminal commands that I said I would try. Well I guess when the computer tried to go to safe sleep mode it just shut down. Anyone that tried it change 0 to 3 it will bring it back. Anyway like I was saying I believe it to be from Application Enhancer I just up graded to the latest one 2.0.3 If it doesn't work after that then I'm going to uninstall it.
  • Jude Dippold Level 1 Level 1 (0 points)
    This worked for me:
    1) Shut down MacBook and remove the battery;
    2) Hold down the Start button for ten seconds and then release it;
    3) Reinstall the battery
    4) Restart the computer
    This procedure resets the MacBook's PRAM settings which contain many of the computer's basic settings, including the RAM disc which needs to be accessed for the computer to awaken.
    For those having this problem on a desktop, see Apple's instructions for resetting your computer.
  • Jeffrey Carlson2 Level 1 Level 1 (5 points)
    I have had the same problem. The computer sleeps and will not wake up. I read in one of these threads that the energy saving setting could be the source of the sleeping. I remember just having made a change.

    The impact was dramatic. I unchecked the Wake Options: Wake for Ethernet network administrator access and uncheck Other Options: Automatically reduce the brightness of the display before display sleep. I have not had a problem in the last 24 hours. The day before I had to restart the computer 4 times. Give this a try. the only option I have checked in the Options tab is Show battery status in the menu bar.
Previous 1 2 3 Next