Previous 1 2 3 4 Next 646 Replies Latest reply: Feb 5, 2016 11:02 AM by King Am Go to original post Branched to a new discussion.
  • xo.carly Level 1 (5 points)
    Thank you SO much!! I had the same problem & this worked for me too!!!!!!!! You just saved me $450!
  • ghettosoak Level 1 (0 points)
    I have had this problem, and the "earjack *******" notion really does work. If you hold the two up side by side, the plain headphones' jack is slightly longer. That's because the iPhone likes to take it deep.
  • ima747 Level 1 (0 points)
    I've had this problem perviously and the unplug-replug 7-8 times worked for me the last 2 times it glitched but not this time. I cut the end off a Q tip and went rooting around in the headphone jack and dug out a little lint which didn't solve it but atleast there's no lint in there now... I did a software restore, tried all the other tricks I could find but here's how I finally got it working again.

    Headphones out, ipod stoped
    Called my phone from another phone
    the ringer rang out the speaker but when I tried to talk and listen I got nothing (obviously trying to use the headphones which weren't there)
    turned on speaker phone, could now talk and listen.
    turned off speaker phone and it went back to working properly
    hang up, enjoy working speaker again.

    My suspicion is that it's a combination of hardware and software issues that cause the hangup. The most likely cause is a sticky switch in the jack causing the iphone not to properly recognize when headphones are removed. However once you unstick the jack (dig out lint, jiggle it with a bunch of insert-removes etc.) the software may still glitch and apparently asking it to go to speakerphone then back to regular mode (which should CHECK for headphones in theory, and not just trust the jack switch) may just do the trick...

    If it rings out the main speaker it has to know on some level that the headphones arn't there...
  • kicko Level 1 (10 points)
    My understanding is there is a switch inside the jack they should move back turning the headphones off but it sometimes "sticks" in new devices. My laptop did the same thing, after a little "jacksex" it no longer was an issue.
  • Mr. Mobius Level 1 (0 points)
    Try "twisting" the headphone plug while it's in the jack. I went to the Apple store today after many restores. I though my internals speakers had gone.

    Not the I can "recommend" this other method, but for those where nothing else will work and you are out of warranty: I would try a small cotton swab with rubbing alcohol. I use this method in the recording studio to clean contacts. Only a last resort.

    With both methods a twisting motion will work best.
  • Tracy (Austin) Level 1 (0 points)
    Since I don't recall ever plugging in headphones to my new iPhone, this "stuck in headphone" problem caught me by surprise. The only way I was able to tell that I was in headphone mode was by trying to adjust the volume during an actual phone call.

    As suggested in this thread, I tried using some computer speakers to plug in/out a bunch of times, but my phone was still stuck in headphone mode whenever I tried to place a call or receive a call.

    So, I plugged in my computer speakers, made a call to my home answering machine and heard my call on the speakers. Then, while still in my call, I unplugged the computer speakers and it fixed the problem. My iPhone is no longer in headphone mode and I can place calls again.

    Apple really should consider adding some sort of "Setting" where the mode can be changed manually. All this plug in/out stuff is really quirky.
  • realitydreamship Level 2 (295 points)
    heres a video of how to do it and reset the iphone... this actually works for both 1st and 2nd gen iPhones... -in-headphones-mode/

    Message was edited by: realitydreamship
  • shorty_jr Level 1 (0 points)
    i tried to plug and unplug several times, i restored my iphone from itunes, i reseted my iphone with home and lock button but it didn’t work...any soloution?pls
  • Joe_66 Level 1 (0 points)
    iPhone: My problem is similar - it seems my phone will stay in headset mode (sometimes?) if I am listening to the iPod through the Aux port in my car and I receive a phone call. I will hear the phone ring through the car speakers, unplug the aux jack and attempt to answer the call. The caller can hear me, but I cannot hear the caller. The same thing happens if I am using regular headphones.

    Rebooting the phone sometimes helps. Using the iphone headset seems to work to correct the problem. Now I must ensure that I carry my headset at all times. This is a software problem in my opinion.

    Apple - you need to fix this.
  • BKLinTX Level 1 (15 points)
    Now me too. Started after using Aux jack on my car. Plugging in earbuds several times did not clear problem for me. I also had to start iPod, play a song, hit pause and remove earbuds to clear issue.
  • KJB1985 Level 1 (0 points)
    I have the same problem, but none of the above fixes does anything to help.

    Any other ideas?
  • d-d-g Level 1 (0 points)
    I had this happen a few times before and inserting the headphone jack worked those times, but this time it didn't.

    What I did to fix it after trying everything above a number of times was to take an air duster (like this one:, inserted it all the way into the headphone jack and sprayed all around for about 10-15 seconds.

    After that was done, I inserted the headphones and pulled them out one time and it was fixed.
  • stanpaise Level 1 (0 points)
    ima747 you are a genius,

    thanks It works great
  • Wurkle Level 1 (0 points)
    Having same problem... but it is now causing trouble DURING calls. Whilst using phone all went quiet, it had switched to headphone mode.
    I've reset, cleaned with air duster and tried insert / remove jack. All have worked but the problem keeps occuring.

    There seems to be no pattern to when it is going to goto headphone mode.
    Any other fixes out there?
  • paulba71 Level 1 (0 points)
    Having the same problem. It is definately a software problem and is on 2.2.1 also. To say I am mad is an understatement. If another company release software with these types of issues we would be all jumping up and down, but Apple get away with it. I have to all intents and purposes a brick as at least twice a day (usually in the middle of a call) the phone jumps into headphones mode and you need to Home+Power reboot to get sound back. All the shiney u.i. is still "lipstick on a pig" if you can't use it for it's main purpose - the phone.
Previous 1 2 3 4 Next