Previous 1 26 27 28 29 30 Next 668 Replies Latest reply: May 5, 2016 8:55 AM by rpv101 Go to original post Branched to a new discussion.
  • Shotokan8 Level 1 Level 1

    So is this a hardware or software problem? Some of your solutions are software related (icloud) while others are hardware related (freezer, air can, brush).


    If hardware, does anyone know how an earjack works?  When I try to look in there I see 3 little 'bumps' but is one of those a moveable switch that I need to try to move to get mine to work? 


    There has to be a consistent pattern between all of these.

  • Easterbrooks Level 1 Level 1

    Try changing your air play to another device then change it back.  The phone will at this point realize there is no headphones attached and you can now select iPhone again

  • tommyfromon Level 1 Level 1

    So I tried everything to get my iphone out of headphone mode.


    I eventually stuck a tookpick inside the audio port and pulled out a small amount of pocket lint....The phone works perfect now.

  • gurskyi Level 1 Level 1

    thanks man! sucking rocks!

  • bassman777 Level 1 Level 1

    iPhone 5 - Compressed air through the straw in the headphone and docking jack fixed it.

  • Shotokan8 Level 1 Level 1

    All, I believe for most of you it's a hardware problem and all those tricks work.  Not for me


    I'm starting to believe it's a software problem.  Not only is it stuck in headphones mode but sometimes people can't even hear me through my earphone mic and I have to restart it for the mic to work again.


    I've wiped my phone and reinstalled it (not from backup).  Any thoughts on resolving it if it's a software issue?

  • rdh48 Level 1 Level 1

    Can't really add anything to the problem, but FYI: -

    Discovered the problem yesterday evening after calling my wife on her mobile. She could hear me but no amount of her responses/shouting came through to my end. Got home and after phaffing about saw that the volume control showed 'Ringer, Headphones'. Sound only came out when a call came through but none of the other alert sounds worked. Tried all the different suggestions in this forum, i.e. various jacks in an out umpteen times, twisting jack, blowing through straw, pausing music in play mode and removing jack etc, etc! Sound only came through when buds inserted.

    Gave up in disgust and put phone to one side to try and sort out today. However, this morning everything was back to normal - so can only guess that one of the various attempts worked and the software cleared itself overnight.

    By the way, wife has never put anything in the jack and keeps phone in leather case (not in pocket), so lint would not have been a possible cause. Phone just got its knickers in a twist all by itself. Never knew this could happen so waiting for mine to play up now!!


    From the previous 28 pages of this forum this problem seems to have been around since 2008 and Apple seem to blithely ignore it!!!!!!!!!!!!!!!

  • shannon ong Level 1 Level 1

    plug in the headphone.

    turn off the phone.

    unplug the headphone and turn phone on.

    the sound works like normal.

  • bauer23 Level 1 Level 1

    This worked for me! 

  • Connern14 Level 1 Level 1

    I turned Siri on and it fixed it

  • Shotokan8 Level 1 Level 1

    Nope didn't work.  Am i the only one that believes it's a deeper problem and NOTHING is fixing it (hardware or software related)?

  • rdh48 Level 1 Level 1

    Couldn't say for sure as to whether it's hardware or software but FYI the next day after posting my previous response, guess what? Wife's phone refused to take a charge via any method. Ordered replacement charging dock, watched youtube video on just how easy it is to take phone apart, replace part and put back together - ha f*****g ha!!! Unless you have microscopic fingers, eyesight like a soaring eagle and really tiny (must be magnetic) screwdrives - you are truly stuffed. Have bought the s'drivers, a huge magnifying glass on a stand and various sets of tweezers, put it back together but either must have done something wrong, not replaced a miniscule spring thingy that jumped out from god knows where, replaced screws in right order or, perhaps there was never a problem with the original charging port but the wretched thing doesn't work. It now resides in our dustbin until dustmen come on Friday and in the meantime deciding on a cheapo replacement from a well known auction site or paying through the nose for a 2-year deal on a newer version from the rip-off phone shops. Am I grumpy (?), **** yes, her expensive iPad I treated her to just over a year ago has now decided to have a mind of its own this afternoon!!!!!!!!!!!!

  • Shotokan8 Level 1 Level 1

    Thanks but what does all that have to do with iphones stuck in headphones mode?

  • gbaca Level 1 Level 1

    Compressed air did the trick for me. Looked like a small piece of lint blew out. Sweet!! 

  • ScoCo Level 1 Level 1

    After trying everything mentioned in this thread, the one thing that finally worked for me was shooting canned air into the headphone slot. I shot bursts (1 sec), about a dozen times with music playing... so I could tell if it was working. The music finally came on, but then stopped. I kept shooting air until the music stayed on with out needing to spray any more.

Previous 1 26 27 28 29 30 Next