13 Replies Latest reply: Feb 10, 2008 3:31 PM by cameraz
theweerdguy Level 1 Level 1 (20 points)
this is interesting. I successfully set up my comcast mail account with the ipod, and am recieving emails just fine. HOWEVER it will not allow me to send emails due to an error that says "the connection to the outgoing server smtp.comcast.net failed." I have contacted comcast about this error, and we ran through the access codes and account settings, and found that everything was the way it was supposed to be. Is anyone else having a similar problem, or can anyone offer up a solution?

Thanks, Connor.

iBook G4/ Mac Pro, Mac OS X (10.5)
  • Whackintosh Level 1 Level 1 (25 points)
    I have the same problem for my pop account. Getting my mails works, but sending gives an failing message.
  • boarder 6 Level 1 Level 1 (105 points)
    the same thing happened to me. i fixed by typing in my username and password under outgoing mail then going to advanced and changing the server port to 25.

    P.S. To find all the info if you use mail go to preferences and its in there.
  • Karru Level 1 Level 1 (0 points)
    I know when i set up my pop account i had to put the login info for outgoing and incomming. Don't know if you did that on not but seems to work fine on mine like that.
  • mollib Level 2 Level 2 (460 points)
    I'm having the same issue with my gmail account (imap) but it's intermittent. The messages will attempt to send a few times and then they'll go without a problem. Or, they'll look like they're sending but not really send. I've sent a couple without issue - not sure why it sometimes work and sometimes doesn't.
  • cameraz Level 1 Level 1 (10 points)
    Did you ever find a solution to your problem? I also can receive Comcast e-mail, but can't send! I checked my settings and they are correct. Can anybody help me here? Thanks!!!!
  • fowlski Level 1 Level 1 (0 points)
    Did anyone come up with a solution to this..? I am having the same issue with my @netscape.net email. I can get incoming messages no problem but outgoing messages doesn't work at all. I get the same message "the connection to the outgoing server "stmp.aol.com" failed". have tried various different ports for outgoing messages, preset 587, port 25 and 446 (as suggested on other forums). Authentication is set to Password, as for the incoming messages...
    Help.
  • lenn5 Level 4 Level 4 (2,530 points)
    I have time warner cable. On the outgoing mail server settings I have User Name: Optional and Password: Option. Also have SSL: OFF

    lenn
  • mtcabral Level 1 Level 1 (0 points)
    Hi, I was/am having this same problem, but here's an additional detail. I'd be curious to have someone else try this and see if it works:

    My inbound always works fine; my outbound fails with the "can't connect" message. But if I temporarily turn off that email account under SETTINGS -> MAIL with the unsent msg still in my OUTBOX, it successfully sends shortly after. Maybe it has something to do with NOT being logged into the email server (via the incoming connection)?

    Pls post back if this works for you. Thanks, Mike
  • BobBranst Level 1 Level 1 (0 points)
    I'm on Time Warner(RoadRunner. After I removed my User Name and Password from the outgoing mail settings (as suggested by lenn5)my outgoing mail started working perfectly. It makes no sense to me why it worked, but it did.
  • Jayschwa Level 2 Level 2 (175 points)
    I am having the same issue but w/ inconsistencies.

    I have 2 pop accounts that were synced from apple mail.

    Both can receive just fine.

    After the initial sync... the outgoing ports were set to :534 (or something)... I reset them to :25 and it worked once.

    Than I noticed that if I am on the same network as the mac I sync with, Mail on iPod sends fine (but causes my G5 to lose that mail account password in keychain... annoying)

    However, when I am about town, on random wi-fi networks, mail will not send.

    I imagine this could be a router firewall issue for which I have no control over... but I don't think that is it.

    I will try to add my user/pass to the end of the outgoing server string to see if that makes a difference.
  • Jayschwa Level 2 Level 2 (175 points)
    Oh yeah... and iChat would e cool too.
  • ateringcateringcat Level 1 Level 1 (5 points)
    i had same connection failed error, set port to 25, user name & password entered ii outgoing section of ipod. & it worked.

    next day, it didn't. after a couple of hours frigging about, + 1 call to my ISP tech support (nildram) that confirmed that 25 was the ONLY port to use, i deleted the outgoing username/password bit & it's working again.

    something flakey going on.
  • cameraz Level 1 Level 1 (10 points)
    I solved this problem ... for Comcast users, at least:

    When you go into the settings for mail, it asks you to enter your user name and password for your Incoming Mail Server. However, it says the name and password for the Outgoing Mail server are optional. THEY'RE NOT OPTIONAL! You have to enter the name and password on the Outgoing Server as well.

    As soon as I entered my name and password here, my mail worked perfectly ... both ways!