1 Reply Latest reply: Jan 17, 2008 4:20 PM by sfcrotty
sfcrotty Level 1 Level 1 (0 points)
Hi all,

I am trying to share screens with a Mac Mini running ARD in OS X 10.3.9 over a LAN from my Macbook Pro (10.4.11). I have an Airport Extreme base station (7.2.1). The Mini is connected to the base station via wired Ethernet cable, the Macbook is wireless.

I'm using Chicken of the VNC (2.0b4) on the MacBook, but I can't get anything but Connection Refused.

* The software firewall on the mini is off (I'm behind NAT)
* I've turned on ARD in the Sharing prefs control panel, set up the users and checked all the "allow" checkboxes (and restarting the mini)
* I've tried connecting to port 5900, 5901, and 3283
* I've tried enabling port mapping on the Airport (which seems crazy, since this is all happening within the LAN)

I can SSH to the mini just fine from the Macbook. Using NetUtility, I can ping it, traceroute to it, you name it.

The only weird thing that I can find is that when I do a Port Scan on the Mini, it never returns port 5900 as open (which it seems like it should). Other ports return as open.

I've Googled my brains out looking for answers on this, and the best info that I can find points toward a network config. problem. But if that's the case, why can I SSH okay?

And yes...I could upgrade to Leopard on the MacBook. Or install OSXvnc on the Mini. But I can't see why I wouldn't have exactly the same problem. And, dadgum it, this should work!

I'm totally stumped (and have a sneaking suspicion that I'm missing something obvious). If anyone can shed light on this, or point me at a resource, I'd be very grateful.

thanks,

c

MacBook Pro, Mac OS X (10.4.11), Mac Mini (10.3.9)