Previous 1 67 68 69 70 71 Next 2,048 Replies Latest reply: Aug 30, 2015 4:27 PM by el.jeffe58 Go to original post Branched to a new discussion.
  • DrBobP Level 1 Level 1 (0 points)

    I disabled the IPV6 (whatever that is) and it seems to have fixed the connectivity issue.

  • colombian_24 Level 1 Level 1 (0 points)

    I have the same problem. I'll be on my macbook pro only 1 week old in the living room and the internet will work blazing fast. Once I take it to my room which is not even more than 35 feet away from the router and put the computer to sleep I wake it up and the internet slows down pretty bad, (however it still works if I wait about 10-15 seconds per page, i just swapped out my macbook pro I bought in late may because no matter how long I waited it wouldnt work at all in my room) meanwhile my ps3 and ipod touch keep working fast in my room! Doesn't make sense. I just put the settings to never sleep and so far so good, lets see if it works.

  • hgunneng Level 1 Level 1 (0 points)

    DrBobP, you have a new MBP and disabling the IPV6 solved the problem of getting disconnected? Im using Lion, i put the IPV6 to Link-Local, (cannot disable in Lion) but it didnt help.

    I have the same problem with most other people here, my new MBP 2.3 is disconnected from internet using wifi after about 30seconds, with ethernet cable its working fine. My old macbook and Ipod is working fine using wireless.

    But when using my new MBP in starbucks wireless is working fine. Maybe MBP can only work with strong signals or it is disconnected when using certain routers? Anybody else have used their MPB in i.e. Starbucks, are you disconnected there too? Anybody having any solutions to this problem? Have tried all suggestions in here, doesnt work.

  • DrBobP Level 1 Level 1 (0 points)

    I just read another thread that suggested disabling the security on your router or changing the name of your network from time to time.  My connection was perfect all day yesterday;  when I signed on today I had to reboot the router.  So at best,  the situation is better than it was before I disabled IPV6.   I am using a Linksys G 2.4.  Maybe the common thread is the router? 

  • DrBobP Level 1 Level 1 (0 points)

    The other thing I was thinking about is whether there are other 2.4 G  devices in the area that are interfering.  Maybe you should try to change the channel on your router.  My Linksys has 12 channels all at a very slightly different frequency.

  • michaelfromhell Level 1 Level 1 (0 points)

    I went through all channels, no dice. Also set router to choose best frequency automatically, again same issues..

  • Geoff@Amsterdam Level 1 Level 1 (0 points)

    Last Friday i mentioned I would go back to change my macbook pro again, but for an macbook air. After some reading at other threads, on air, it seems they Macbook Air owners have similar problems. So, I did not do it. (I still prefer MBP over MBA cause of power and upgrade possibilties)


    Later that night, I played with some settings -> change DHCP to static address. Which did not work of course. I had not filled in other settings. I changed it back again and switched to another location and I seemed to have a connection again for some time.


    This weekend I was at another location with my MBP and found no issues at all. I was connected to a D-Link DIR N 650 router (WPA-2).


    Tonight I will see how it works with my own Sweex LW055 (WEP) router again.


    I would not be suprised that there are some router compatibility issues here.

  • hgunneng Level 1 Level 1 (0 points)

    yes, that seems to be the problem, router compatibility. But strange that only my MBP has these problems and not my Ipod and old macbook. different machines might react differently to different router problems, who knows.

  • michaelfromhell Level 1 Level 1 (0 points)

    I reported earlier that I was having the same issue with my ipad 2.  I know this thread isn't for ipad's but I just want to create some depth to enable further thinking..


    While experiencing the issue on my ipad, i received push messages through anapplication "Viber".


    Google tells me this app uses:


    TCP: 5242 and 4244

    UDP: 5243 and 9785


    This means while my web page is hanging, some data is actually getting through.


    Has anyone experienced any programs on the MBP that continue to functioneven after the web pages begin to hang?


    This to me suggests it’s not a router compatibility issue as previously suggested, but more likely a OS X software issue..




    Message was edited by: michaelfromhell

  • Geoff@Amsterdam Level 1 Level 1 (0 points)



    True, I have the same and others as well. I have notice something though, coincidence or not, but when I moved very near my router (I moved from a +3 meter distance to < 1 meter) the connection was good, when it actually did connect. I had that 2 times. Still, the connection dropped shortly.


    I also begin to wonder whether the aluminium design might be weakening the signal somehow. I do not seem to be the only one with this idea: html

    I haven't read all the pages in this thread, so someone else might already have mentioned it. It could explain why my other wireless devices have no difficulties.


    When it comes to routers, I lack some technical knowledge, but the difference between my router at home and the one at another location is:

    - My Sweex is around 4 years old and has one antenna

    - The D-Link one is a half year old and has 3 antenna's.

    The range for both the routers are around the same (around 10 meters), but I can imagine the new D-Link one with three antenna's boost the broadcast strength of the signal, being able to better 'penetrate' the aluminium case of the MBP/MBA


    I changed the security settings of my Sweex router from WEP to WPA-2, which did not help.




    I am not sure about the reason why your IPAD2 is having these issues too. Is it partly designed with aluminium as well? Some data is definately getting through, since it does load a webpage when I wait a couple of minutes.


    it probably depends on the location of the wifi card in the system.

  • gusgrave Level 1 Level 1 (20 points)

    I thought I'd throw my 2 cents in. I, like multiple other MBP user have experienced strange behaviour regarding the WiFi connectivity via AirPort. I have been keeping track of what I've done so far in another thread:



    I have found a large number of threads in different forums with a unique "solution" in each forum, none of which has been permanent.


    I have found numerous problems with my airport connection and I have not found a way to "fix" these problems yet, dough I tried something last weekend that has allowed me to connect and stay connected even after reboots and sleep-mode.


    Turn AirPort off, delete everything related to the network from Network Preferences and Keychain, reboot, create a new Location under Network Preferences, delete every connection profile EXCEPT for Airport, this should be the only connection method available under this "Location", turn airport on and find your network, connect.


    I doubt this will work for everone and for every problem, though it has worked for me so far. As I propose in the thread, I find it har to believe that a new "location" would cancel out disturbing networks and hardware problems/incompatibility seems not so likely since the WiFi will work great in some locations and poor in other with different or the same router manufacturers depending on actual location, and since it works great once the connection is established until you loose connection, I find it hard to believe that all of us would have hardware issues.


    Best regards

  • AlekseyK Level 1 Level 1 (0 points)

    Think same. However how to force Apple to fix this??? There is only phone support available.


    michaelfromhell wrote:


    This to me suggests it’s not a router compatibility issue as previously suggested, but more likely a OS X software issue..



  • AlekseyK Level 1 Level 1 (0 points)

    That works only temporarily.

  • gusgrave Level 1 Level 1 (20 points)

    Thats what I though, all solutions I have found are temporary, deleting .plist files, renaming the network, changing orders in connection methods, re-install,  bla bla bla....


    I have not found any true solution to this problem and I have been struggling with this for over a year.


    I haven't read the entire thread so I don't no if you've already checked the console messages and see if you can derive any information from there.


    This is one area of the Mac world where I have actually began to loose faith...

  • alifromcarnforth Level 1 Level 1 (0 points)

    I posted to this forum last week the wireless connectivity problems I faced with my MBP on my home wireless network. Usual problems, connectivity dropping out and the other normally stable macbook and 13inch MPB losing connectivity once the new 15inch hit the network. I have been at  my girlfreinds for the last 7 days using her netgear router (almost the same as my own). Bizarrely, I've had a rock solid connection. I cant explain what this means, only that the 15inch mbp seems to run just fine here.

Previous 1 67 68 69 70 71 Next