Previous 1 2 3 4 Next 2,043 Replies Latest reply: Feb 23, 2015 5:12 PM by Gwardlaw1 Go to original post Branched to a new discussion.
  • JCTorres Level 1 Level 1 (0 points)
    Hello Everyone!

    Until Apple fix this problem, you will need to broadcast the SSID and disable 802.11b or mixed mode your AP. That should take care the problem.

    Jaden
  • jimix Level 1 Level 1 (0 points)
    I contacted Apple support regarding this. They advised I contact Verizon since they provided me with my router (for FIOS service). Verizon states that there are known problems using WPA with their router and also with disabling SSID broadcast. The best part is that the Verizon tech recommnended that I buy an Apple Airport base station with wireless N and use that for wireless connections, disabling wireless on the Verizon router.

    So there is a $200 solution. In the meantime, I am using WEP with MAC level access control and SSID broadcast on. That seems to work fine but I don't feel very safe.
  • RychenCop Level 1 Level 1 (0 points)
    i had the same wireless problems and all i did was set the default connection in my router for g only and i have no problems now.
  • Gr8_Gonzo Level 1 Level 1 (0 points)
    Add me to the list of folks with this issue. Seems like in my case rolling back to 11.G from the mixed protocol has temporarily solved my issue. As a new convert to Mac from Windows it is very annoying that my $700.00 Dell Laptop doesn't choke on wireless N and my $2000+ Macbook pro does? Don't get me wrong the MB pro if much more computer and built much better but still it makes you go huh?

    I hope that Apple is listening and working this issue as I do want to get back to wireless N speed before my MB pro is old!

    Dell is still kicking butt on Mac in this regard.

    Gonzo
  • jawbone22 Level 1 Level 1 (0 points)
    Trystero, please forgive if I mess this up. This is my first post.

    I'm interested in keeping in contact with you, as we are in similar situations. After several years with a Dell desktop PC, one month ago I added a MacBook Pro 17 and I'm having problems staying connected through my NetGear MR814v2. After successful setup and operation, my Mac loses connection to the network within anything from three hours to three days. Any time I open Safari, it's a gamble whether I see, "You are not connected..." By contrast, three PC notebook users spend considerable time here using the router with no trouble at all.

    Although Network Diagnostics or Assistant would run me through a more extensive recovery procedure, I've discovered that most of the time, I can reconnect by just rebooting the router. But again, that's something that's never required for the three PCs that also access the NetGear. One of those laptops is older and the other two are new, so age doesn't seem to be a factor.

    Apple telephone support generally wants to blame the router, but I can't get past the fact that three other notebooks have no such trouble with it. I guess I'll continue to phone them in hopes that something will change. In the meantime, this computer is of minimal use to me.
  • UCLAMacConvert Level 1 Level 1 (15 points)
    +1

    Recently bought a Trendnet TEW-633GR wireless router which does 802.11 b/g/n and if I have any combination of .n broadcasting (b/g/n; g/n), my MBP drops connectivity constantly. Full bars, but browsers won't load pages, etc. When I hold down alt and click on the Airport bars, signal strength will go from 130 to 0 and back each time I click. Something is very unstable about it. I went through my second Trendnet, I am convinced now after reading that it's not the router (but thanks to Newegg for letting me RMA the first one anyway).

    The only way I can get constant connection is to drop .n on the router spec. If I do b/g or g only, everything's rock solid. I get a constant transfer speed (from download sites) of as high as 600kbps (from sites like Apple and Microsoft), 300kbps from Rapidshare, so it's not all bad.

    It would just be nice to get .n capability since we're supposed to have it. Come on Apple!
  • Kawter Level 1 Level 1 (0 points)
    I have the same problem with a Linksys wrt350n | MBP 2.33 17".


    APPLE PLEASE ADDRESS THIS!! The only solution (if you call it that) is to restrict the router to G mode) either that or reboot every 5 mins

    Message was edited by: Kawter
  • williamsteeleiii Level 1 Level 1 (0 points)
    I've got the "me too's" to with my xmas macbook pro. It's very frustrating. I read someone say they changed their router to "g" only and that fixed the problem but that's not the case for me. I've got vista running on hp laptop with no wireless connectivity problems at all! This is an Apple problem. Hope someone from Apple is listening.
  • Stickie Level 1 Level 1 (0 points)
    Wireless & internet drop outs ongoing etc, still no fix on the horizon.

    The monkey on my back is the Netgear DG834N router, but certain its a OSX software issue.
    Still no iChat fix either, keep having to switch off and on the UPnP setting in the router.

    Come on Apple! Make me love my Mac's again!
  • JimBobCFI Level 1 Level 1 (0 points)
    This is another "me too..!" Sad to say, both my MBP and the MB we purchased from the Apple Store after Thanksgiving have this same issue. We are rarely able to both sign onto our secure WiFi together. We purchased and set up at the same time that we bought the MACs, an AirLink AR680W 802.11. router, which is our 1st excursion into the world of wireless. We have 2 older desktop PCs which are running XP, and both run quite nicely without drops on our secure WPA network. We 1st attempted a WEP, but had too many issues. I believe I will try the "g" only router for awhile. I will let all y'all know how it works out.
  • DavidRHall Level 1 Level 1 (0 points)
    /beatDeadHorse

    Ive been running my macbook pro for about 5 months now with no problems before. About a month ago I installed Leopard to run bootcamp, and then problems started to happen. Nothing too major, just broken registration for some software, so that I had to call up the companies to re-register.
    And then yesterday BAM. For no reason I can tell the connection started to crap out. I would turn the computer on (booting into XP mind you) and would not be able to access the internet until i rest the modem and router. All the other computers in the apartment work fine, including my old G5 powermac. Only mine cant seem to connect. If I reset the modem, it works for about an hour or so, then will dump me out. I a assuming from reading all this that this is a macbook problem, not a router problem or bootcamp problem? It really drives me nuts.
    Thanks for the any help.

    .ryan hall
  • LinMD Level 1 Level 1 (0 points)
    I THINK I have solved this issue - at least for me. I have a MBP and Linksys WRT600N WPA-Personal w/ AES. Ever time the MBP went to sleep it would loose the internet connection although it appeared to have a strong signal from the router upon waking.

    Got some help from apple care that involved adding a new network Location we named wireless, with changed service order to have airport first, removing the battery and resetting the controller card but it only fixed the problem for 1 sleep cycle.

    I upgraded the firmware on the router to v1.01.35 and the problem persisted.

    So today I took a close look. If you watch the network preferences window on the MBP my IP address becomes "self assigned" after waking up from sleep. The nonsense # is not a valid network address (e.g., 192.168.1.1xx).

    If this is your problem, try this fix:

    1) log on to router and under basic setup, click DHCP reservation. Then "MANUALLY add" your MBP info. If your MBP is connected you will see in the pertinent info at the top. Click add. The info will show up under DHCP reservations, click save settings.

    2) Go to your MBP setting for this location (In my case the wireless location set up above), click advanced, then TCP/IP then for Configure ipv4 select using dhcp with manual address. type in the address your reserved in the router. click ok, then click apply.

    3) Click DNS and manually enter all dns addresses and search domains (so you have duplicate lists; the ones you enter will be bold) since it seems that these get dropped and refreshed sometimes during sleep.

    You would want do all this under a new location like the "wireless" one I described above so that when you take your MBP out to Starbucks you can switch it back to Automatic and not a hardcoded IP address. This way you still have this location for home where you control the router.

    I have tested this with multiple sleep/wake cycles as well as a restart and a shutdown restart of MBP and router. It is working (so far ...).

    I'll be the first to admit that this is not an elegant solution and not the way things "should" work but it worked for me (fingers crossed0 and now I don't have to constantly restart my MBP after sleep (while at home).

    LinMD
  • Zebra1 Level 2 Level 2 (290 points)
    I hate to spoil a party and I do feel for you guys but I have Leopard 10.5.1 running on three Macbook Pros(2.33,2.4, 2nd 2.6) and they have no such issues either on "n" or "g."

    I have an Airport network with Extremes in "n" and a couple of wired and bridged Expresses on "g" so that those who can't use "n" can go on "g."

    My suggestion to all of you is to stay off "n" for those who have third party routers. The "n" specification is not finalized and different manufacturers may be implementing different versions of it, older ones or newer ones. Apple specifically recommends to watch for spec discrepancies in the newly released documents for the Macbook Air:

    http://docs.info.apple.com/article.html?artnum=307288

    and

    http://docs.info.apple.com/article.html?artnum=304197

    I move around a lot, using many wireless setups at my clients' offices, etc. I don't have problems except a minor one across all my Macbook Pros:

    When I first get to a place and wake the machine from sleep it takes a while to find wireless networks and while that is taking place the trackpad movement of the mouse gets quite jerky. Once its done looking for networks or after I choose one to connect to it is fine.

    I urge you to stop beating on Apple every time you think you have a problem. Knowledge is power and the more one knows, the less one blames sight unseen.

    Perhaps buying Airport Extremes will take care of your woes.
  • Zebra1 Level 2 Level 2 (290 points)
    P.S. I would also remove any third party wireless utilities you may have installed in your systems.
  • Cloudster Level 1 Level 1 (0 points)
    I'll give that a go and see what happens, it makes little difference whether or not you're broadcasting your SSID if someone really wants access to your WAP, but I prefer to keep it off.

    My problem is slightly different. I never lose connectivity (usually) while using the computer, it's when I wake it up. I actually have two problems. The first is my MBP flat-out forgetting my WAP. I'll have to turn off Airport and turn it back on, then it usually finds it. On rare occasions I'll have to cycle it twice. (sidebar question: is it possible to script this and put a button next to my wireless strength icon? it would save a lot of bother)

    My second is that I'll have a page not load, and apparently caching information gets convinced that it'll never load. If I refresh the page (Firefox latest version), it'll instantly go back to a page not found. Recycle the Airport, refresh page, page loads.

    My WAP is a Linksys WRT54G, I'm running 10.5.1. This has been happening since I got my MBP July '07 and continued with 10.5. I spoke with a Genius Bar guy and he said that some MBP's shipped with a slightly different wireless card and that they sometimes have problems. As far as I know, mine is not N-spec, not that I'd buy N-spec equipment at this time.
Previous 1 2 3 4 Next