Previous 1 103 104 105 106 107 Next 2,048 Replies Latest reply: Feb 4, 2016 5:23 PM by userremoved Go to original post Branched to a new discussion.
  • EmboCR Level 1 (0 points)

    Was having the same repeated drop in connectivity.  I think for me it started after updating AirPort Utility. Wasted days installing and uninstalling network hardware, changing routers etc. After reading it here, resetting the smc was the fix that worked for me.  Thank you for the posts above but more importantly the solution.

  • SlashProgrammer Level 1 (0 points)

    Same problem.  Clearly a defect but Apple wants $110 ($70 for a new Wifi card and $40 to put it in).  They should be fixing if for free.  Anyway a USB Wifi dongle can be had on eBay for $10.  So you figure out which is the best way to solve the problem!

  • joshpqt Level 1 (0 points)

    The question is more on which Wifi dongle to use? Can't seem to find a reliable one... sigh getting quite frustrating.. I already gave up on APPLe not giving a Sh*t bout our situation so I need to proceed to the next step and find a quality adapter that doesn't die every 15 minutes Ahem, "ASUS USB N10". ... sigh..

  • BeautifulJrzyGrl Level 1 (0 points)

    I had this problem ever since I bought the Macbook Pro about 18 months ago.  With my older mbp I had no problem and so it was exceptionally frustrating to have my internet going out every 5 minutes.  Anyway - it turns out the problem was with the Comcast wireless router I had.  Comcast sent me out a different router and I haven't had the problem since.  So - I would get a new router and see if that helps computer has not lost internet connection at all since I changed the router.

  • teanut1224 Level 1 (0 points)

    Ha, 105 pages.  I just got a MBP with Retina Display and just wanted to add the wifi issue still exists.  Yay!  Although I didn't know it was a pre-existing issue when I purchased last Sunday.


    I have tried the deletion of the network and password and re-adding "fix" and so far for 20 minutes it has worked.  Of course I am typing a response on a forum, so obviously the connection will drop as soon as I press "Add Reply", but I now copy all my entered text for messages, emails, etc before pressing any buttons. lol

  • BurningThumb Level 1 (0 points)

    In my case it turned out to be a cable issue.  There is a cable under the wifi card and because the MBP air vents are so big lots of dust gets in and then works its way under the cable.  Take the wifi card out, remove the cable, clean everything, and put it back together.


    A repair shop can do it for less than $40 if you are not comfortable doing it.


    Also, as an aside, if its not hardware it could be your router.  Had a PC with a similar issue and in that case I assigned a reserved IP on the routers DHCP server.  So every time the DHCP server hands an IP to the PC it hands it the same IP.  That solved the PCs problem.

  • StickySadness Level 1 (0 points)

    Oh nice, Ill try this out! My solution keeps being deleted. imma just keep posting it

  • StickySadness Level 1 (0 points)

    Thanks to BurningThumb, im going to definitely try his method.


    I too, found, my own fix to compesate for Apples lack of customer concern and/or impotence. The fix I use is tethering my cellphone's wifi to my macbook via the app "PDANET." They have apps for several different types of phones.


    *I would advise against using an Iphone, seeing as how PDANET is not available  in the appstore due to the app's interference of ridiculous tethering nonsense your mobile providers and and apple try to impose on their customers ...*


    After a couple weeks PDANET will try to try to restrict your net use through their app until you purchase the "full version." I literlly good "pda serial key" followed by my model of cell phone and the first youtube video had a serial key that unlocked the app.

  • StickySadness Level 1 (0 points)

    Don't do it! Apple had to replace mine before they wrongfully voided my warranty and it didnt even work long enough to leave the apple store



  • StickySadness Level 1 (0 points)


  • naleo Level 1 (0 points)

    I'm seeing a variation of this same WIFI issue and wondering if anyone has noticed the following;

    • when returning from sleep or powering on, MBA (late 2011) does not autoconnect
    • select the WIFI network from the list
    • complete the password dialog
    • if 'save password' option is checked, WIFI connect fails however it has connected and if you select Cancel the WIFI status indicates its connected and all is good
    • when resuming from sleep or restart same thing happens
    • if when connecting to wifi, you deselect 'save password' it connects instantly and status indicators are all good.
    • what is puzzling is that none of the passwords are being saved in the KeyChain


    So my conclusion is that the problem is not with WIFI connection, its with saving the password in the KeyChain. If I disable save password, it works fine. Its like the save process fails and so the logon process reports and error when this is clearly not the case.


    I have tried the following with no success or resolution:

    • verify and repair Keychaing
    • removed all Airport entries
    • removed all preferend/known WIFI address
    • reset the order of service preference (interestingly, Bluetooth DUN is always before WIFI not matter how many times I change it)
    • verified my disk and repaired permissions
    • removed the prefences files from various directories (such as /Macintosh HD/Library/Preferences/SystemConfiguration/)


    Everything else is working EXCEPT for saving the WIFI password in KeyChain.


    This all started a couple of weeks ago after a recent upgrade (currently OS X 10.8.2 (12C60) with all latest updates.


    Any help or suggestions would be MOST appreciated. This is driving me nuts!!

  • Salir518 Level 1 (0 points)

    My MacBook Pro is about 3 months old and I have the same problem, which is driving me crazy. Loosing the internet connectivity each and every hour is not funny at all.


    However, 105 pages of complaints and possible solutions and that is since 2008!!!!!!!!!!!!!!!!!!!

    Trying out all of the suggested solutions is time consuming, and one cannpt know which one will work and which one is safe at all.


    Why Apple does not/ can not find a solution for this issue and fix it for all the time?!!


    What is happening there?


    In any way, for sure, my next computer is not going to be from Apple! Obviously time for loosing customers has started by Apple!

  • laurenmay1 Level 1 (0 points)

    Salir -


    Here's what to do:  Call Customer Service (not Apple Care, not the Apple Store, etc.) - Customer Service at Apple Corporate Headquarters.  Demand a new computer.  I got one (look back at my posts) and others have too.  The next day!  (They do not delay when you call Customer Service at Apple Corporate.)


    They are aware of the problem and hope you become frustrated enough that you go away.  It's a strategy.  But 'the squeaky wheel gets the oil' - Call and DEMAND a new computer.  They will give you one.


    Best not to try this and that - which I did for over a year.  Go to the source that can help, and send Apple a message.


    Good luck - L

  • bettybopper Level 1 (0 points)

    I'm so sick of this issue that never gets resolved. I purchased my MacBook Pro in early 2011. I had the problem then intermittently. I still have the problem but it seems to have gotten worse. I have to be right net to my router now or the signal is too weak and drops out. As for public wifi, forget it. At UNSW I can't connect at all. Many other mac users at uni have the same problem but pc users have no such issue so it's obviously an apple problem.  Since upgrading to mountain lion it has become far worse.     How can an international company such as apple just let this kind of major issue slide?  It baffles me but it put me off purchasing another mac until the problem is resolved for once and for all.

  • habitoti Level 1 (5 points)

    Not fixed with 10.8.3 -- still loosing connectivity with 811n and Retina MBP :-(