Previous 1 105 106 107 108 109 Next 2,048 Replies Latest reply: Aug 30, 2015 4:27 PM by el.jeffe58 Go to original post Branched to a new discussion.
  • StickySadness Level 1 (0 points)

    oh yea they do that. just reword and repost it. dont let apple ceonsor or silence you

  • StickySadness Level 1 (0 points)

    No luck with the MTU change here. thanks for posting though. somesones gotta pick up these pieces and help other customers experiencing this nonsense

  • acevintage Level 1 (0 points)

    My adjusting the MTU to 1450 lasted for about two I'm back to square zero. The issue is on the old MB not my MBP. The firmware update to airport was done through my MBP. But my guess is that the old MB can't handle the firmware update. But I don't find anything threads relating to this with anyone else. The old computer just will not join my network. I'm really stumped. And my Apple Care was up a couple of years ago.

  • goncaloabq Level 1 (0 points)

    i have the same problem. Have a mb pro late 2011, 13". I never had this problem before, have my computer for almost a year and a half now, but lately it has been happening very often, maybe since the update to 10.8.3 or 10.8.2, i really can't recall. It only happens when i let my computer on standby for a while or when i'm working for some hours on it...


    but i can only solve the problem restarting my computer...that's very frustrating. i work on my computer everyday, i'm a researcher at a university and i really need my computer working fine! please help!!!

  • TheGuyintheProjectionBooth Level 2 (195 points)

    10.8.4 is in beta and should be out soon. Hopefully it will address this WiFi issue. Fingers Crossed.

  • jagbirlehl Level 1 (0 points)

    Same problem here. I am using lion 10.8.3 and it seems the conection will drop every few minutes without any indication. Have you been able to find a fix as yet?

  • acevintage Level 1 (0 points)

    I ordered a new MacBook Pro. My old MacBook was at the end of it's lifecycle anyway. I have moved the old laptop into the same room as the Airport and it seems to stay connected now that it's right next to the unit. I will continue to use it there. Whatever is causing this issue is not happening with the new Pro.

  • Bigtex106 Level 1 (0 points)

    I have the opposite problem. My new MBP (just got it a month ago) won't stay connected to the wifi for more than 10 minutes. It just randomly drops. My old white macbook never disconnects, and all of the windows laptops in our house stay connected, so I know my router's not completely to blame. I've tried every fix I could find, like changing location, MTU size, rebooting my laptop and router, deleting everything and re-adding, renewing DCHP lease, updating and changing the channel on our router, setting iPv6 to link-local, etc. What's really frustrating is that nothing I've tried helps, not even a little bit. I'm thinking of just buying a new router or waiting for 10.8.4 to come out.

  • sonofgem Level 1 (0 points)

    I had the same issue. All devices connected except my MB pro. On your wireless router go to advanced settings and make sure that you have set the wireless mode to 802.11b. The router will probably be set to 802.11b + g. If 802.11b does not work for you try setting it to 802.11g.


    802.11b worked for me 100%

  • choddo Level 1 (0 points)

    I use 802.11n @ (up to) 300Mb - no way dropping back to 802.11b speeds at 11Mb tops (for everything you realise?) is an acceptable solution. Anyway, new router solved it for me for 6 months solid now.

  • R3K Level 1 (0 points)

    I'm also having this problem since I upgraded my Internet. So naturally I thought it had something to do with my Internet service. And the fact that connection on my iPad would drop too similarly confirmed it. It was very suddle though, took few sec to disconnect and reconnect.


    So I called ATT. They came over and did their thing. (Now they messed up my moden which goes red every couple of hr. It didn't do that before. Gotta call em back!). My MBP still loses connection even when my modem is working. So I'm guessing it is my MBP and not ATT. And after googling it, I see it's a general issue. I clicked this thread and for some reason I was on page 60, instead of page 1, and luckly it had a solution. IDK if it's THE solution. But I just tried it out. Lets see if it works. Can anyone confirm it? This thread is full of problems but not enough solution.


    It's pretty frustrating when you are trying to watch a long HD video and wifi drops. You have to start all freaking over again.

  • habitoti Level 1 (5 points)

    Just upgraded my TPLink WR841N to the newly available DD-WRT firmware, and guess what? No more issues with the MBP and N-mode. Stable throughout the weekend, no drops, high speed. So it is seemingly not an issue of the MBP Wifi alone, but some strange interdependencies that might make it work or not. Glad I left the "or not" side now...

  • ekremers Level 1 (0 points)

    This is getting ridiculous, this thread alone is over 5 yrs old and still not a peep from apple.


    As I've posted earlier I started getting the same problems since my MBP was about 1 month old. Unstable WiFi wherever I went while everyone else was connecting just fine, even other MBPs. I solved it by taking my laptop to Apple's service center so many times, getting every single piece of hardware replaced to no avail, that they finally sent me a brand new one. Not a single drop now for 1+ year.


    There doesn't seem to be a software fix. Otherwise we would have known by now and we would be getting many replies "Finally, this worked for me!" etc. Moreover, the problem has been present since at least OSX 10.6. Those waiting for the next OSX to solve the problem will wait a long time...


    I'm pretty sure there is a hardware issue with some MBPs.


    I read one post a while back about a faulty wire on the wifi antenna. (

    ericfromyelm?). And he said fixing that wire fixed his problem. Anyone else try this? Did it work?

  • R3K Level 1 (0 points)

    Yeah, I don't think post on page 60 did the trick. Every time it goes to idle and I log back in I have to wait couple of sec for it to connect. This never happened before! Just lately.


    I still get this:

    Unable to connect to the Internet

    Google Chrome can't display the webpage because your computer isn't connected to the Internet.

    You can try to diagnose the problem by taking the following steps:

    Go to Applications > System Preferences > Network > Assist me to test your connection.

    Error 106 (net::ERR_INTERNET_DISCONNECTED): The Internet connection has been lost.



    Someone please shed some lights on this.

  • R3K Level 1 (0 points)

    Ok this is ******* me off! I never had this issue. Now I don't know what to speculate anymore! Is it my recently upgraded modem or my mac.


    What type of modem do you guys have?