Previous 1 109 110 111 112 113 Next 2,048 Replies Latest reply: Aug 30, 2015 4:27 PM by el.jeffe58 Go to original post Branched to a new discussion.
  • keywon Level 1 (0 points)

    Hi everyone,


    So I finally got the wifi on my 2011 Macbook Air (on 10.8.3 until yesterday) working normally again after almost five months of mystery wifi problems and scouring through these boards for a solution.  Just thought I'd share since my wifi problems made me so miserable for so many months. 


    Long story short, it turned out to be a problem with the cables on my wifi antenna.  I had REALLY believed that it wasn't a hardware problem because the wifi actually worked perfectly fine on Windows 7--but I guess I was wrong.


    A few months ago, the wifi on my computer suddenly stopped working in places where it once used to work--either slowing down to painfully slow speeds or just not connecting at all.  Also, I found that my wifi was extremely sensitive to location - it would work in my living room but not in my room, and only in very specific locations at school, even though it had worked pretty much everywhere at school before. 


    First, I knew it wasn't a router problem because I was having wifi problems in multiple locations.  I tried so many things - adding a new location, renewing the DHCP lease, deleting all of my network settings and starting fresh, changing the service order, making sure bluetooth was off, verifying disk permissions, etc. etc.  None of this worked.


    I tried doing a fresh install of Mountain Lion.  Didn't work.  I even tried erasing everything from my computer and reinstalling EVERYTHING.  Also didn't work. 


    So, convinced that it wasn't a software problem, I had read that sometimes, wifi would work on Windows but not on OS X.  So I made a Bootcamp partition and installed Windows 7.  It made me really angry when I found out that my wifi worked perfectly fine on Windows 7!  This made me convinced that a hardware issue could be ruled out. 


    Eventually, I tried downgrading the wifi driver.  This fixed things somewhat, but not completely, and I lived with that for some time.  It was a little slow in locations where it just straight up didn't work before, but I could live with it.  However, when my wifi refused to work in a new location where I really needed it to work, I put the drivers back to the way they were before I tried the downgrading thing, and went to the Apple Store. 


    I explained everything I had tried to the Genius and she got really stumped.  Trying to help her out, I mentioned that some time before this wifi problem started happening, I had gotten the top case on my computer replaced due to keyboard problems.  She offered to take a look inside the computer just in case something had happened when the top case was being replaced, even though we were both skeptical that anything could be found there given that the wifi worked fine on Windows. 


    Turns out that the cables on the wifi antenna need to be crossed in a specific way, and whoever had put my computer back together had done so incorrectly!  This had made my wifi extremely sensitive to location. She said it was a common mistake to make. 


    Just thought I'd put this out there in case other people were having similar problems!  I hope you all find solutions soon. 

  • joseilemonade Level 1 (0 points)

    I struggled with this for a long time and can't tell you exactly what I did to resolve the self addressed ip problem except that I no longer have it.  First I followed some suggestions on the internet to change the airport advanced settings in the tcp/ip section to dhcp with manual address. I did that by looking at my ethernet address which dhcp was giving me a valid address for.  Then I applied those changes but nothing happened.  The second step I took was to copy all the information from the ethernet advanced settings tcp/ip tab over to the airport tcp/ip tab by selecting manual instead of dhcp with manual address.  Then I hit apply but again nothing happened.  I read that sometimes it's best to delete the network from the preferred networks (the first tab or general tab in the advanced settings).  I did that and what do you think? Again nothing.  I was about ready to give up when I can't remember if the network configurations pop up menu appeared or it was after I hit the button for network diagnostics on the safari page.  Either way you can access the network configuration assistant by going into network diagnostics (after you hit the assist me button on the bottom of the network preferences page or by trying load a web page in safari).  Anyway it revealed that there was a change in my network configuration - my dns settings were set to manual and asked if I wanted dhcp to assign new dns settings.  I answered yes and it reconfigured the dns settings and voila...everything was back to normal.  I guess it makes sense in retrospect. If I could connect using my ethernet's ip, router and submask addresses then it wasn't a problem of connection but of dns resolution (I wasn't getting a self-assigned ip address nor a yellow light in the network preferences after manually assigning ip, submask and router addresses).  The network I was trying to connect to had its own dns settings which dhcp for some reason wasn't assigning.  Perhaps there was a change on the other end of dns settings and dhcp wasn't picking up on it or dhcp was somehow blocked by corrupted settings from before.  But anyway this is how I resolved it for myself.  Hope it helps.

  • RSWH66 Level 1 (0 points)

    Not fixed in 10.8.4 either...

    New rMBP 13 sporadically drops on returning from sleep

    No consistent solution found yet

  • gusgrave Level 1 (25 points)

    This might already have been suggested as a workaround (this thread has grown to long to backtrace), but I have had additional issues with my WiFi that might be of interest.


    The issues has not been related to my MBP but rather a new laptop and mobile device, both from the same manufacturer. Now, both the laptop and phone connect to WiFi, sporadically drop internet access, not WiFi access, still showing full signal strength but are not able to access the internet.


    Now, unlike some manufacturers, this company has officially confirmed WiFi issues with their devices. The problem is apparently related to the AES encryption, not the encryption itself but the storing of files related to the encryption router-side. A workaround for this issue has been suggested and seems to be working for both the phone and laptop, at least for the last 48 h or so.


    Exchanging the encryption from AES or AES/TKIP to just TKIP in the router settings allows both laptop and phone to have stable internet access. (Just to be clear; PC and other manufacturer, no guarantee for MBP)


    This is of course not a optimal way to "solve" this issue and a router-change will have to be made, but for now it works.


    Thought I'd post this, just in case. My MBP WiFi issues was not "dropping signal" but rather an inability to connect so I cannot say anything about this solving signal drop issues, but just in case.

  • matthewyau89 Level 1 (0 points)



    I'm also experiencing similar problems with my MBP. And from my experiences, I would say that it is likely to be related to the laptop. My PC works fine wired and wirelessly. My sisters Windows laptop also works flawlessly on wireless connectivity. And furthermore, the disconnecting issues are eradicated when I connect my MPB via ethernet cable.


    I have yet to work through this thread and it has become obnoxiously large but some of the solutions I have tried didn't seem to work. I just hope that it is a software issue and not a hardware issue.


    Anyway, my problem is that it will disconnect randomly and can often be stubborn to find connection again. I will get back in without wasting too much time but it's certainly an inconvience one can do without, especially with deadlines looming.


    I have alos tried connecting to a mate's internet and the same issue arises - random disconnection and stubbornly difficult reconnection. With such a large thread, I'm surprised the issue hasn't been attended to with more endeavour by Apple.


    Let's hope a solution can be found soon.

  • jackiejacqueline Level 1 (0 points)



    After combing through this interminable thread and trying solutions, the one that worked for me for a while was deleting the network entry in Network Prefs and recreating it.  For a couple of weeks, all was fine.


    Now I can't connect to my router -- I end up with a self-assigned IP address -- even though Tivo and my iPhone have no problem connecting through the router via wifi to the internet.


    I found gusgrave's comment about encryption interesting because I *can* connect with stability to a neighbor's unprotected wifi.


    Steve Jobs is spinning, and I mean spinning, in his grave.

  • laurenmay1 Level 1 (0 points)

    Dear Jackie -


    I know (Steve Jobs spinning).


    I wonder if the excellence of macs died with him?  It seems like Apple is becoming mediocre.  Sad.

  • gusgrave Level 1 (25 points)

    I also think this touches on an interresting point. First, we have to remember that network issues are common and that the root of individual issues can have different origins. This is just my personal experience and opinion.


    For me (and I know this sound ridiculous) the issue was MBP-router communication issues, 100%. This originating from, as I perceive it, software related issues. I checked my logs during the failed connection attempts and saw that I was receiving "bogus" country-codes, like X3. This seemed confusing to me, so I checked my language settings. I had modified some setting since I write papers in English (which is not my native tongue) and therefore need to use "." instead of "," as a decimal separator.


    This simple change gave me a "Custom" location. So, switching back to my "default" location (appropriate for my geographical location) solved the connection issue... I got the correct response and correctly identified country code with functional channels. I know this sounds like a big load of BS, but I got connected and have been ever since.


    This is obviously strange behavior. The encryption AES/TKIP issue was related to another manufacturer, but it sounds like similar issues as some have had here. Further, some have indicated that switching WPA/WPA2 to WEP solved issues in "understanding" the some passwords. Can't remember the detail, but adding or removing some special character (think it was $) allowed connection establishment. So, excluding cable-crossing, broken WiFi cards/antennas and any other (but equally valid) hardware issue, I think many issues originate from software. Some routers (like mine) works with other units, hence the routers are fine... Some computers (like mine) worked with open/unprotected networks or WiFi at other locations (randomly), hence the MBP is fine, when it actually manages to connect.


    Best regards to all!

  • laurenmay1 Level 1 (0 points)

    Dear Gus -


    I appreciate your explanation.


    But WHATEVER the cause, the result in inexcusable.  INEXCUSABLE.


    We should not have to become saavy in areas that relate to computer connection.  In effect, Apple has stolen precious life (time) from many of us.  And in my opinion if Microsoft can do it, Apple should be able to do it better, as the products are roughly 3 times as costly - sometimes more.


    Just my humble and aggravated opinion.  Best - L

  • gusgrave Level 1 (25 points)

    Preaching to the choir!


    I agree 100% with you! As stated, just sharing thoughts and experiences, hoping it might help someone.


    There are no excuses for pushing less them functional products, but I guess this is the new direction of things. My new iPhone has had more issues than any other phone I have ever owned or heard about....

  • jackiejacqueline Level 1 (0 points)

    La la-la la --  that's my attempt at showing that I am part of the chorus, too.


    OK, but ***:  I was unable to connect *at all*, and I switched my encryption from WPA2-PSK to "WPA-PSK + WPA2-PSK" and am now connected.

  • prb238 Level 1 (0 points)



    How can this be?  Previously had a Dell laptop & no conncetion issues.  Just retired & treated myself to

    a $2200+ Apple laptop & can only connect on the 1st level of my house.


    I am not tech savy, nor have any desire.....Guess I'll take this up with Apple!

  • mmagidson Level 1 (0 points)

    Same here, brand new Mac and I get spurts of dropped calls on Skype because of this. This thread goes back to 2010. 3 years and no solution?

  • vServo Level 1 (0 points)

    How hard is it to make the damned wifi work.  Long time customer and next computer purchase is going to be pc for sure. I'm sick and tired of having to reset my wifi 30 times a day to use my ipad or MacBook Pro while my roommates never have a single issue with their pcs.  MacBook Pro my *** its a MacBook joke

  • MBremer Level 1 (0 points)

    I have a 2012 MBP Retina 13" with the same issue (dropping of WiFi every couple of minutes).


    I have changed the router several times as I thought it might be a signal strength issue from the house through to me office 20m away from the router.


    The signal strengh shows 100% (4 bars) in my office but it drops the network (Netgear N600 router). I have tried changing the channels etc to no avail.


    I have now been working all afternoon and evening in the house (direct line of sight to the router), on the 5G as well as 2.5G channels and everything is working fine.


    Could it be that the MBP shows good signal strength in the office but in fact it does now like working on the "perifiry" of the range? By the way, where can I find the signal strengh utility that was removed with the latest version of OSX and why did they remove it?