Previous 1 113 114 115 116 117 Next 2,051 Replies Latest reply: Apr 2, 2016 3:49 AM by lvange Go to original post Branched to a new discussion.
  • Agatha Nolen Level 1 Level 1



    I've had a MACBOOK PRO since Sept 2010 and an HP 4780 wireless printer (that I bought from the APPLE STORE). I am running high speed internet and have had CONSTANT drops where i have to turn off the network and turning it back on again to print wirelessly. I tried rebuilding the network, different channels, deleting files and nothing worked. Until now.

    Six weeks ago a friend of mine upgraded the memory from 4GB to 8GB as per Apple instructions. He says that there should be NO connection between the memory and the wireless drops---BUT, I haven't lost a connection ONCE since!!! And it connects automatically when I the laptop has been closed or is idle.


    It was an incidental finding....but it worked for me! Has anyone else tried upgrading the memory in the MACBOOK PRO to see if that fixes the problem?  (I agree the problem is with the MACBOOK PRO as my PC never has lost connection to the printer).

  • laurenmay1 Level 1 Level 1

    Dear 2Dutch - and others on this thread:


    It's been 13 days  -- 13 DAYS !!  -- and after implementing the reccommedations 2Dutch made below - my MBP has not lost the connection once.  Not once.  THANK YOU  !  So far, this is the best recommendation from anyone, anywhere. L




    Open Finder and navigate to this directory:

    /Library/Preferences/System Configuration


    Delete these files:




    Restart machine.

  • TheGuyintheProjectionBooth Level 2 Level 2

    OK, MacBookPro4,1; running 10.8.4.Tried the file deleting method: Failed at start up. Thought that since it worked flawlessly for a long time and stopped when I changed the memory back to 4GB from 6GB (won't do 8) since it was over heating which I thought was contributing to the screen flicker/lockup problem and the WiFi dropping, it failed too. Although when I take it to the office (Pub) on jump on our WiFi, Public/Guest G & N, Private/Back of House G & N, it jumps right on and I have no problems. Then when I get home it works for a while then starts dumping. Now it dumps whenever I try to surf. But comes back on its own not long after. I can also, now, do Option click on the WiFi icon and 90% of the time have it work and can see all the available networks.


    So . . . mine has been as it pleases with no rhythm or reason.


    Composed on my G4 Dual 1.42 PPC running 10.5.8 Work Horse.

  • TheGuyintheProjectionBooth Level 2 Level 2

    Deleted Dup Post. Post said it timed out and failed. Guess not.


    Message was edited by: TheGuyintheProjectionBooth

  • TheGuyintheProjectionBooth Level 2 Level 2

    Will strangeness ever cease? I spent the day at a clients club using their WiFi. I was scared to death that I would lose connectivity and there is no way to hardwire. But I jumped on and spent all day moving files, telecommuning, phone calls, VTCing and not once did the connection drop. Then back at base, within 10 minutes, dead. It's kinda like it wants to be taken places and it will behave. But at "home", it's a bad child. Also I have noticed that if I hardwire to the network, the WiFi comes up. Disconnect, it goes away.


    This is just plain nutz!

  • jperezb Level 1 Level 1

    I have the same issue with my Macbook Pro Retina model A1398. I'm from Chile.

    My wifi connection is loosing in random minutes. I used almost all the suggestions in this thread, but none worked.

    I'm worried, because Apple fixed this issue for the new Macbook Air, but not for Macbook Pro.


    Waiting the Apple reply...

  • acevintage Level 1 Level 1

    I can't believe the issue has been documented since 2011 and Apple hasn't done anything about this!


    This was occuring for me on an old 2007 white MacBook. It had been running just fine for years, and then after one of my upgrades, started dropping off the network. I ended up buying another MBPro and giving the white MB to my son. Just after I did that, laurenmay1 posted this message:


    Open Finder and navigate to this directory:

    /Library/Preferences/System Configuration


    Delete these files:




    Restart machine.


    IT WORKED! and my son can now use the old MB without any issues.

  • Fragilegorilla Level 1 Level 1

    I tried everything suggested here, deleting systempref files, changing channels, every security setting enable/disabled, firewalls on/off, MTU to 1450, deleting and making a new network etc....etc....this has been driving me CRAZY!


    Finally I seem to have fixed it.


    I did two things, one or both fixed it for me so I'm leaving them both as is.


    1) I unchecked  the "Use Passive FTB mode" box, in the network>Advanced>Proxies.


    2) I believe this next thing is what really did it. I checked my MTU. It turns out my lowest MTU that returned a ping was 1250 and I had a "message too long" at an MTU of 1260. You then have to add 28 to the final number so my MTU was literally just under 1280 (the minimum).


    To test your MTU you go into terminal (click on top right corner and type in terminal press enter).


    Then type (caps are important) or just cut and paste this:


    ping -c 2 -D -s 1472


    The number (1472 is the MTU your testing) the web address can be anything. Keep changing the number in that line.


    You'll get one of two responses each time:

    1) "ping: sendto: Message too long" that means the MTU is too high so you'll get problems of wifi dropping. So drop the MTU number in the command and try again.


    2) or you'll get something like "1480 bytes from returned..... " with a time in ms shown. That means the MTU is OK and your ping was returned so raise the MTU in the command.


    Keep changing the numbers, eventually a small change in the number will move you from the "message too long",back to a ping response and vice versa. Pick the number that got the ping response and add 28. Set that as your MTU.

    Network>Advanced>Hardware. Set MTU "manually", "custom" type in your number.


    For me the value was 1250 = ping and 1260= message too long. Adding 28 to that 1250 took me to my optimal MTU.


    The problem has now gone away.

  • Fragilegorilla Level 1 Level 1

    Actually when my MTU was set at 1252 I got a ping return and at 1253 I got message too long so I was exactly at 1280 optimum MTU after adding the 28.


    If your MTU is lower than 1280 there is apparently a way to reduce it further but as mine was right on the line I didn't investigate how.

  • TheGuyintheProjectionBooth Level 2 Level 2

    Your concept is interesting, but your math/the way you are describing the numbers makes no sense. What ended up being your "optimum MTU"? 1280? I just ran through your terminal sequence and mine fails at 1473. 1472 = ping, 1473 = Too long. Taking it way down = ping. So I am at a "lack of understanding" loss.


    Any assistance will be greatly appreciated.


    Thank you.

  • Fragilegorilla Level 1 Level 1

    Yes, mine pinged at 1252, and I got a too long message at 1453.


    The page I was reading that described the MTU discovery process says you then add 28 to the number where you get the ping, I don't know why, my final MTU was exactly 1280. It has worked flawlessly since. The site also said having an MTU too high causes the problems we've all been having.


    Based on what you got, if you had a too long message at 1473 and ping at 1472 your final MTU should be the 1472 + 28 = 1500 but that's the default.


    Maybe it was the uncheking of the passive FTP mode box that fixed it. It's the only other thing I changed.

  • Fragilegorilla Level 1 Level 1

    Here is the link to the page I got the MTU discovery method from:


  • Fragilegorilla Level 1 Level 1

    That first line should be:


    "Yes, mine pinged at 1252, and I got a too long message at 1253."

  • TheGuyintheProjectionBooth Level 2 Level 2


    Thanks for the clarification. Then add 28 to the last working number. Now that makes sense.


    And another strange networking thing . . . up until recently both my 2003 G4 Tower and the MBP would get an IPv6 address. Now only the G4 does. If I enter it manually it works, but will not get it on its own anymore. This is the beast that just won't die. Now if I can get this and the screen flicker dealt with, I'd have a working machine.


    Just had to reboot. WiFi came up for a couple of minutes and when I pulled the Ethernet and put a "load" on the WiFi, it dumped. The page I tried to surf to failed. So I plugged the Ethernet in and the page came up and so did the WiFi but only connecting at 117Mbps. It use to connect at 270 nominal. Pulled the Ethernet, hit a link and the page came right up. Uhp, it's gone now. Plugged the Ethernet back in and . . . IT'S BACK! It says it's connected at 104Mbps, but it's not working. Gone now.


    Anyone for a game of "Whack-A-Mole"?!

  • clwill00 Level 1 Level 1

    I am having this issue with a new Macbook Pro Retina (early 2013) edition.  After several hours, the wifi icon shows I have still have it, but I don't.  I turn WiFi off and back on, and voila, everything works.  But of course Time Machine fails, and it sure is frustrating.


    I'm using Apple's Airport Extreme WiFi, so it's not an access point issue.  I have tried the various suggestions above.  None of it works.


    Seriously, it's been years, does Apple give a hoot?