4 Replies Latest reply: Jan 23, 2008 3:25 AM by IanB
IanB Level 4 (1,370 points)

My ISP (BT Yahoo!) allows you to create disposable email addresses as an anti-spam measure. When you use their web client to send an email from one of these disposable addresses, then your primary email address is not sent. Any emails to one of these disposable addresses get directed to the inbox of the primary account.

How do you set the Mail application up to send and receive emails using one of these disposable addresses?

iMac 17" Flat Panel, Mac OS X (10.5.1)
  • Pascal Bouvier Level 4 (2,880 points)
    go to mail>preferences>accounts>account information and in the email address field put a comma after your mail yahoo address and add these disposable email addresses, all separated by a comma of course.

    you will then be able to choose from these aliases when creating a new email.

    hope this helps
  • IanB Level 4 (1,370 points)
    Hi Pascal,

    Thank you for your response and suggestion. However I already tried that and the primary account name gets included in the long headers. I think that is because authentication with the SMTP server is still via the primary account (the disposable addresses don't work).

    Any other ideas?
  • Pascal Bouvier Level 4 (2,880 points)
    i see, then here is another thought... create a new email account for each alias but give a bogus incoming email account, just force create the account, use the outgoing server of your main email account, for each of these "alias" accounts. then for each of these "alias" accounts make sure that you unselect "automatically check for mail" in mail>preferences>accounts>advanced that way you will be able to send, and you do not care about receiving from them, as i guess you will be receiving from your main account. i think if you use this workaround, you will get a sign next to your inbox, stating that there is a problem with that "alias" inbox, not to worry but cosmetically annoying.

    hope this helps
  • IanB Level 4 (1,370 points)
    Hello Pascal,

    Thank you for continuing to try and help.

    I have already tried that. Unfortunately the SMTP server only accepts the primary email address for authentication and, when you look at the message, you find it in the long headers so it defeats the object of using a disposable address.

    You would think that my ISP would be able to help but unfortunately their support service is about as much use as a chocolate teapot.