10 Replies Latest reply: Jan 26, 2008 6:56 PM by Winston Churchill
Rpk Level 1 (35 points)

I recently moved my ATV over wireless to Wired ethernet. Now my Itunes is unable to detect the ATV device. Basically my setup is my DSL modem is connected to Linksys router which dishes out IP's for all my devices. ATV by itself is fine, it connects to the internet without any issues. Reading through similar issues reported in the forum it looks like one needs to

1. Enable ports UDP 5353 and TCP 6389 on my router
2. Enable the same on the mac
3. I also included itunes in Set access for specific services and applications firewall setting based on an earlier thread but i still don't see the Atv under devices.

4. http://docs.info.apple.com/article.html?artnum=305003 mentions that UDP port 5353 on the firewall. How do i enable this?

I dont know how to enable these ports on the Router. I see so many options but dont how to configure these ports

Any help is much appreciated


Mac Mini, MacBook Pro, Apple TV, Ipod Photo, Mac OS X (10.5.1)
  • Winston Churchill Level 10 (93,195 points)
    If your mac was previously seeing the tv over wifi then the relevant ports on your mac must already be open.

    Have you tried restarting everything (tv,mac and router) since you swapped over to ethernet.
  • Rpk Level 1 (35 points)
    I just learnt how to enable ports on the Linksys router. Learnt that "Port range forwarding" is the same as opening ports in the Linksys router. So i enabled these ports and used the IP address of the ATV. I shut down DSL modem, Linksys router & ATV. Waited for 30 sec and then started them all. Rebooted my Mac also. Opened up Itunes and i still don't see the ATV under devices.

    I do have the check for looking for ATV devices.

    When ATV was working over wireless it was synced to my macbook Pro. I have since moved my itunes library to my Mac Pro and it is Itunes 7.6 in my Mac Pro that is having the problem recognizing the ATV.

    I think i have tried every recommendation out there. Is there anything else that i can check? I am baffled as to why it is not still not showing after doing all this.
  • Winston Churchill Level 10 (93,195 points)
    Agh, you didn't say you'd moved the library to another mac. Try selecting 'change library' from te syncing option on the source menu of the tv and entering the pass code again.

    But that now opens up the possibility of incorrect network settings on the MP, since this is not the mac that worked over the wifi network.
  • Rpk Level 1 (35 points)
    Well under Sources->Synching i see only "Turn on Synching" and when i select that it gives me a passcode. I dont see any library to select.
  • Rpk Level 1 (35 points)
    Both the Mac Pro and ATV are in the same subnet. They have the same subnet mask and router IP. The IP on ATV is and the MAc Pro is Both are configured for DHCP.
  • Winston Churchill Level 10 (93,195 points)
    Yes you won't get the option to change your library while syncing is off, is there any reason you have syncing off. Are you aware that in streaming only mode unless you have selected your library as the source from the tv the tv won't show up as a device in itunes.
  • Rpk Level 1 (35 points)
    I don't follow. What i did was i reset ATV to factory settings. (I wanted to start from a clean slate when synching to my Mac Pro hence i reset it to factory settings.) I then downloaded the latest update for Youtube and it did it successfully. This is where i am now currently.
  • Winston Churchill Level 10 (93,195 points)
    OK that clears up some of my questions, but whilst it may well not be your issue are you aware that a streaming only tv only shows up in the devices list in itunes when that itunes library is selected as the source on the tv.
  • Rpk Level 1 (35 points)
    Got it. Well i finally called ATV support and the tier 1 tech basically said i have done everything he would have asked me to do so he put me to tier 2. After waiting for a long time i was able to get to tier 2. When i described the problem to him he said there were many reports coming in with itunes 7.6 not recognizing ATV. Apple is currently investigating it i believe.

    Since ATV worked over wireless with my Mac Book Pro originally he wanted me to try it and also since my Mac Book Pro had itunes 7.5. Well after changing my connection from wired to wireless and doing another factory restore, itunes 7.5 on my mac book pro saw the apple tv device.

    Basicially what i am seeing is : 1. Mac Pro with itunes 7.6 and ATV over wired is not working 2. Itunes 7.5 and ATV over wireless is working.

    He asked me to run a tool to gather some info and i have sent it to him. He said he will get back to me after he investigates the logs. I shall update the thread with the resolution (hopefully)
  • Winston Churchill Level 10 (93,195 points)
    I guess you've been sent a little application called 'Capture Data', I wish you luck with your endeavours.

    I've been on this forum for around a year now and seen quite a few itunes upgrades, each time there has been a flurry of problems just like yours and to my knowledge they have basically turned out to be as a result of corrupt instals (often caused by installing over damaged files) and not buggy software. The introduction of 7.6 has actually produced the least amount of issues of all the upgrades so far. I don't want to put a damper on your confidence that  will get back to you and solve your problem but I'd be surprised if this was a fault with 7.6, although this is just my opinion.

    Personally I'd continue to try to resolve this yourself.