1 Reply Latest reply: Jan 29, 2008 7:11 AM by Lino Gambella
Lino Gambella Level 1 Level 1 (0 points)
Hi,
Since some days i started to experience some strange behaviours of my MBPRO keyboard and touchpad.

It all started with random funcion key feedbacks (for example sometimes i see the eject bezel overlay even if the eject key was not pressed), but it was no big deal, i thought it was me doing some other key combination by mistake and i just let it go...

Yesterday the problem has become more complex, suddenly the keyboard and the touchpad are losing control, randomly, for some seconds, i skip characters and even touchpad movements, seems like the usb subsystem is freezing for a moment, but that's impossible since i tried with external keyboards and mouses and they work fine, aswell as my wireless keyboard and mighty mouse, maybe it could be just the usb controllers for touchpad and keyboard?

I called the customer care and they told me that it's for sure an hardware problem, even because i tried to reproduce the behaviour booting the leopard install dvd and i had the same problem there.

The question is: anyone is experiencing the same thing? If yes, what did you do? How long did it take for the customer care to fix your computer?

Thanks in advance and sorry for my bad english...

PS. here's something that came up on my system.log:

+Jan 28 10:58:37 terrorist kernel[0]: USBF: 38.993 [0x480a900] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 2 of hub @ locat+
+ion: 0x5d000000)+
+Jan 28 10:58:37 terrorist kernel[0]: USBF: 38.993 [0x480a900] The IOUSBFamily was not able to enumerate a device.+
+Jan 28 10:58:51 terrorist kernel[0]: USBF: 52.731 IOUSBCompositeDriver[0x4829a00](Apple Internal Keyboard / Trackpad) GetFullConfigDescriptor(0) returned NULL+

Message was edited by: Lino Gambella

MacBook PRO, Mac OS X (10.5.1), 15"