Previous 1 2 Next 15 Replies Latest reply: Apr 16, 2008 6:35 AM by JTF
Tim Baker Level 2 (280 points)
For the past couple of days, after doing a few searches in the Google search bar, it suddenly stops working and I get the following error message instead of Google:

Safari can’t open the page “” because it can’t find the server “”.

If I type in in the address bar, I get the same thing.

I'm able to search Google in Firefox and visit the site no problem.

This is VERY strange. Any idea what it could be? I reset Safair (emptied cache, cookies, etc) and doesn't fix it.

MacBook Pro, MacBook, Mac mini, iPhone, Mac OS X (10.5.1)
  • Tim Baker Level 2 (280 points)
    UPDATE: Okay, now Google started working out of nowhere, but I can't access my .Mac gallery on Safari, only on Firefox. It was working on Safari about 10 minutes ago and now I get that same server not found message.

    Something is definitely going on here. Any ideas?
  • DragonWizard27 Level 1 (0 points)
    I am having the same problem.. I have done everything I cn think of and nothing works.. Dumped the cash and the preferences and cookies and everything I could find that had to do with Safari and reinstalled.. It still can NOT find certain sites because it can't find the "server".. when it lists the server that it can NOT find it gives the URL but just leaves out the "http" part of the address.. Something in Safari is screwed up.. an answer on this would be greatly appreciated.. (or am I just talking to myself here)...
  • Tim Baker Level 2 (280 points)
    It's the strangest thing. For example, I was updating my .Mac gallery page, and I'd hit refresh a few times and it would load fine, then it just stopped working. I'd quit Safari and restart it...still wouldn't work. I'd empty cache & cookies...still no luck. It worked fine in Firefox though.

    After like an hour or so later, it started working in Safari again. So far I've had this issue with Google, .Mac Gallery and Flickr. It just stops working, says it can't find the server, and nothing seems to fix it.
  • Norman Harris Level 3 (560 points)
    I think it is Google. Couldn't open in Safari or Firefox. Now I can. Google maps wouldn't work but now functions properly.
  • Chod Lang Level 1 (25 points)
    It's the strangest thing. For the past two days neither the google search window in Firefox and Safari work and I cannot connect to in either browser. I can, however, connect to google from my mobile phone (Treo 700p).
    Anyone have a clue as to what's going on?

    p.s. all my bookmarks work fine.
  • DragonWizard27 Level 1 (0 points)
    I removed a thing called "Safari Enhancer and the folders (all of them by hand and into the trash) in Caches in my Users folder library. I also got rid of "Peer Guardian" and the Safari Preferences as well.. When I did a restart and checked Safari I could not only get to Google but I could download from a site that it had refuse to connect to.. All is now well with me... If you have any of these programs on your computer try dumping them and like I did remove the Safari cache folder by haaand to the trash.. May this work for you as well as it did for me.. I am happy again as I can now do searches without having to resort to a different search engine.. It can now find the google server again...
  • Tim Baker Level 2 (280 points)
    I don't have any of those programs installed and still have the problem.
  • Ted Harper Level 2 (325 points)
    Can you take your Mac somewhere else (next door neighbour using a different ISP, or to work or something) and use the internet connection there, and do you get a different/better result there?

    It sounds like you've checked all the "obvious things", and are still getting sites not found or really slow to resolve (that is when the blue progress bar in Safari stops about where the first w in www in the address bar is before the page starts to appear).

    If so, something you could try fairly quickly and which has brought relief to rather a lot of people with similar-sounding issues, is you could try changing the DNS server settings on your Mac to use a different provider. NB: I'm not sure what it is that makes the difference, but something seems to have been changed in OS X which makes the Mac work badly with some ISP's DNS services, even when a PC (or a Mac running an older OS X version) is still working just fine on the same network and using the same DNS. I use the DNS servers from, which are and, but people have had good success with other providers too, I just can't remember the names or addresses offhand. Try specifying those in the network configuration on your Mac itself, or on your router if you want to change it for all machines on your network, and see if it suddenly fixes those issues for you.
  • Tim Baker Level 2 (280 points)
    If it was a DNS issue, wouldn't that mean that Firefox would be unable to resolve the website as well, because I'm having no problems with FF.
  • Ted Harper Level 2 (325 points)
    Tim Baker wrote:
    If it was a DNS issue, wouldn't that mean that Firefox would be unable to resolve the website as well, because I'm having no problems with FF.

    I agree with you from the common-sense standpoint, but it definitely seems to have been the case for quite a few people in here running 10.5.x that they DO get different DNS-related behaviour depending on which app is making the request. Doesn't make a lot of sense to me, but it does seem to be reported fairly commonly that way. Try it and see, then we'll both know if I'm blowing smoke
  • rockoluvsmelba Level 1 (0 points)
    I've been having similar issues. I can't access certain websites but it's not just on Safari, but Firefox as well. One of the many sites is (I'm car shopping) and it was working about 2 weeks ago on my computer and I haven't made any changes as far as firewall, upgrading, router, etc and now it's not working. My other mac and ipod touch can access the site with ease. Occasionally the site will load but then I can't get anywhere from the home page without it saying it can't find the server. I've reset safari's and firefox's history, cookies, cache and still nothing. I've also gotten rid of Peer Guardian and I'm kinda running out of ideas here. BTW I'm using Safari 3.0.4 & Firefox on a PPC mac running 10.4.11. If there's anybody who can think of anything, I'm sure others as well as my self would greatly appreciate it.
  • rockoluvsmelba Level 1 (0 points)
    So I just tried setting the DNS to the serviers Ted suggested and every site that wouldn't load is now working. Thank you SO much for bringing those up! =)
  • timzter Level 1 (0 points)
    I bought my iMac 24" in Dec 2007 and I, too, am having issues with connecting to either or on either Firefox or Safari. However, I can connect to or Weird! I am connected to the Internet on via the iMac's Wi-Fi. I clicked on System Preferences-->Network and selected the wireless connection and clicked on Advanced. Under the DNS tab, I see 3 IP addresses:

    The first one is my router's IP address but it is greyed out and I can't remove it nor move it down to make it a lower priority. The other two IP addresses are the openDNS addresses but I never added them myself. I learned about them from this topic/thread. I would like to make the openDNS addresses the active ones but I cannot delete the address or move. The only way I can make it disappear is to disable my AirPort connection, but then if I do that, I won't have Internet access at all (catch 22!). Any way to solve this? It seems that there are many google links on this issue but there is not one clear, working solution.
  • mangofever Level 1 (0 points)
    I had a similar problem with Googlemail, Ebay & a couple of other sites with Safari - I came across the following on TalkTalk's FAQs, which appears to have done the trick. I had also previously also added the additional DNS servers which are mentioned elsewhere on the thread, but don't know if this has made any difference.

    +I'm having problems viewing certain websites e.g. Hotmail.+
    +If you are having problems viewing certain websites such as Hotmail, MyEbay or secure online banking websites please follow the steps below if you are using a TalkTalk Wireless Router. If you a are using your own router please set the MTU value to 1432 and consult the manufacturers manual for how to complete this.+

    +Open your internet browser (eg. Safari) and type this URL in the top bar (where you'd normally type a web address): (Remember, you don't need to type 'www')+
    +Use the word admin when prompted for both username and password, click 'OK'+
    +A page titled 'Huawei Echolife HG520' should appear. Select 'Basic' on the left menu. On the drop down menu, select 'WAN Setting'+

    +Please scroll down and fi rstly change the TCP MSS Option to 0 (zero) followed by the MTU option to 1431, as per the screenshot shown below. Once both of these changes have been made scroll to the bottom of the page and click on the 'Submit' button.+
Previous 1 2 Next