2 Replies Latest reply: Apr 2, 2008 5:16 PM by StoneSoup
meadj01 Level 1 Level 1 (0 points)
2 days ago my wife's Mail refused to open, and this has continued. Every time she runs Mail, she gets this error:

Mail can’t open because you don’t have the necessary permissions to change the folder where it saves information.
Mail stores information in Macintosh HD:Users:eliza:Library:Mail. If this folder is on your computer, use the Get Info panel in the Finder to change your permissions for this folder to “Read & Write.” If this folder is located on a network server, contact the server administrator. After your permissions are changed, open Mail again.

I tried following the directions in the Finder, and I applied the permissions to the enclosed folders. That did not fix the problem. I then tried the brute force method in Terminal, involving the command chmod 777 ~/Library/Mail.
This did not work either.
She can now only access her mail on the .mac web site.
Please advise.

iMac G5, Mac OS X (10.5.1)
  • imac007 Level 3 Level 3 (860 points)
    You can reset the ACL's and permissions for the home directory with a utility on the install disk.
    You need to boot to the install disk, select English and then from the Utilities menu choose Reset Password.
    You can then select the volume and the user for whom you are wanting to reset the settings.
    Then select the reset option and reset it at the bottom of the window.
    It will then reset the home directory top levels.
    It is done when done is grayed out and the volume and user are selectable again.
    Quit the program and restart the computer.
    Then go to the hard drive icon and open it.
    Double click on the Users folder and click once on the affected account home folder.
    The go to File>Get Info.
    Go to the Sharing and Permissions area at the bottom and unlock the lock.
    Then click on the gear like icon at the bottom and "apply to enclosed".
    Then test Mail.
    This might not be the solution but it should restore the home directory permissions to normal.
  • StoneSoup Level 1 Level 1 (45 points)
    This problem with Mail just bit me this morning.

    The steps below resolved my issue. Thanks, imac007!

    Regards,
    StevenC