Previous 1 2 Next 15 Replies Latest reply: Apr 9, 2008 6:37 AM by Andrew N
JoeAt Paste Level 1 Level 1 (0 points)
I have four weird things going on with Mail.

1) When I am composing a message, it saves drafts every few minutes. If I am writing a long message, I can end up with a dozen drafts in various stages of completion. They do not go away when I send the message.

2) The number of drafts will always be one greater than the actual number of drafts in the folder until I look at the contents of that folder. Then it will go down to the actual number.

3) When I send an email, it appears in the sent folder as unread, with a blue dot next to it.

4) I have to quit and restart several times a day because mail seems to hang up. I generally realize it is happening because I see email on my iphone that is not in mail.app. When I restart, the messages appear in the inbox.

I have two POP accounts that are joined together into an IMAP account at Fusemail. I'm just reading the fusemail account, so everything looks like IMAP to me.

Anybody else seeing this kind of behavior?

Joe

Powerbook 17, Mac OS X (10.5)
  • Honolulu Level 3 Level 3 (950 points)
    This is what Mail Help has to say:

    Saving draft messages
    If you’re not ready to send a message and want to finish later, you can save it as a draft. Mail also saves drafts automatically a few seconds after you start to compose a message.

    To save draft messages:

    Click Save As Draft in the toolbar, or choose File > Save.

    If you quit Mail and have a message open that has not been sent, Mail saves it as a draft automatically.

    To reopen a draft, open the mailbox where you store drafts and double-click the message.

    By default, your drafts are stored in the Drafts mailbox. For IMAP mail accounts, you can choose to save draft messages on the computer you’re using, or on the IMAP server so you can see the draft messages using other computers. To change this setting, open the Mailbox Behaviors pane of the Accounts pane of Mail preferences.

    I know this isn't much.
  • erikselz Level 1 Level 1 (0 points)
    I have issues similar to Joe's. #1-2 definitely, #3-4 periodically. Have attempted to "Rebuild" to no effect. I have two IMAP accounts linked together in one mailbox.
  • reunited Level 1 Level 1 (0 points)
    I too am experiencing the exact same issue. The issue did not appear until I changed my mail account from POP to IMAP.
  • Brian Ibbott Level 1 Level 1 (0 points)
    Yes, I'm absolutely seeing the same behavior on my Mail.app as well. And it also seemed to start when I converted my POP email to IMAP.
  • antg4 Level 1 Level 1 (0 points)
    I've heard this has something to do with fusemail using "Sent Items" as the name of the sent folder instead of "Sent Message". I've just signed up with them and seen the same issue. The sent messages are unread in both mail.app and in webmail.
  • antg4 Level 1 Level 1 (0 points)
    I've been looking around.. apparently for the drafts issue, this is an OS X problem. I've seen the same problem with mail.app talking to an exchange server and with fusemail. I can't remember if I saw the same problem on mediatemple.net so it might be an issue with the server / client combination.

    The recommendation until it's fixed is to tell mail.app to store your drafts locally. This shouldn't present many problems, unless you want to start an email at work in mail.app and then finish it off later at home.. I suppose you could either just email the draft to yourself or create an "incomplete" folder or "server drafts" folder, where you can copy the draft...

    I've sent a support request to fusemail to see if they have any info on the unread sent messages issue. It's a stange one because it doesn't seem to happen with every e-mail I send..

    ant.
  • antg4 Level 1 Level 1 (0 points)
    Ok, I heard back from Fusemail support, here's the deal:

    1) Sent items are treated differently because Fusemail treats the sent items folder as a subfolder of the inbox.
    To avoid it, they recommend creating a rule to store all outgoing mails in the sent items folder, and mark them as read:

    Apply rule to: Outgoing Email
    Select Condition to Add: For all messages
    Select Action to add: Move it to the specified folder (Sent Items)
    Mark as Unread


    As long as you use fusemail as your SMTP server and have server authentication enabled, this rule will work.

    As for the issue with drafts, their system is designed to hold draft messages once they're saved on the server. They say this is because people often want drafts to be kept for template emails. I suppose auto-save drafts wasn't really considered when they decided this...

    Cheers,
    Ant
  • Guy Parrot Level 2 Level 2 (410 points)
    Interresting! I get the very same troubles 1,2 and 3, but I do NOT use Fusion or anything else. As a matter of fact, apart from .Mac, I only have a Yahoo account.
    I have noticed though that replying to someone's mail and sending that reply does not show as an unread mail. Only new mails are marked as 'unread' once sent.
    As for the count of drafts, I can manually throw them out, though that leaves an empty count of 'one'. Rebuilding the mailbox will get rid of that fanthom 'one'.
    I am glad to report I do not have problem 4. Yet.
    Also, I did notice that all of this has happened since I upgraded to 10.5.2.
  • Ed Hagen Level 1 Level 1 (0 points)
    Like the original poster, multiple drafts of the same email appear in my drafts folder (saved on server). It is not uncommon for 20 or more drafts to appear as I write a long email. These drafts are not deleted when I send the email -- I have to delete them manually. It seems that an auto-save function, rather than overwriting the same draft, is instead saving a new draft every 30 seconds or so. This behavior only appeared when I upgraded from 10.4.11 to 10.5.2 (the latter was a completely fresh install on a new hard drive). It happens on both my home and work computers.

    I am using Gmail in IMAP mode, and my campus IMAP service, not fusemail or anything similar.
  • antg4 Level 1 Level 1 (0 points)
    Good point, I just did a test with an exchange server over IMAP and got the same result with the drafts..
  • Timothy Swan2 Level 1 Level 1 (15 points)
    Same problem here. As I compose an email multiple drafts are created and are saved after the email is sent. The most annoying thing about this is that it makes it look as though the mail was never successfully sent and the drafts must be manually deleted.

    The behavior seems to be random, since it doesn't happen with every email, or with every account.

    This is new to 10.5.2.
  • Guy Parrot Level 2 Level 2 (410 points)
    Well, I was wrong: replying to someone, or sending a new mail matters not, my sent mail shows as "unread" in a random way. Yesterday, I replied or sent 25 mails, some are shown as "unread", others are not 'blue dotted', for a lack of a better description.
    Yes, I can un-unread my sent mail manually, but I'm looking for a rhyme and/or a reason.

    Apple?
  • Seth Goldhammer Level 1 Level 1 (5 points)
    I also was having an issue with multiple drafts being created, then persisting after send. I may have resolved it. Under the mailbox behavior I unchecked 'Store drafts on the server'.
  • zeb Dropkin Level 1 Level 1 (0 points)
    I tested this option. For me, it seemed that the multiple drafts issue was resolved, but, as one might guess, my drafts were no longer saved in the correct Drafts folder in gmail. I wish to continue to save my drafts to my gmail drafts "folder" on gmail. I don't think this resolves the issue of multiple drafts being saved locally for those of us who intend to save our drafts remotely.
Previous 1 2 Next