6 Replies Latest reply: Feb 4, 2008 10:22 PM by George Peters
amankini Level 1 Level 1 (0 points)
I’m working with 30 fairly new imacs (Intel based) running 10.4.11. I need to permanently disable the ability to use wireless. Macs are so “easy” to use, even when the utilities are not accessible, the network diagnostic routine or imac update feature) will “discover” a network path by enabling the wireless network once the wired network is unplugged. This ability defeats the firewalls & security features of my network.

Imac, Mac OS X (10.4.11), Intel based imac 1.83ghz
  • George Peters Level 4 Level 4 (3,165 points)
    You have to "Turn Airport Off" either in the Menu bar or the best way is to go into the System Preference/Network select Airport from the list and remove it from the menu bar so that a user cannot simply turn it back on again. I've never had a Mac auto enable the wireless network once it's been turned off.

    George
  • capaho Level 4 Level 4 (3,650 points)
    Go to Network in the System Preferences and select AirPort from the network list, then click the "-" button under the network list window to remove it.
  • George Peters Level 4 Level 4 (3,165 points)
    That's how you do it in 10.5.

    George
  • amankini Level 1 Level 1 (0 points)
    You're not trying hard enough. (lol)

    I have removed the icon from the menu bar & also removed access to the utilities folder. As I stated in my problem, macs are so “easy” to use, even when the utilities are not accessible, the network diagnostic routine or imac update feature will “discover” a network path by enabling the wireless network once the wired network is unplugged.

    This means they can go to the apple icon & press update and the system will detect a network path (creating a wireless link) or they can click on the diagnostics from a failed network attempt and system will detect a network path (creating a wireless link)

    You don't need access to the wirelss icon to do any of this. The system will enable itself!

    Antonio
  • amankini Level 1 Level 1 (0 points)
    What seems to work is to disable the airport adapter then lock the
    preferences. (Duh!)
    Then the computer can only use the enabled adapter, the wired
    connection. Of course, with admin intervention, the wireless can be
    enabled.
  • George Peters Level 4 Level 4 (3,165 points)
    I didn't get the chance to test it out today but I will still take a look tomorrow. I have the feeling it will be the same result because my students accounts do not have admin privileges. Who's not trying hard enough? hehe. Either way glad you figured it out.

    George