13 Replies Latest reply: Aug 10, 2008 4:18 PM by nerowolfe
Lladnaar Level 1 Level 1 (0 points)
When I run Software Update it remains open with no software updates available, rather than reporting no updates and closing. In System Preferences it says:
Last attempt: Failed. Error occurred while checking.
In console the only relevant message I can find is:
Software Update [408] arguments=(null)

Is anyone else having this problem? Or any idea how I can track the source?

MacBook, Mac OS X (10.5.1)
  • rofe-ch Level 1 Level 1 (0 points)
    Hi, I just had the same problem. I cannot update the following Apple software "Keynote, Pages, Numbers and iWeb".
    In the error list I find the following entry

    03.02.08 19:20:34 Software Update[228] arguments=(null)

    I am using an iMac Dual Core with OS X 10.5.1.
    Thanks for any help.
    With regards, Rolf
  • tharrison Level 1 Level 1 (5 points)
    I've also experienced problems with Software Update, but only on my Macbook.

    Software Update begins to check for updates, and the progress indicator disappears. The main window says "New software is available for your computer". However, in the Software Update preference pane, the result is:

    "Last attempt: Failed. Error occurred while checking."

    Nothing was showing up in the install.log, so I thought I'd fiddle around a bit. I attempted to check from the command line (as root), and this is what I got:

    sh-3.2# softwareupdate -l
    Software Update Tool
    Copyright 2002-2007 Apple

    Software Update found the following new or updated software:
    * Keynote402-4.0.2
    Keynote Update (4.0.2), 33200K [recommended]
    * Pages302-3.0.2
    Pages Update (3.0.2), 29880K [recommended]
    * Numbers102-1.0.2
    Numbers Update (1.0.2), 28050K [recommended]
    * iWeb203-2.0.3
    iWeb Update (2.0.3), 18860K [recommended]
    sh-3.2#

    This is in direct conflict with the Software Update.log file, which indicates that I'd already installed all those updates:

    2008-02-03 21:30:24 -0500: Installed "Keynote Update" (4.0.2)
    2008-02-03 21:30:36 -0500: Installed "Pages Update" (3.0.2)
    2008-02-03 21:30:43 -0500: Installed "Numbers Update" (1.0.2)
    2008-02-03 21:30:51 -0500: Installed "iWeb Update" (2.0.3)

    I figure there's something causing issues with the GUI version of the installer. I can't explain why it works on my iMac but not on my Macbook. So, I decided to install from the command line:

    sh-3.2# softwareupdate -i -a
    Software Update Tool
    Copyright 2002-2007 Apple


    Downloading Keynote Update 0..20..40..60..80..100
    Verifying Keynote Update
    waiting Keynote Update
    Downloading Pages Update 0..20..40..60..80..100
    Verifying Pages Update
    waiting Pages Update
    Downloading Numbers Update 0..20..40..60..80..100
    Verifying Numbers Update
    waiting Numbers Update
    Downloading iWeb Update 0..20..40..60..80..100
    Verifying iWeb Update
    waiting iWeb Update
    Installing Keynote Update 0..20..40..60..80..100
    Done Keynote Update
    Installing Pages Update 0..20..40..60..80..100
    Done Pages Update
    Installing Numbers Update 0..20..40..60..80..100
    Done Numbers Update
    Installing iWeb Update 0..20..40..60..80..100
    Done iWeb Update
    Done.
    sh-3.2#

    After installing the updates, my GUI Software Update still does not work. Checking the install.log, I've only found the following errors:

    Feb 3 21:39:10 portia Software Update[1552]: Package Authoring Error: installation-check results requires a message
    Feb 3 21:39:10: --- last message repeated 4 times ---
    Feb 3 21:39:15 portia Software Update[1552]: JavaScript error "Undefined value" while running "_choice_suvisible"
    Feb 3 21:39:15 portia Software Update[1552]: _choice_suvisible returned error: Undefined value

    Now, the updates prior to Feb 02 that I installed contained only one update that was specific to the Macbook:

    2008-01-19 17:00:33 -0500: Installed "MacBook MacBook Pro Software Update" (1.1)

    I ran 'pkgutil --files com.apple.pkg.MacBookMacBookProKbdSU' to see what it updates, and I don't see anything that might impact the Software Update application. Also, used pkgutil to verify the OS-specific updates (non-app updates):

    sh-3.2# pkgutil --verify com.apple.pkg.update.os.10.5.1
    Verifying files from package 'com.apple.pkg.update.os.10.5.1' on '/'.
    Missing file "System/InstallAtStartup/System/Library/PrivateFrameworks/DiskImages.framework/ Versions/A/Resources/version.plist".
    Finished verifying files from package 'com.apple.pkg.update.os.10.5.1' on '/'.
    sh-3.2#
    sh-3.2# pkgutil --verify com.apple.pkg.update.security.2007.009
    Verifying files from package 'com.apple.pkg.update.security.2007.009' on '/'.
    ACL found but not expected on 'Applications'.
    ACL found but not expected on 'Library'.
    Finished verifying files from package 'com.apple.pkg.update.security.2007.009' on '/'.
    sh-3.2#


    Interestingly enough, on the iMac, the verify on the 10.5.1 shows all manners of missing files (including parts of Software Update and the framework). Could that be part of the problem?

    Just thought I'd share my investigations. At least I can still install updates from the command line, it seems.

    Macbook 2.2GHz, 120G, 1G.
    iMac 2.0GHz, 250G, 4G.
  • rofe-ch Level 1 Level 1 (0 points)
    Thanks for the hint. The Software Updater still fails today updating iPhoto and iPro (10.5.1).
    The only way to update seams the terminal using:

    sudo softwareupdate -i -a

    I really hope those bugs will be gone with the next upgrade. I really find the OX 10.5.1 annoying because most ofd the files I write to the hard drive have "system" priviledges and I need to change them in the finder in order to have write access.
    Regards, Rolf
  • Lladnaar Level 1 Level 1 (0 points)
    Thanks for the tip on using the command line software update (nb: it's important to sudu or you get an error about the plist). I've just updated, and got the iWork updates that I triggered me to notice the first place.

    Interestingly my GUI is now working again. I got the iWeb update just before it broke, and an iPhoto update just now. So either iPhoto fixed something that iWeb broke, or it was all just a server problem that's now fixed.
  • Lladnaar Level 1 Level 1 (0 points)
    Oops, replyed to wrong message. See above.
  • letoutpuissant Level 1 Level 1 (10 points)
    This is ridiculous! I've been having these problems since NOVEMBER. Apple should get on this considering they've now had two separate Leopard upgrades and the Software Update still is not working properly for everyone.
  • ThierryZ Level 1 Level 1 (25 points)
    Hi!

    I'm experiencing the exact same problem as described here.

    In my main account, after launching Software Update, the progress bar disappears after a while and the main window displays a "New software is available for your computer." (although I know there is not, since I've run the Software Update from another admin account and it says it's up to date) and the part of the window that should display the list of updates is empty and the "Install" button at the bottom right is greyed out.

    If I go to "Preferences…", I can see, below the "Check Now" button, the following text : "Last attempt: Failed. Error occurred while checking."

    I've, of course tried the procedure that worked for "curlz813" (see this thread : http://discussions.apple.com/thread.jspa?messageID=6727973) several times, without any luck.

    The same behaviour continues.

    The strange thing is that on my wife's account (also an admin account), the Software Update goes on well and says it's up to date.

    What can I do ?

    Thanks in advance for any help.
  • Serenak Level 1 Level 1 (0 points)
    This problem suddenly started to day on my MacBook, all my other Macs are fine, the MacBook is in fact fine in other accounts than my main one... tried deleting the relevant plists (both of them - in Library/Preferences and in ~/Library Preferences to no avail

    Tried bringing back both an earlier System Prefs and Software Update (in Core Services) but no change... if I run the Terminal Command it works

    I opened the Software Update package and ran the "software update" exectutable in there and it returns this...

    Last login: Sun May 11 23:18:12 on ttys000
    /System/Library/CoreServices/Software\ Update.app/Contents/Resources/SoftwareUpdateCheck ; exit;
    Nigel-MacBook:~ nigelmansell$ /System/Library/CoreServices/Software\ Update.app/Contents/Resources/SoftwareUpdateCheck ; exit;
    2008-05-11 23:20:58.079 SoftwareUpdateCheck[466:10b] Checking for updates
    2008-05-11 23:20:59.190 SoftwareUpdateCheck[466:10b] XML parser error:
    Encountered unexpected EOF
    Old-style plist parser error:
    Malformed data byte group at line 1; invalid hex
    logout

    [Process completed]

    Now that doesn't mean much to me - but maybe someone will know what it means and be able to point at a fix

    How or why this suddenly happened I can't say - nothing unusual has occurred here that I am aware of.

    OK it isn't really a critical problem - but it bugs me when stuff stops "just working" and I can't figure out why or how to fix it
  • bengliang Level 1 Level 1 (0 points)
    hello everyone,

    I had the same problem as described. Repaired permissions, deleted lots of plists, didn't work for me.

    This is what I did to troubleshoot further:
    sudo softwareupdate -a -i <-- this one works!
    sudo open /System/Library/CoreServices/Software\ Update.app/ <-- doesn't work, same problem
    sudo /System/Library/CoreServices/Software\ Update.app/Contents/MacOS/Software\ Update <- works!!! (huh???)

    Finally, switched to another user account and tried the Software Update (from the apple menu) and it worked just fine...

    So I figured it's a problem specific to a file in the user directory, and that led me to check which files are being touched by the Software Update application. I used sudo lsof -p <process id> to check.

    This showed me that the file ~/Library/Caches/com.apple.SoftwareUpdate/Cache.db was open.

    LONG STORY SHORT, delete all the files in /Users/<yourusername>/Library/Caches/com.apple.SoftwareUpdate/ and then retry Software Update and it should work!

    (so, why does this problem occur in the first place? two possibilities. 1. I encountered this after a recent upgrade to Leopard, so there was lots of junk in that old Cache.db and com.apple.SoftwareUpdate folder dating back to when I was on Jaguar. It ain't pretty. Something in there could have caused the Software Update to get confused and crash. 2. When you have multiple users accounts on the same mac, if you run Software Update on another account, it may cause the Software Update to get confused and lock the settings and other files.)

    hope this helps! all I can say is, it worked for me!
  • Actually Human Level 1 Level 1 (55 points)
    YOU ROCK! Your solution worked for me and I JUST this week started having this problem after months of working just fine and using Leopard. THANK YOU!!!
  • Sybil Ann Chick Level 2 Level 2 (230 points)
    Thanks from me too! I finally updated my Mac Mini to 10.5.4 from 10.4.11, as I no longer needed to use some possibly Leopard incompatible software, but after finding odd things had happened with some fonts, decided to do an archive and install, after which Software Update just hung and hung. Used this solution and, bingo, it's working again OK. I supposed it might be something to do with me having already run it and done updates before I decided to do an archive and install.
  • Robb Allan Level 2 Level 2 (345 points)
    Nicely done. Works as advertised.
  • nerowolfe Level 6 Level 6 (13,070 points)
    letoutpuissant wrote:
    This is ridiculous! I've been having these problems since NOVEMBER. Apple should get on this considering they've now had two separate Leopard upgrades and the Software Update still is not working properly for everyone.

    Have you filed a bug report? Posting here without giving any technical aspects of your issue will not help anyone.
    File the report here:
    https://bugreport.apple.com/cgi-bin/WebObjects/RadarWeb.woa/wa/signIn

    I would add that no software will be perfect for everyone. If 99% of the user base has no major issues, that's about all anyone can expect.
    Everyone here assisting others obviously is running Leopard with no issues to speak of.
    Are you saying that you cannot install 10.5.2?
    Not even the full manual install?