11 Replies Latest reply: Apr 2, 2008 2:48 AM by iviann
aimili Level 1 Level 1 (0 points)
I just tried to install the latest updates into my Macbook, and without warnings it just shut down and tried to restart by itself. But then it showed this weird message:

panic(cpu 0 caller 0x003A8DBD): unable to find driver for this platform: "ACPI"

debugger called: <panic>

(a bunch of other stuff with numbers)

Kernel version:
Darwin Kernel version 8.81: Mon Sep 25 19:42:00 PDT 2006; root:xnu-792.13.8.obj~1/release_1386

And then the screen asks me to restart my computer by holding down the power button for several seconds or press the restart button.

After doing that, it goes through the same process again. I am not sure what to do. How do I fix this? Will the boot/restore disk work?

Mac OS X (10.4.8)
  • aimili Level 1 Level 1 (0 points)
    Can't anyone help me?

    When I bought my Macbook, it came with a couple disks, but they are all at home, and I'm away at college. I asked a couple friends with Macbooks, but theirs are a lot newer than mine. I don't think it's the same operating systems. Do you think it'll work? I just don't want to make the problem even worse...

    Also, if I try to restore, will I lose what I have on my hard drive?? Thanks for the help.
  • smithrj Level 4 Level 4 (1,540 points)
    No, don't use their disks it will make things much worse. Can you start your computer at all? You can back up your files on flashdrives, disks, whatever you have. Send for your disks. Using disks not meant for your computer will make it more than likely inoperable. I need to re-read your first post and I'll post back. Ok, aimili?


    Ray
  • smithrj Level 4 Level 4 (1,540 points)
    Can you get to your Utilities folder? If yes, find disk utilities, find disk permissions, run this.

    Post back with answers,

    Ray
  • aimili Level 1 Level 1 (0 points)
    Thanks for the response.

    I cannot get into the desktop at all. Basically, just when I start my computer, it takes me straight to a black screen with those weird numbers and characters, and then in the middle it asks me to shut down and restart by pressing the power button. I cannot get pass that at all, so I can't save any of my files
  • smithrj Level 4 Level 4 (1,540 points)
    Hello again, try to boot from a safe mode, I'll give you directions:

    To start up into Safe Mode (to "Safe Boot"), do this:

    Be sure the computer is shut down.
    Press the power button.
    Immediately after you hear the startup tone, press and hold the Shift key.
    Tip: The Shift key should be held as soon as possible after the startup tone but not before.
    Release the Shift key when you see the gray Apple and progress indicator (looks like a spinning gear).

    Post back with results and we'll try something else,

    Ray
  • smithrj Level 4 Level 4 (1,540 points)
    Hi, if this fails try resetting the Pram to get a screen, more directions: Resetting PRAM and NVRAM
    Shut down the computer.
    Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    Turn on the computer.
    Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    Release the keys.

    Ray
  • aimili Level 1 Level 1 (0 points)
    Thanks for all the wonderful suggestions, but none of them worked I tried both methods, and it only goes to the grey screen with the Apple logo, but no spinning dials. After that it goes straight to the black screen I mentioned
  • Jason Sutter Level 1 Level 1 (15 points)
    I'm also having this same:

    panic (cpu 0 caller 0x0039bc83) unable to find driver for this platform.

    It happened while I was updating a friends intel macbook pro from 10.4.6 (I think) to 10.4.11 or whatever the latest combined update was on the apple software updater. I have tried to repair permissions, start up in safe mod, reset pram, with no luck. I assume the answer will be to reinstall the OS, the problem is this particular laptop was purchased a year ago and was a demo model from a large chain store, and my friend didn't receive the OS install discs. Now he's up the creek with out a laptop!!! HELP!!
  • iviann Level 1 Level 1 (0 points)
    Me too. (Sorry: my english... is...)

    I have a macbook: it happens the same: that aimili's "panic message" with the ACPI, (panic(cpu 0 caller 0x003A8DBD)).

    Besides, my cd-unit don't works (it crashed some months ago, so I can't use my "install disc"). This is a very disgusting situation. Please, help. The only option I see right now is to run other OS, but there is no other OS installed in the computer. I found this option pressing and holding the "option" key (after press the power button). Then I can see two pictures of two disc representing two OS: Mac and... and... windows (!!! ????). I don't understand how this was possible.

    Please, I need more information about how to re-start/reset/etc. the computer without the cd's.

    thanks!!
  • BDAqua Level 10 Level 10 (120,635 points)
    Hi, and a warm Welcome!

    You'd get more help by starting your own New Topic.

    The two OSes with Option Key are due to somebody installing something like Boot Camp, but if Windows wasn't installed also it won't help.

    Does clicking on Windows do anything?

    If you have another Mac around there are options, but please staart a New Topic...

    http://discussions.apple.com/post!default.jspa?forumID=758
  • iviann Level 1 Level 1 (0 points)
    Thanks a lot
    I did what you say me in this new topic:
    http://discussions.apple.com/thread.jspa?messageID=6960388&

    No, when I click in windows the computer says windows is missing (I never installed a different OS).

    Now I'll test all this keys:
    cmd-.
    cmd-opt-p-r
    cmd-opt-n-v
    cmd-opt-o-f
    d
    n
    r
    t
    z
    ctl-cmd-shift-power
    shift
    cmd-v
    cmd-s

    thanks!