1 2 3 4 5 Previous Next 65 Replies Latest reply: Jul 27, 2008 10:26 AM by joymac Go to original post
  • 15. Re: Ipod Touch wifi cannot find server? ?
    Cwiko Level 1 Level 1 (0 points)
    On, off, reset, renew, deleted and updated and still nothing. i have a full signal and the right ip addresses. But nothing will let me connect. this has only happened since the January upgrade which i might add i was forced into as my ipod miraculously fails whenever an update comes out.

    hey apple get you act together and sort this out! We’re not going back to the bad old days are we? and has no one heard of TESTING before an update?!

    if anyone has any more suggestions they are greatfully recived.
  • 16. Re: Ipod Touch wifi cannot find server? ?
    ateringcateringcat Level 1 Level 1 (5 points)
    my Touch will connect & get web pages on my home wifi (airport) and the free clouds network at mcdonalds.

    some networks just give the "can't find server" error, including my mate's router.

    on investigation as per earlier poster, there was no DNS listed in the Touch's wi fi screen.

    i would conclude from that, that it is a router problem, not with the ipod.
  • 17. Re: Ipod Touch wifi cannot find server? ?
    gdCT Level 1 Level 1 (0 points)
    Only thing that worked for me was to replace my linksys wrt 55ag (5+yrs old) with a new 54g

    The old one worked from christmas until
    I upgraded to 1.1.3

    why????? Who knows and apple won't say
  • 18. Re: Ipod Touch wifi cannot find server? ?
    i pod touch Level 1 Level 1 (0 points)
    my service is talktalk i phone then to ask for setting so i can get my i touch up and running i was told that they did not support apple i touch i can not find amy service when i try connect on my i pod touch,it connect ok wi-fi network but safari can not find service message.some please help to find ansewr
  • 19. Re: Ipod Touch wifi cannot find server? ?
    mm86 Level 1 Level 1 (0 points)
    I reset the network settings, reset the whole Ipod but still I can't connect to the internet!
    I haven't messed with my router, because (I dont want to screw it up. . and lose complete internet access in my house). I had a perfect connection with my ipod even after the upgrade. . then a day after the upgrade it decided to not connect to the internet.
    Apple doesn't have any info on how to fix this. . so hopefully someone figured it out. .
  • 20. Re: Ipod Touch wifi cannot find server? ?
    Red Sunrise Level 1 Level 1 (0 points)
    Hey,

    I got the itouch yesterday after a slight accident with my 1st geneation ipod nano. anyway, moral of the story is like most people, im set up with my router, good singal strength and everything and it still gives me that message "cannot find server" i tried reseting, turning wi-fi on and off, and pretty much everything else... still nothing...

    seeing how many people are having this problemn i find it hard to believe its all our routers. my itouch has an ip and a subnet mask, but nothing else... so it may be router related. but u would think that if the router lets you join it it would work... never had that problem when it came to any computer or my wii on my wireless router.
  • 21. Re: Ipod Touch wifi cannot find server? ?
    Red Sunrise Level 1 Level 1 (0 points)
    Ok i think i got it... all this server stuff reminded me of all the problems i had with some other router stuff... here goes my fix. (only works at home or somewhere where u have a pc that can do the following)

    I havent tested it to long, but so far so good.

    What i noticed is that my itouch only picked up the ip adress and subnet mask. the rest was blank.. so heres what you do.

    1.) On your computer run comand prompt can be done on most my going start> run> cmd. (my sister has a vista computer and that was a little different)

    2.) type in ipconfig/all you should get a thing showing your ip address, subnet mask, dns server, dhcp server, and default gateway.

    3.) go to your itouch, settings > wifi > then the server you are connected to (hopefully your at least connected).

    4.) Now comes number filling
    A.) fill the ip adress section with the numbers under ip adress (if its there dont mess with it.) if you do fill it out, you have to change it a bit. the ip adress you will have there is for your computer so what at you do is.... (i had 4 things on my router, itouch was last so... my last 3 digits were 101. for my i touch i changed that to 104. everything you add just moves up, so just change the last number. that should be in already though.)

    B.)Subnet mask, just fill in the subnet mask haha.

    c.)router: fill in with the numbers in default gateway

    d.)Dns - fill in numbers under dns server

    e.) search domain number same as router or dhcp server. mine are the same but if they are different it may matter.

    so thats probably about as clear as mud but it basically involves serching your router info on a computer, then filling in the blanks.

    im not sure if its a permanent fix but its been running for an hour now and ive turned it on and off and stuff so yeah.

    Red Sunrise
  • 22. Re: Ipod Touch wifi cannot find server? ?
    The Dormouse Level 1 Level 1 (0 points)
    I'm having the same problem as all the rest of you - I can connect to my network at home but can't use Safari, Mail, iTunes, YouTube, Stocks, Weather or Maps. This is so frustrating; I just bought this iTouch today (it came with the new apps that are apparently linked to the internet problems) and I already have a nano, classic and shuffle - so I pretty much just got this one for the internet connectivity.

    I did just try typing in all this extra information and although the iPod thought about it longer when I tried to get to a page on Safari, in the end I just got the same "Safari can't open the page because it can't find the server" bullsh*t message as before. Apple really needs to get their butts in gear and fix this fast - this is totally unacceptable and I will take my iPod back if it's not resolved within a month.
  • 23. Re: Ipod Touch wifi cannot find server? ?
    beppolina Level 1 Level 1 (10 points)
    I can join my home wifi just fine, but can't use the ipod touch at all to connect to any of the free wifi hotspots in New York City -- the same "Safari can't open the page because it can't find the server" message, even though I've got the little "bars" indicating that I'm connected. The whole point of buying the software upgrade was to get internet/.mac email etc when away from home, fer chrissakes.....
  • 24. Re: Ipod Touch wifi cannot find server? ?
    beppolina Level 1 Level 1 (10 points)
    more detail -- I get numbers under IP Address, subnet mask, and router, but nothing under "DNS."
  • 25. Re: Ipod Touch wifi cannot find server? ?
    Dave_Beaudoin Level 2 Level 2 (210 points)
    And have you tried all the suggestions that were made in this thread?
  • 26. Re: Ipod Touch wifi cannot find server? ?
    beppolina Level 1 Level 1 (10 points)
    Yes, Dave, I have -- your detailed post was very helpful. I have no trouble using the wifi network in my house, where I have control over the router. It's when I'm in an area with free public wifi that I can't connect. (Haven't tried a Starbucks yet, though.)

    Here's what happens when I'm trying to connect to a free public wifi hotspot:
    1. I go to Settings --> Wi-Fi Networks.
    2. I choose the hotspot name & touch the little blue arrow.
    3. Under DHCP, I get an ISP address, a subnet mask, and a router -- but no DNS.
    4. There's a checkmark next to the network's name & all the "bars" are blue -- so I should be connected, right?
    5. And yet, when I go to Safari, I get "Safari can't open the page because it can't find the server." When I try iTunes, I get "Cannot connect to iTunes Store."

    So......now what?
  • 27. Re: Ipod Touch wifi cannot find server? ?
    Dave_Beaudoin Level 2 Level 2 (210 points)
    If you can get a router address "number" then enter that number into the DNS manually and then try and connect. (it may work if the connection is wide open)

    It's too bad this thing is so picky about connecting, but over the years I've seen many routers and wireless PCI-e cards or USB thumb cards that didn't seem to like each other and won't connect no matter what you do.

    You also have to remember that some people don't use WAP2 or WEP and leave there connection open but they DO USE Mac address filtering which means if your Mac address isn't listed for that wireless router then you aren't going to be able to connect.
  • 28. Re: Ipod Touch wifi cannot find server? ?
    Christopher Moss Level 1 Level 1 (45 points)
    If you have an IP, subnet mask, but no DNS, you can manually enter either of OpenDNS's servers:
    208.67.222.222
    or
    208.67.220.220

    My similar problem when I first had the iPod Touch was solved by turning it off (right off, not just asleep) and on again. Then everything worked.

    Chris
  • 29. Re: Ipod Touch wifi cannot find server? ?
    mm86 Level 1 Level 1 (0 points)
    Well after completely restoring my ipod to factory settings, I figured this may cure things up. It still didn't work! When it connects to the router, I have all of the info (IP address Subnet mask, router, DNS, are all there!) but the Search Domains is blank. Im not sure if thats a problem but It is really frustrating me! I had perfect internet connection until a day after I upgraded my software. . .
    If anyone has found a fix for it. . please post!