8 Replies Latest reply: Apr 25, 2008 5:10 PM by Chris Gibbons
Bubalooney Level 1 Level 1 (0 points)
when I try to import from my camera, (into a new event OR an existing event)
I get:

The import was canceled. you may not have permission to write to /Users/myhd/Movies/IMovie Events.localized/New Event 2-4-08


Any ideas? Of course I should have permission...it's my camera and my mac. (I'm sorta wishing it wasn't my iMovie 08) : )


thanks!

Brad in Denver

iMac, Mac OS X (10.4.9)
  • AppleMan1958 Level 7 Level 7 (27,370 points)
    Two things:
    1) Make sure you have installed all updates through Software Update. If the Software Update says to reboot, do it before opening iMovie. Especially if it says to reboot for the QuickTIme update.
    2) It is generally a good idea to repair permissions after running Software Update. Go to the Applications/Utilities Folder. Run Disk Utility. In disk utility, repair the permissions.

    If it still doesn't work after that, come back and we can dig deeper.
  • Bubalooney Level 1 Level 1 (0 points)
    THanks AppleMan.

    Nope....quicktime is totally up to date. And I've tried the "repair permissions."

    Still unable to import from camera do to "may not have" permissions error.

    : (

    Can ya help? pretty please?

    Brad
  • AppleMan1958 Level 7 Level 7 (27,370 points)
    That's about all we can do with the information you have supplied.

    Maybe you might share with us...
    What kind of camera? Brand and Model number.
    What format is the original footage in?
    Are you at 7.1.1 of iMovie?
    Which Mac? Are you still at 10.4.xx?
    Do you have any external drives attached?
    Are you using symbolic links to redirect to an external drive?
    Are you using File Vault or any kink of encryption?
  • Bubalooney Level 1 Level 1 (0 points)
    thanks appleman.

    it is a canon zr500. It is imported into dv (I think

    It has successfully imported in the past to iMovie.

    I am on 7.1.1 and at mac 10.5.1

    no external drives (during import...have to unplug it to plug in the camera)
    no symbolic links to extrernal drive (at least on purpose.)
    No File Vault. (I'm unsure of what it is...if I am using it it is by accident.) It is not open.


    THANKS! This is makin' me crazy.
    You're kind to help.

    brad
  • AppleMan1958 Level 7 Level 7 (27,370 points)
    If you go to /Users/myhd/Movies/IMovie Events.localized/New Event 2-4-08 and right click on either the folder or the contents (if any) then select Get Info, you should see how the permissions are set. What are they?
  • Bubalooney Level 1 Level 1 (0 points)
    dude! that's it!

    I "unlocked" everything i could find in the "get info" box under permissions.

    You rule!!!!!!


    THANKS so very much.

    Cheers
  • AppleMan1958 Level 7 Level 7 (27,370 points)
    ...even a blind squirrel finds an acorn every now and then!
  • Chris Gibbons Level 1 Level 1 (15 points)
    Hi - I am having the same problem you resolved for another reader. However, when I go my Users/MyHD/Movies ... there is nothing to unlock. I can't find the iMovie/iMovie Events/ path at all.

    I have done every update I can, repaired permissions, and still nothing - any ideas?