Skip navigation
This discussion is archived

1.5.6 quit unexpectedly

1128 Views 6 Replies Latest reply: Feb 6, 2008 9:50 AM by c_kyr RSS
c_kyr Calculating status...
Currently Being Moderated
Feb 5, 2008 7:16 AM
I just downloaded the 1.5.6 trial from the apple website. The installation went fine, but when I try to start the application I get the "quit unexpectedly" error message. The details are as follow:

Process: Aperture [332]
Path: /Applications/Aperture.app/Contents/MacOS/Aperture
Identifier: com.apple.Aperture
Version: ??? (???)
Build Info: Aperture-710231815~3
Code Type: X86 (Native)
Parent Process: launchd [95]

Date/Time: 2008-02-05 10:15:49.240 -0500
OS Version: Mac OS X 10.5.1 (9B18)
Report Version: 6

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /System/Library/PrivateFrameworks/ProKit.framework/Versions/A/ProKit
Referenced from: /Applications/Aperture.app/Contents/MacOS/Aperture
Reason: image not found



Any ideas?
Thanks
MacBook 2GHz, Mac OS X (10.5.1)
  • jrg_uk Level 3 Level 3 (720 points)
    Currently Being Moderated
    Feb 5, 2008 9:33 AM (in response to c_kyr)
    c_kyr wrote:
    I just downloaded the 1.5.6 trial from the apple website. The installation went fine, but when I try to start the application I get the "quit unexpectedly" error message. The details are as follow:
    \[...\]
    Dyld Error Message:
    Library not loaded: /System/Library/PrivateFrameworks/ProKit.framework/Versions/A/ProKit
    Referenced from: /Applications/Aperture.app/Contents/MacOS/Aperture
    Reason: image not found


    Seems to suggest that the installer didn't correctly install the ProKit framework - or, it thought it should already installed (you're running 10.5.1 - so it should be there already) but it wasn't.
    PowerBook G4 15"/1.67GHz/DVD-DL/2GB + 23" ACD, Mac OS X (10.4.10), Mini-CD/1.83/1GB/10.4.10 Mini-G4/1.42/512MB/10.5.1 PB-G4/500/768MB/10.3.9
  • jrg_uk Level 3 Level 3 (720 points)
    Currently Being Moderated
    Feb 5, 2008 12:13 PM (in response to c_kyr)
    Well, here's how one other person installed the Leopard version of it:

    http://discussions.apple.com/thread.jspa?messageID=6204405&#6204405
    PowerBook G4 15"/1.67GHz/DVD-DL/2GB + 23" ACD, Mac OS X (10.4.10), Mini-CD/1.83/1GB/10.4.10 Mini-G4/1.42/512MB/10.5.1 PB-G4/500/768MB/10.3.9
  • jrg_uk Level 3 Level 3 (720 points)
    Currently Being Moderated
    Feb 6, 2008 4:50 AM (in response to c_kyr)
    They've just released a ProKit framework update.

    So install that instead, http://www.apple.com/support/downloads/prokit45.html or via the normal System Update route if it lists it.
    PowerBook G4 15"/1.67GHz/DVD-DL/2GB + 23" ACD, Mac OS X (10.4.10), Mini-CD/1.83/1GB/10.4.10 Mini-G4/1.42/512MB/10.5.1 PB-G4/500/768MB/10.3.9

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.