9 Replies Latest reply: Apr 27, 2008 8:50 AM by Kevin Bleicher
hobbes305 Level 1 (0 points)
I recently purchased a new Simpletech 1TB external HD to be run on a G5 IMac with the Leopard operating system. In order to set this system up to run on a MAC, the manual instructs me to open the disk utility, select the External HD, select Mac OS Extended for the format, click erase, confirm erase and wait for the HD to reformat. Whenever I try this, I get the following error Message:

Disk erase failed
Disk erase failed with the error:
Resource busy

I contacted Simpletech but the tech-rep had never heard of this issue. Any suggestions

iMac G5, Mac OS X (10.5.1)
  • DaddyPaycheck Level 6 (16,030 points)
    Hi hobbes305 -

    Greetings and welcome to the Apple boards :-)


    I have seen this problem with other drives. My solution has always been to format it on a Mac not running OSX10.5.

    Luck-

    -DaddyPaycheck
  • Smokerz Level 6 (9,485 points)
    Try the partition function instead of erase function. Before you do the partition check the options box and choose APM.
  • ThreeProng Level 1 (0 points)
    You need to format the drive as a APM partition in order to install Leopard as an G5-boot-able drive. i ran into the "resource busy " message myself. I repaired permission on the partition in question and then was able to reformat it and install Leopard.

    Good luck!


    3P

    Message was edited by: ThreeProng
  • Remy-K Level 1 (0 points)
    Hi Hobbes305,

    I have the same problem with a Simpletech Duo Pro Drive. After hacking around a little I discovered that this is a bug in Leopard. Not sure if you're using Leopard or not. But what I did was boot my Mac into the Install disks of Tiger and then ran the Disk Utility from there and it worked like a charm. Hope this helps!

    Remy
  • AriBe Level 1 (0 points)
    Remy,

    THANK YOU! I tried to re-boot using the install disk of Leopard and nothing worked. It kept with the same error "resource busy." Did as you said with Tiger's install disk (good thing I still had it) and used the erase function which worked perfectly in the Disk Utility. The partition option didn't work.

    I thought the error was with Simpletech and returned two other drives as defective. I owe Simpletech a huge apology for doing that. Leopard is amazing but these bugs just drive me crazy.

    Remy, you saved me a lot of frustration so thank you again!!

    AriBe
  • pmarkoni Level 1 (0 points)
    Thank you!
  • fiaafnr Level 1 (30 points)
    After battling this problem for hours and searching infinite useless internet forums, I was able to develop a workaround at least. If you cannot get a drive to work using the 'Disk Utility" app, Try this:

    WARNING: All data on disk will be lost!!!

    1) connect any external drive you are having issues with
    2) open a terminal (apps>utilities>terminal)
    3) 'diskutil list' to identify the drive name (should be something like /dev/diskX) - you can recognize it by the size, hopefully
    4) 'diskutil eraseVolume "MS-DOS FAT32" "NEWDISK" /dev/diskX'

    and that should work. I tried it first with all versions of "HFS" types and it kept failing. My guess is that some hard drives interfaced thru firewire just cannot support MAC filesystems ??? At least with my case, it is true.

    Hope this helps.
  • omnimoeish Level 1 (0 points)
    Yeah I got a 1TB Western Digital MyBook that I had working beautifully for about a month and then just one day it stopped working. I don't have any Windows Vista machines (from the couple of weeks I tried Vista, it seemed like it could have been made by Norton, so bloated and worried about security I could never do anything with it without it crashing so I installed XP over it), but XP Pro doesn't even see it (both in VMware and a real PC running XP Pro) but Disk Utilty sees it but I am getting this error, I cant partition or erase or repair or anything. I tried the Tiger install disk utility, had the same problem and I just tried fiaafnr's trick and it immediately got an error trying to erase it. Luckily I got it at Costco so I'm taking it back.
  • Kevin Bleicher Level 1 (75 points)
    I just had all of this happen with an old WD 500G and the terminal trick didn't work. This disk has always been a pain to mount (esp Firewire).

    I recently purchased a 1T at Costco, hoping that WD fixed all of this, but after reading this post I may return mine too!

    ERG. Don't buy WD, I suppose!