11 Replies Latest reply: Feb 7, 2008 12:46 PM by robh800
robh800 Level 1 Level 1 (0 points)
I'm having a problem that I can't figure out how to fix. I have google earth installed - I want to delete it, but I can't. When I drag it to the trash can, I get a message that says something along the lines of "This application can't be deleted because you don't have permission to change some of the files." (Not the exact message, but close).

I've tried the basic stuff, like repairing permissions through Disk Utility, and clicking the application, doing "Get Info" and making sure that I'm set to have Read/Write access, but I still get the same error message. I'm logged in as an admin. I'm just stumped. Does anyone have some idea how I could fix this? Any help would be much appreciated.

MacBook Pro, Mac OS X (10.5.1)
  • Kappy Level 10 Level 10 (244,405 points)
    Can you put it in the Trash but not Empty the Trash? If you can't put it in the Trash via Drag and Drop try instead selecting it and then selecting Move to Trash from the Finder's File menu. If you are logged into an admin account you should get an authentication dialog. Enter your admin password and click OK. File should be moved to Trash. Hold down the OPTION key and Select Empty Trash from the Finder's File menu.

    If the above doesn't work then visit The XLab FAQs and read the FAQ on Trash related problems for alternative solutions.
  • CT Level 6 Level 6 (16,390 points)
    This will sound silly, and is a long shot, but...

    What happens if you try to drag it twice in a row?
    What I mean is you drag it and get a message saying you can't.
    Then you drag it again.

    I ask this because there is some possibly related funny business, e.g., here:

    http://discussions.apple.com/message.jspa?messageID=6306666

    -charlie
  • robh800 Level 1 Level 1 (0 points)
    Thanks for the suggestions, but I didn't have luck with either one. I can't even move it into the trash, using drag and drop or "Move to trash" from the finder menu, so I don't think that's the problem.
    I tried dragging it twice in a row and I get the same message - "The operation could not be completed because you do not have sufficient privileges for some of the items."
    I also read that thread you linked to and tried replacing Google Earth with a newer version so that it would ask if I wanted to replace the older one. I clicked yes, got the same error message. I tried doing that twice in a row as well, and also tried clicking "Move to trash" twice in a row. I always got the same message and was never asked to authenticate.
    This seems very odd to me and I'm hoping I'm somehow just missing something obvious...
  • CT Level 6 Level 6 (16,390 points)
    Weird.

    This may also seem silly, but, in the spirit of not missing something simple...

    Are you SURE you are logged in as admin?

    I say this because some Leopard installs have the annoying feature of changing admin accounts to non-admin accounts.

    http://docs.info.apple.com/article.html?artnum=306876

    charlie
  • robh800 Level 1 Level 1 (0 points)
    Thanks for the reply. I don't think any suggestions/questions are silly. I've seen people miss the most obvious things (and have done it myself, much to my embarrassment). Unfortunately, in this case, I am logged in as admin. Unless there's more to this in Leopard than what I'm used to, of course. I checked system preferences>accounts and it shows that I am logged in using an account that has admin privileges. That should be correct, right?
  • CT Level 6 Level 6 (16,390 points)
    Yes. Darn it.
  • Kappy Level 10 Level 10 (244,405 points)
    Where is this application now? Is it in your Applications folder? If so try:

    1. Open the Terminal application in your Utilities folder.
    2. At the prompt enter each line pressing RETURN at the end of each:
    cd /Applications
    ls -l 'file name'
    Verify the file is there

    sudo rm -R 'file name'
    ls -l 'file name'
    Verify file is deleted


    You can then quit Terminal.
  • robh800 Level 1 Level 1 (0 points)
    Thanks, Kappy. I think I'm doing something wrong here...The application is in the Applications folder. I was able to do cd /Applications in terminal without a problem, but then I got stuck.
    Just to verify, I should be typing a lowercase L (not an upper case i, right?) followed by s, space, dash, lower case L, single quotation mark ('), space, and then, in this instance, Google Earth? So ls -l 'Google Earth'
    I'm not familiar with terminal, but I think you have to type everything exactly as written, right? Anyway, doing this got me the following:
    ls: illegal option --
    usage is ABCFGHLPRSTWabcdefghijklmnopqrstuvwx1 file ...
    Now, since I'm pretty sure I did the first part wrong, it really shouldn't be a surprise that the second part didn't work for me Doing sudo rm -R 'Google Earth' first prompted me for a password, which I entered, and then returned this:
    rm: Google Earth: No such file or directory.

    I have a feeling we're getting closer here. Thanks again for the help.

    Message was edited by: robh800
  • robh800 Level 1 Level 1 (0 points)
    I guess I should mention some other things, just in case they're relevant to this. I'm doing this on someone else's computer. It's a 24" aluminum iMac. Google Earth, as well as most of the other applications and settings, were brought over using Migration Assistant from a PowerBook G4 running 10.4.11. I don't know if this information is useful or not, but maybe someone will see it and say "Of Course! THERE'S your problem!"
  • beerunner Level 1 Level 1 (10 points)
    have you tried dragging and dropping the file into Terminal in the 'file name' the when you try the command

    cd /Applications
    ls -l 'file name'

    Verify the file is there

    sudo rm -R 'file name'
    ls -l 'file name'

    Verify file is deleted

    just another suggestion...
  • robh800 Level 1 Level 1 (0 points)
    Ha! Yes, that did the trick! I knew I wasn't typing things into terminal correctly, dragging the application in worked and the application is finally gone. Thanks to everyone for your help!