13 Replies Latest reply: Mar 29, 2008 6:43 PM by zellous
svbala Level 1 Level 1 (0 points)
Hello,

I am creating a website using iWeb and have problem with the navigation bar. When visiting couple of pages in my website, the navigation Bar limks to the other pages are not functional. I tried deleting those pages and re-creating them and still the problem persists.

Kindly help.

Regards
svbala

Macbook, Mac OS X (10.5.1), iWeb '08
  • Jurgen Banda-Hansmann Level 1 Level 1 (75 points)
    Have you tried to republish the whole site, via File - Publish to a Folder or File - Publish to .Mac ?
    Using this option, iWeb recreates your complete site and with that should resolve any kind of problems.
  • John Grover Level 1 Level 1 (0 points)
    I'm having a similar problem. Even though I am using the Publish to a Folder and uploading to my web host using fetch, I am getting results that are quite variable depending on who is looking at the site. Some users (particularly Windows users) see no Nav Bar at all. I am also having a problem with returns on the photo page showing up as black question marks. Finally, a html snippet from paypal looks perfectly placed in iweb, but either dissappears or shows up over the text on the web. The site address is www.fellowshipofreason.com so you can see what I mean.
  • Wyodor Level 6 Level 6 (19,605 points)
    Tell your windows friends to use a modern browser. [Safari|http://www.apple.com/safari> and [Firefox|http://www.getfirefox.com] come to mind.
  • John Grover Level 1 Level 1 (0 points)
    Agreed there...but this is going to the "general public". I am resigned about the nav bar since every computer I have and browser I have tried works. Who knows what the complainers were using.

    Even so, on my Macbook Pro and my Dell laptop, the black question marks and the misplaced donate buttons show up. Any solution for those problems?

    Thanks!

    John
  • contact@ywamtaoyuan.com Level 1 Level 1 (0 points)
    since i've upgraded to ilife 8, every page i make changes too, the navigation bar disappears.
    I've read some of the feeds and tried to recreate the page, publish to folder and place in fatch again and the file in fetch shows the navigation yet when i open the internet through firefox, explorer nor safari show the navigation bar.

    What can i do? please help. do i back up everything and reinstall iLife 6 or what.
    thanks.
    Adele
  • NorCal Newbie Level 1 Level 1 (0 points)
    I am suffering the same problem - my host server shows the /Scrips file but no Nav bar with IE or Firefox. My site hosting company says the custom java scripts are the problem, but the site publishes to .mac just fine. Has anyone seen any answers?
  • Old Toad Level 10 Level 10 (127,510 points)
    Have you tried doing a Publish All to .Mac as Jurgen suggested above?

    OT
  • contact@ywamtaoyuan.com Level 1 Level 1 (0 points)
    Thanks, but i have "Published to folder" and the reloaded the whole site to the server in small amount of files at a time and that solved it for me. It took a long time but now our site is working again.Thanks. Hope this helps someone else.
    Media department
  • Brendan Mccann Level 1 Level 1 (0 points)
    I am having the same problem. All nav bar links work from the welcome page, but none there after. The links work in iweb. I have reuploaded the entire site and refreshed the browser (safari, firefox) to no avail. I'd rather not have to start my site from scratch.
    Any suggestions?
  • contact@ywamtaoyuan.com Level 1 Level 1 (0 points)
    yes, it started with just the pages that i made changes too. i use iweb to design my english site and dreamweaver for my chinese site and put the file in fetch after i "publlish to folder".

    i deleted two or three files in fetch at a time and the replace with the new files from the site folder from mac. it takes time but worked for me. now my site show correctly in safari, firefox, and internet explorer.
    hope this works for you.
    Blessings
    Media department
  • Ethmoid Level 6 Level 6 (10,550 points)
    Simple question, but did you make sure that all the navigation links were active - did you check this box in the Inspector under hyperlinks before publishing?
  • NorCal Newbie Level 1 Level 1 (0 points)
    I found the solution for my site- i deleted the Script folder and used a different FTP program (Fetch versus Classic FTP). For whatever reason this fixed the nav bar, but no the links, so I deleted and reloaded the .html files in the main directory. I have no idea why it worked, but I don't see how that is relevant, since it did solve my problem. Hope you find your solution.
  • zellous Level 1 Level 1 (0 points)
    This issue was frustrating me too. I found this discussion group and tried a few of the suggestions but they did not work. I did however try this and it has worked. I noticed that the top navigation bar links that did not work were in the proximity of my logo. When I selected (with anchors) my logo in edit mode in iWeb I saw that its area protruded over the links in question. Keeping this logo selected I used the tool command "Backward" this set this image back in layers. (Note: you may have to double click a few times until the icon fades - which means that it has been successfully done) I also selected the navigation bar area and set it "Forward". I did this for every one of my pages. I then published all of my site to a folder and then uploaded that to my public_html folder. Cordially, Zellous