6 Replies Latest reply: Apr 27, 2008 6:45 PM by bed42
Apocralypse Level 1 Level 1 (0 points)
I have a wireless mighty mouse (all-white model), and over the last couple of days all of the buttons suddenly stop working at the same time; the right and left clicks, scroll-ball and side buttons are all unresponsive. I fixed this first time round by turning the mouse on and off again and it seemed to do the trick, but it's happened again today. It's fixable with the same method, but I'm curious as to whether anyone else is having the same problem and whether it is hardware or software problems that are responsible...

iMac 24" 2.8Ghz, Mac OS X (10.5.1), 2GB RAM
  • DaddyPaycheck Level 6 Level 6 (16,035 points)
    Hi Apocralypse-

    Have you tried fresh, name-brand alkaline or rechargeable batteries?


  • Apocralypse Level 1 Level 1 (0 points)
    Thanks for your comment, I've tested both the batteries in the mouse and both are fine. I probably should have mentioned in my first post that the cursor still moves around the screen when I have this problem. The mouse is still operating as it would normally, it's just that the buttons don't respond; that's why I thought it could be a software problem. However, I downloaded the Leopard update to 10.5.2 yesterday and have had no problems since so it seems ok...
  • Wender. Level 2 Level 2 (195 points)
    I have the exact same problem using a bluetooth Mighty Mouse with my iMac Core Duo and Leopard 10.5.2. This problem started after the 10.5.2 update but not immediately after updating, it has been a few weeks now hasn't it?

    Like you, I experience this: The buttons and ball are unresponsive, but the pointer moves. Moving the pointer over the dock makes the dock respond but I can't click on it. No clicks work, no scrolling works, sidebuttons doesn't work either. Keyboard works fine (also BT). There is no battery warning or "connection lost" warning and I have used brand new batteries as well. Funny thing is: I can either just wait for 2-3 minutes then it works OK, or I can turn the mouse off and then it works again immediately.

    Any ideas?
  • madde001 Level 1 Level 1 (0 points)
    Just to add my report to this thread, I have the same experience with my bluetooth Mighty Mouse, of the buttons becoming unresponsive while the cursor movement still is normal. It didn't happen immediately after my 10.5.2 update, but in the last couple of days since that update it's happened twice. Once, fresh batteries appeared to fix it, and I assumed that was the problem. But then the following day it happened again out of the blue. I just stopped using the mouse for awhile (used my other Bluetooth mouse) and when I tried the Mighty Mouse again, presto, it was back to working.

    So for me, this seems to be intermittent and I don't really know what the underlying problem is.
  • yappledapple Level 1 Level 1 (0 points)
    same problem here with my wireless bluetooth mouse.

    I had the same problem prior to 10.5.2 ~ mouse movement is not hindered, and sometimes click + drag does not pull out items from list view. Keyboard works fully so I have to find out a way to turn the computer off by means of keyboard shortcut.
  • bed42 Level 1 Level 1 (0 points)
    Just adding to this list - as my wife has had this exact issue on her iMac with 10.5.2. Mouse movement works fine, buttons and scrollball don't. Turning the mouse off and on again has fixed the issue.