Previous 1 2 3 Next 163 Replies Latest reply: Oct 29, 2008 7:49 PM by younker_dl
Satoru Murata Level 1 (15 points)
All right, I've spent the past 12 hours (on and off, of course) looking through all the threads in here, doing a lot of experimentation, and a bunch of clean installs and whatnots, and I've decided to start a new thread, since in many of the said threads, some people seemed to have similar issues, but the other issues in the same threads seem to be different problems, and it just becomes confusing when you try to trouble shoot something and people are talking about different problems.

So, this thread is specifically for people who satisfy these criteria under Leopard:

1) You're having issues with very slow file transfers in your *local network* when at least one end is connected wirelessly; that is to say, when both ends are connected to the router via ethernet, you see no problem at all.

2) Your wireless connection doesn't display problems when connecting to the internet.

3) It is not specifically an 802.11n issue; i.e., the problem can be duplicated when in Mixed b/g only mode and/or using an 802.11g router.

4) It's not a router connection issue; i.e., your wireless connection isn't being dropped, and you are able to find your AP and connect to it without any problems.

So basically, that more or less sums up my problem. My equipments:

MacBook Core2Duo 2.2GHz, 802.11b/g/n, OSX 10.5.2
iMac Core2Duo 2.13GHz, 802.11b/g/n, OSX 10.5.2
Router 1: TRENDnet TEW-631BRP (Draft N router), H/W V3.0R, FW v.
Router 2: NETGEAR WGR614 v.5 (g), FW v.1.0.3_1.0.3

Internet: RCN Cable, 20Mbps/2Mbps

In my usual setup, the iMac is connected via Ethernet and the Macbook is connected wirelessly.

I know that this is a Leopard problem, but I'm not so sure it's a 10.5.2 specific problem. Let me explain.

I'd been using the TRENDnet more or less happily for the last couple of months. My iMac and Macbook have been in sync in terms of Leopard versions, so I know things were OK till last night when I first noticed problems. Transferring a large video file from the iMac to the Macbook would start off fine, then really slow down, and finally almost completely halt. Naturally, I blamed 10.5.2.

After trying all the different "fixes" in the Leopard/network related threads with no avail, I tried booting my laptop into Tiger (10.4.11) installed on an external HDD. Voila, wireless file transfer speed is fast at around 8MB/sec (obviously using N). I did a fresh install of 10.5, and the speed immediately dropped down to 1-2MB/sec, although not necessarily stalling. Then, updating to 10.5.2 slowed it down more, and now the transfers will sooner or later almost completely stall.

Again, I tried all the suggested remedies (use b/g Only mode, adjust RTS/Fragmentation thresholds, use WEP instead of WPA, delete all the Network Services in System Preferences -> Network, etc., etc.). Nothing helps. I tried swapping the router to an older Netgear (802.11g/b), and it's the same deal, so it's not a router issue.

A definite characteristic is that the transfer seems to stall after a certain period of sustained transferring; i.e., this will usually only happen when transferring large files (>200MB). If I were to download a folder with 600 JPEG files @ 1MB each, there won't be a problem, and the transfer rate will be pretty fast (although not as fast as under Tiger @ 7-8MB/sec), and it won't stall. It's only when I try to transfer big video files, etc., that this problem occurs.

If you are having similar issues, please share your experiences, suggest remedies, offer insights. I will try to answer any question you may have and that I may have missed to address.

PLEASE: if your symptoms are different from what's listed up there, please try to refrain from posting here, unless you are absolutely certain that the issues are related. Thanks.

iMac 20" Core2Duo 2.13Ghz/ MacBook 2.2 GHz Superdrive (White), Mac OS X (10.5.2)
  • clind Level 1 (0 points)
    I have also problem with Slow Wireless (internet) after 10.5.2 path. Before this path i had to turn off/on airport 2-4 times before it worked. But now it seems stable but with very low speed. I can even log into Messanger. I have tried 3 different routers/accesspoints (Philips/Zyxel and Linksys), with the same problem. My PC and even my Nokia cellphone works fine to surf the internet with Wlan.
    Getting tired of this now. This was my first Mac and likely the last one.
  • Satoru Murata Level 1 (15 points)
    Thanks for the info, but your problem is not the same as mine. No offense (really), but as I stated, I want to keep this thread solely for people having problems with local network file transfers. FYI, my internet connection from either my iMac or my Macbook is A-OK.

    Testing at consistently gives me a 15-20Mbps/1-1.8Mbps result. When I was downloading the 10.5.2 update (350MB combo update) from Apple on my Macbook with 10.5.0, I was clocking in at an average of 2.6MB/sec, which is pretty much the theoretical maximum of my 20Mbps RCN connection.
  • iBookster Level 1 (125 points)
    I am having a similar problem. I have an iMac 2 ghz core duo and an ibook 1ghz g4. They are both connecting to an airport express. I often "stream" movies stored on my iMac to my ibook ,but ever since 10.5.2 this has been a no go as the playback becomes choppy and quicktime will eventually turn into a beachball when the movie does no longer load.

    Trying to copy the movie over the wireless network does not solve the problem. After a couple of minutes transfer at 1.5 mb/s it drops to around 100kb/s then 20kb/s and then eventually stalls.

    Normal internet use and heavy download is not problem. Only LAN transfers seem to be affected.
  • ericmeyers Level 4 (1,410 points)
    Same exact issue. Slow file transfers on local network. Huge packet losses and poor pinging a machine that is connected wirelessly. Large data transfers tend to make the connection almost drop, sometimes dropping completely.
  • mattsigal Level 1 (0 points)
    Yup - as I've posted in some other threads, I am having the same problem. Both computers are running 10.5.2. The iMac is corrected via ethernet to a Linksys WRT54G 8.00.2FW. A brand new (as of yesterday) MacBook is connected wirelessly to the same router.

    The MacBook has no problem connecting to the internet or doing its thing but, try to transfer a large file over... It gets through the first "chunk" (usually about 100 MB or so) with ease. Probably within less than a minute. Then it completely stalls. If you leave it, it willl (EVENTUALLY) finish the transfer... but this might be 20, 30 minutes later.

    On top of this, when it is transferring, the entire computer stalls up. Firefox goes from taking 2 seconds to 3-4 minutes to open, even Activity Monitor needs coercing. This is a brutal bug.
  • Satoru Murata Level 1 (15 points)
    Great, sounds like we're getting people with the same issue lined up here. If you come across people having the same issue, but in a different thread, could you all be kind enough to redirect them here? I don't intend to pimp out this thread, but I would like to consolidate people with this particular issue (as opposed to some of the other wireless issues people are having with Leopard).

    In the mean time, can any of you specify exactly when this problem crept up?

    As I mention, I first noticed it after I upgraded both of my computers to 10.5.2., so that's why I thought it was an issue with that upgrade. I tried booting my Macbook into Tiger and everything was jiffy, but then when I installed 10.5 (intending to stay away from 10.5.2.), the problem crept up again. The iMac (again, wired to the router) always remained 10.5.2. So it's not just a 10.5.2. issue, it seems.
  • Rookie X Level 1 (20 points)
    I noticed that today:

    my internet connection via airport and via ethernet is ok, normal speed. Airport is stable, no problem there.

    *What's painfully slow though is the transfer speed between macs inside my local network (airport WLAN 802.11 g ).*

    And not just with big files but any size: when I try to transfer a 12MB file from one mac to another in my local network via airport/WLAN, it will sometimes start at a high speed and then after let's say after 2MB the speed will drop to around 56KB/s. Sometimes it will start at this ridiculous speed right away. This way transferring any file is just impossible.

    And no, it's not a router problem. Didn't change anything there and its firmware is up-to-date. It's quite probably related to Leopard or the latest Leopard update. Can't say exactly because I didn't notice until today.

    So please Apple start listening to your customers again and publish a solution or some update. And quickly so please. It's so annoying. Thank you.
  • Shawn Parker1 Level 1 (125 points)
    Same issue here.
    I first noticed when Time Machine would sit and prepare for a long time and then take up to 10 minutes to back up 9MB worth of files. Right now it seems to have borked on an 80MB transfer. It has taken 5 minutes to transfer 10MB and wants 25 minutes to do the rest. iTunes streaming can get choppy.

    Setup is:
    Wired - Dual 1Ghz MDD, 1.75GB Ram, plenty of HD space.
    Wireless - Powerbook 1.67Ghz, 1.5GB Ram, plenty of HD space.
    Router - Sonicwall TZ-150.
    Wireless - Airport Express in bridged mode.

    Screen sharing is fast. Internet access is fast. LAN is pitiful.

    Unfortunately my only experience is with 10.5.2 - I just upgraded the MDD to get to use it as a Time Machine backup server, and that was just last week, right after 10.5.2 showed up.

    Message was edited by: Shawn Parker1
  • Noblestreet Level 1 (0 points)
    Hi Guys,

    I've got the same problem but I noticed this since I have Leopard. I have the lastest MacBook bundled with Leopard and I upgraded my IMac (intel Duo2 ) to Leopard. As of the first moment I noticed that pulling in data over the internet I had speeds up to 1,5 mbps but if I tried to copy data between the two machines it's just too slow. It takes ages to copy over 300 megs. I installed the latest update to 10.5.2 but this hasnt helped.

    I've been looking online and I have come across alot of threads with the same problem, but no body has a solution. This is rather crappy.

    I hope someone has an idea how to solve this issue. I dont want to keep copying via an external hdd.

    Best regards,

  • Mark Jenkinson Level 2 (285 points)
    Yup, same problem here. MacBook Pro 10.5.2 and PowerMac G5 10.5.2. Transfer speeds between the two macs is at an abysmal 75KB/second...and yet at the same time, I can download from the internet at ten times that speed at around 850KB/second. Using a Linksys WRT350N.
  • akeyo82 Level 1 (0 points)
    Same issue here, with a D-Link DI-624+. Slow speed in the LAN, but no problem in the internet connection. I've also tried with different protocols. I hope Apple will fix this bug as soon as possible, since I think it's a consequence of the new "features".
  • Ken Schuller Level 1 (0 points)
    I'll concur, network streaming since 10.5.X is painful at best and has gotten worse with every dot release. Apple, I've spent thousands of dollars on your equipment in the 13 years I've been using it and this is unacceptable.

    Here's the home network for reference:

    12MB uplink to Internet via Cox Cable --> brand new (yesterday) Airport Extreme (to replace a Linksys WRT 54G, which I had originally suspected was the culprit) 100MB Ethernet to Core 2 (single) Mac Mini. Media lives on a Lacie 500GB RAID1 array connected via Firewire 400. The Mini shares out to a Macbook Core 2 Duo @ 2GhZ, Airport Extreme and an iMac Core 2 Duo @ 2.16GhZ.

    Movies stutter and die when streaming to the MacBook or the iMac, regardless of codec. The iTunes application can no longer stream mp3s from my shared library (on the Lacie array) to either of those two machines without constant rebuffering.

    I have verified the Lacie array isn't suspect by copying known good (by test play on the Mini) files from it to the Desktop on the Mini and streaming from there. I've verified the MacBook and iMac aren't suspect by copying those same known good files to the Desktop on each and playing from there. I don't have issues opening a connection from one machine to any other on the network, but any sustained connection is an issue, regardless of networking protocol (AFP, SMB) or connection\authentication method (Finder sidebar or "Connect to Server" dialog.)

    Apple, you have an obligation to your customers to resolve this. I've been a networking professional for 17 years and setting up the Airport Extreme was far from a challenge.
  • Ken Schuller Level 1 (0 points)
    Further investigation:

    Forcing the AirPort Extreme to N only seems to help. I'm streaming a 20 minute (175MB) Xvid encoded file through QuickTime (via FrontRow) without issues.

    What surprises me is that the AirPort cards in the two clients didn't default to a N connection. In fact, it looks like they were connecting at B speeds.

    I have to wonder if there's something going on with connection negotiation.. I know that connecting to the WRT54G I was connecting at G speeds from both clients. I'd like to leave the connection open to G clients in the event I have guests and I'd still appreciate Apple addressing this, likelihood notwithstanding.
  • hankchill Level 1 (0 points)
    I can attest to this issue as well;

    Before 10.5.2, I had no problems streaming video wirelessly from my G5, through the Linksys router, to my Macbook Pro. Since the update, I thought my router was pooched, so I even went as far as buying an Airport Extreme. Nope, didn't solve any problems. I can guarantee it's not a router or internet issue, because I run a media server off the G5, which streams video to my Playstation 3. The videos streaming to the PS3 is flawless. It's only 10.5.2 to 10.5.2 connections that transfer about 14-17MB of the file, and then the connection drops to an insanely low transfer speed.

    This is however, not the only issue with Leopard 10.5.2 -- If I use iChat AV in a video conference for anywhere past 30 seconds, my connection to the internet completely drops.

    Apple, fix this wireless issue! I'm surprised you even let it go on for this many days! You're pushing people away, and starting to remind me of Microsoft... You can't release an update if it breaks more than fixes!

    sigh I hope the developers at Apple get off their high chairs and give us a STABLE release.

    Any chance of downgrading to 10.5.1?
Previous 1 2 3 Next