Previous 1 7 8 9 10 11 Next 163 Replies Latest reply: Oct 29, 2008 7:49 PM by younker_dl Go to original post
  • Paul A. van der Zwan Level 1 (20 points)
    It looks like for me the recent Security Update fixed it. It included both an AFP server and client replacement. In my tests that was the only cause of slowness, if I used NFS between my iMac and Macbook I got full speed, when I used afp performance was terrible. Maybe Apple silently fixed the performance problem in the afp software while fixing some security issues.
    Hey,as long as I get my pre 10.5.2 speed back I'm happy again.
  • PsycHotIc_PHI Level 1 (10 points)

    came home and ran the updates after work, i'm back to at least 4mb up/down in-network transfer speeds. finally =P
  • darcy Level 1 (35 points)
    Todays Time Machine and Airport update appears to have resolved slow wireless LAN transfers for me too.

    Thank you Apple. Thank you for not testing the 10.5.2 release enough in the first place, thank you for allowing me to be a paid 10.5 beta-tester and not requiring me to sign a NDA to do so. Thank you for taking what is perceived as a long time to fix.

    Don't get me wrong. I am glad it appears to be resolved. I find Apple's QA seems to be slipping these days. Just one man's perception.
  • ibosie Level 4 (1,115 points)
    The 7.3.1 update has resolved my performance issues too! The 6-7Mbps has turned into 90-105Mbps so I'm really pleased.
  • m0thr4 Level 1 (100 points)
    I think I have the same problem. I have a Mac Mini connected via ethernet to my Airport Extreme 802.11n. I also have an iMac that is connected wirelessly to the same base station.

    Everything is fine until I try to transfer a file from the iMac to the Mac Mini. At this point, the connection quality icon in the menu bar starts to drop to one bar, indicating a poor connection. I was trying to transfer a file of 900Mb and it reported that it would take 10 hours. At this point, I can't stop the copy procedure unless I force Finder to relaunch.

    My previous setup (last week) was the same Mac Mini, an iMac G5 and a D-Link Gamer Lounge router. I had no problems with that setup. When I got the Airport Extreme, I didn't have any problems with the G5 to the Mac Mini.
  • ibosie Level 4 (1,115 points)
    Hmm, spoke to soon. I managed to copy 35.7GB of 52.08GB before it began to crawl. In Console I see this, even though my LAN is 10.0.x.x and i have wireless switched off for that machine, i have no clue what is on airport en1.

    Mar 20 13:29:40 user bootpd[14001]: server name user.local
    Mar 20 13:29:40 user bootpd[14001]: interface en0: ip mask
    Mar 20 13:29:40 user bootpd[14001]: interface en1: ip mask
  • puck99 Level 1 (0 points)
    Well the connection speed on my G4 ibook seems to have improved slightly (hangs out at 54mbs more frequently) but my n enaabled Mac Pro (intel) wont connect any faster than 65mbs (and spends more time at 59mbs).

    Is it me or is this CONSIDERABLY lower than its potential of 300mbs? Even the AppleTV is pegged at 130mbs which is much lower as well.

    I would think that this would have a big part to do with the slow transfer speeds on the lan. Has anyone else checked their transfer rates?
  • Bryan M Level 1 (20 points)
    Even when this issue finally gets resolved, I don't think you're going to be able to come close to the faster Pre-N bandwidth. I'm betting that the AE card in your G4 iBook is only 802.11 a/b/g capable. If you have anything connecting to your AEBS that isn't Pre-N capable (and more than likely Apple's Pre-N), the speed of your AEBS is going to drop down to slower bandwidth. This would include older Macs, the iPhone, the iPod Touch, etc.
  • puck99 Level 1 (0 points)
    Although I can't speak on any updates that may come that doesnt seem to be the case in my situation. I took everything but the macpro and the appleTV (both n compatible) off of the network with not even a slight change in Tx rate. I then changed the wireless mode to n only to the same effect; none.

    It seems that no matter the wireless mode (as long as its n compatible) or clients on the wireless network my macpro is stuck with a 59mbs tx rate and the appletv at 130mbs tx rate. This *****.
  • silverburn Level 1 (0 points)
    Well, I've installed the new airport driver....


    Turns out, I can't even get the macbook to connect to my wifi anymore! I've now got to walk into the next room so it can get a signal. It goes from zero bars to full bars in 6 feet...what a bloody shambles.

    Add to that, I had to rebuild my wireless connection, because it refused to DHCP it's IP details from the router - even with a full bar signal. It kept sitting at "Self Assigned IP".

    Nothing else has changed - routers, room layout, where I place the macbook etc etc. It all worked fine before. The only thing changed is the driver. My un-updated 1st gen macbook continues to work fine.

    Haven't even got as far as checking delated.ack yet....

    Really, really ****** off now.
  • silverburn Level 1 (0 points)
    UPDATE: The issue only occurs when I connect the power supply, external display or USB hub.

    Again, all worked fine before...
  • ericmeyers Level 4 (1,410 points)
    Interesting. I too have connection issues when I'm connected to the power supply.
  • silverburn Level 1 (0 points)
    UPDATE 3:
    I think I have it running as it should now!

    Basically, after the airport driver update, I have now repeated a number of actions people have tried before.

    - Reset the PRAM
    - Deleted Airport preferences
    - Deleted known networks
    - Deleted the airport connection, and created a new one
    - On the router, enabled traffic on channel 13 only, set new WPA2 password (and rebooted)
    - rejoined the network from macbook

    I now have a very solid 5mb/sec connection (group N) to my server whether running from the battery or not, and delayed.ack is still on 3!

    Note: when choosing the channel on the router, I tried them all - 13 was the only one to run properly.

    Hooray! AT LAST!
  • BobP1776 Level 3 (695 points)
    For folks who are still having problems after applying the "Time Machine and Airport Drivers" update, another thing to try is to boot once in Safe Mode.

    To do this, Shut Down the computer, then reboot while holding down the "Shift" key. Keep the "Shift" key held down until you see the spinning gear on the gray screen showing the Apple, then release it.

    A Safe Mode boot does a variety of maintenance steps in the background while it is booting up. Be patient, this will take a while. Eventually you will get to the log in window bearing a notice that you are booted in Safe Mode.

    At this point, do not log in. Immediately Shut Down using the button on that log in window. The maintenance stuff has already happened, but there's one additional piece that may yet need to happen which is the rebuilding of the "Boot Caches". This will happen, if necessary, when you Shut Down.

    Now you can reboot normally. I like to also Reset PRAM as part of the first boot after a Safe Mode boot, just as a precaution. PRAM (Parameter RAM) holds copies of various system settings. If any of them get out of whack odd things can happen. To reboot while resetting PRAM, locate the 4 keys Command(Apple)-Option-P-R. Hold down those 4 keys and press and release the power button. Keep those 4 keys held down until you hear the SECOND startup chime and the release them. The computer will continue to boot up normally.

    There have been several reports in the boards here of folks having odd hardware issues after applying this update that have been cured by a Safe Mode boot. For example, loss of their BlueTooth keyboard. If a Safe Mode boot is fixing such stuff, it is an indication that some low level things have not been completely tidied up as part of installing the update. Booting in Safe Mode forces that tidying up to happen.

    And that means a Safe Mode boot may fix lingering Airport problems after this update as well.

    NOTE 1: The first time you log in to each account after booting once in Safe Mode will involve an extra long log-in time as various account specific caches are being recreated.

    NOTE 2: The first incremental Time Machine backup that runs after booting once in Safe Mode will have a very long "Preparing" phase -- about as long as doing a Repair Permissions pass in Disk Utility. A Safe Mode boot marks the file system activity log as invalid, meaning that Time Machine will now traverse your entire file system, comparing against its last backup, to find everything which is changed and needs to be backed up. The actual backup itself will still be incremental (only the things that have changed), but the "Preparing" stage takes a long time because it has to traverse the entire file system looking for changes instead of just relying on the activity log to identify them.
  • cardsdoc Level 1 (0 points)
    I'm still having this problem (sort of) after the update and all the recs here (safe boot, reseting pram, reseting airport preferences). However the problem is now more limited. File transfers work fine unless I hit the airport icon and it performs a scan - then the transfer stops. Interestingly if I run the delay ack command it resumes or I can eject the remote disk and start again. Anyone with similar experiences?

    Message was edited by: cardsdoc