Previous 1 7 8 9 10 11 Next 163 Replies Latest reply: Oct 29, 2008 7:49 PM by younker_dl Go to original post
  • snoodels Level 1 Level 1 (5 points)
    I have had the same problem with my wireless lan connection of my brand new macbook.
    The connection was terrrible slow.
    For me it works, so perhaps this will work for some of you, too???

    • disconnect from your network by turning off AirPort or unplugging your ethernet cable.

    • trash the following folder (from the global /Library, not your own ~/Library in your home directory): /Library/Preferences/SystemConfiguration

    • if required: enter your admin password

    • restart your pc

    • enter your network settings (turn on your Airport card)

    • I've found the solution in discussion for macbooks, so here is the original post:

      So let me know, if this works....
  • overclockedmind Level 1 Level 1 (0 points)
    That didnt work for me, though it did seem to reset some things that hadnt yet gotten reset. Still having the issue.

    -- Joshua
  • straymonkey Level 1 Level 1 (0 points)
    I just spent 4 days trying to solve the slow wifi problem I had after upgrading Leopard 10.5.2 version. This is all the efforts I've found on the net and tried almost all of them. It seems like it fixed my problems. So I wanted to put it all together for any one who might be looking for the solution. Thank you to everyone in the net who posted all these solutions. I hope it fixes yours.

    You will need your admin password and how to delete or rename protected system files for some of them.

    1. Check your DNS settings. - System Preferences/Network/Airport - Advanced/DNS.
    - ping it to make sure it returns at a reasonable speed.
    - if the numbers are gray, that means your router is giving it to you automatically. you will have to change it in your router.
    - many people seems to have had success with using OpenDNS - I didn't use it myself.

    2. Turn off IPv6 - System Preferences/Network/Airport - Advanced/TCP/IP.

    3. Check your preferences. If you upgraded to Leopard, it can corrupt these preference files. These are in /Library/Preferences/SystemConfiguration.
    - NetworkInterfaces.plist
    - Preferences.plist
    Removing these will automatically recreate them. These fixed a lot of my weirdness on my system network.

    For people running Parallel, make sure it's running and open System Preferences/Network and it will recreate it. The only thing is you need to rename it. Look in the icon next to the '-' sign.

    Parallels Host-Guest
    Parallels NAT

    4. For people seeing slowdowns in Safari, look in "username/Library/Preferences/" - this also gets recreated when destroyed.

    5. In terminal, do sysctl net.inet.tcp.delayed_ack - value will probably be 3. Do sudo sysctl -w net.inet.tcp.delayed_ack=0

    If you really want to speed things up, do the following:
    sudo sysctl -w net.inet.tcp.rfc1323=0
    sudo sysctl -w net.inet.tcp.recvspace=32768
    sudo sysctl -w net.inet.tcp.sendspace=32768
    sudo sysctl -w net.inet.tcp.winscalefactor=1
    sudo sysctl -w net.inet.tcp.sockthreshold=0

    6. For those who have their older backups, you can go back to an older version of your /System/Library/Extensions/AppleAirport.kext

    7. Gems sometimes can be improved.

    A. You can edit System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/gem something like this:
    # Copyright 2006 by Chad Fowler, Rich Kilmer, Jim Weirich and others.
    # All rights reserved.
    # See LICENSE.txt for permissions.

    require 'resolv-replace'

    require 'rubygems'
    require 'rubygems/gem_runner'

    *then do update gems.

    B. Some people also seemed to have success doing this: (But I didn't try this)
    # for OSX compatibility
    Socket.donot_reverselookup = true

    C. create a file called .gemrc in your root directory. Mine looks like this:
    localhost:~ codemonkey$ more .gemrc
    gem: –no-update-sources –no-ri –no-rdoc

    8. This is not Leopard's fault but you should try changing the wireless channel in your wifi router. I went from channel 6 to channel 11 and it helped a lot.
  • needsomeihelp Level 1 Level 1 (95 points)
    Has the above worked for anyone yet? Please share your experiences! Thanks everyone.
  • Satoru Murata Level 1 Level 1 (15 points)
    Hi guys, topic starter here.

    Well, here's one success story, although by no means would I recommend it to everyone.

    Basically, a total, complete, utter clean install of the OS fixed it for me. I'd been having various problems on my iMac besides this issue, and I decided, after inheriting about 3 generations' worth of Apps, preferences, kexts, etc., I should start afresh.

    So, with a Time Machine backup at hand, I did a wipe and install, without moving inheriting any previous data. Updated it all the way to 10.5.2 and all the current updates, and lo and behold, wireless transfer speeds are "good". Not excellent, like 7-8MB/sec via my N router, but a good 4-5, and sometimes 6MB/sec transfer rates, both going up and coming down.

    From there, I reinstalled all my apps from scratch, and only transferred over "old" data that were vital; specifically, everything in my user directory except for the Library folder -- the only contents from that directory that I copied over were the Mail/Mail Downloads directory; everything else got a fresh start.

    Luckily, I have .Mac, so a lot of data could be retrieved through a resync with .Mac (Mail accounts, Keychains, etc.).

    And that's where I'm at now. It's been about a week, and I'm still reinstalling (or simply transferring over from Time Machine) one or two apps a day. My iMac is still getting good transfer rates. Now I'm seriously contemplating whether I should go ahead and do the same with my Macbook.

    Hopefully, 10.5.3 will come out before I absolutely need to do it, and it will fix this issue once and for all.
  • straymonkey Level 1 Level 1 (0 points)
    needsomeihelp wrote:
    Has the above worked for anyone yet? Please share your experiences! Thanks everyone.

    Sorry, should have made mine more clear. Yes these worked for me. What I found was that it was a multiple sets of things that was causing the slowdown. Everything from corrupt prefs file, to my neighbor buying a new wireless (using my channel) and having a 3rd DNS server that was no longer working.

    I collected all the solutions so if anyone is having troubles, they can just pick and choose which ones they want to try.
  • needsomeihelp Level 1 Level 1 (95 points)
    Great, thanks for the reply.
  • needsomeihelp Level 1 Level 1 (95 points)
  • mnigara Level 1 Level 1 (0 points)
    Can't thank you enough straymonkey! After upgrading to Leopard last week (clean install, but I brought my Users folder over), I was having a world of trouble with my wireless connection speed. But I turned off IPv6 and deleted the preference files you mentioned and now I'm back to my previous DSL speed. Worked for me.
  • s1ipx Level 1 Level 1 (0 points)
    Hey everyone, I had a similar problem to above...
    I just thought I would let everyone know, there seems to be a fix for this which is explained here:

    After MONTHS of slow Internet, this blog post FINALLY fixed my problem.
  • William Kucharski Level 6 Level 6 (14,940 points)
    BTW, this is what several of us have referred to in several threads when we've said to change your DNS settings to use OpenDNS' DNS servers.

    For a variety of reasons (unrelated to Mac OS X), many ISPs' ancient and standards-defying DNS servers are beginning to show problems that result in excruciatingly slow web surfing.

    Many Vista machines have also been bitten by the same issues and can be fixed in the same way.
  • lashman Level 1 Level 1 (0 points)
    Here was my solution. (none of the others worked for me)

    I changed the security on my netgear router to none. BUT I added wireless security of only registered mac addresses can connect. Hopefully this is safe enough. My speeds on my Macbook jumped from 4,000kbps to 10,000+kbps. There was no change to my wife's Windows machine however. Maybe my "n" card is faster than her "g" card even though it is not an "n" router. ???

  • Ballresin Level 1 Level 1 (0 points)
    Problem with MAC addresses is they can be spoofed. I could get on your wireless in a matter of seconds (if you were actively connected).
  • younker_dl Level 1 Level 1 (0 points)
    I tried the methods posted in this thread, but with the delayed_ack change to 0, I got the AFP copy speed from 700K to 1M, not a big improvment, I have also tried to copy a file from my iMac to MBP with FTP, the speed is about 2.7M, so there should be some problems of Leopard system.

    My settings are listed below:
    iMac 24" running Leopard 10.5.5 with cable connect to TP_LINK 941 router
    MBP running Leopard 10.5.5 with wireless 802.11N connect to the router.

    I have checked the connection speed of the wireless connection by using the network utility, it reports the speed is about 130MBPS, so it should not get so slow speed to copy files from my iMac to MBP by AFP/SMB.
Previous 1 7 8 9 10 11 Next