Previous 1 2 3 4 5 Next 163 Replies Latest reply: Oct 29, 2008 7:49 PM by younker_dl Go to original post
  • Troy Pickett Level 1 (15 points)
    I have noticed the same problem as well, and thought it was my router. Took it to the apple store and watched them transfer files across it at very high rates of speed. (Sigh) But, they were using iChat. I went home, tried it from my G4 desktop to my MBP laptop, file speeds in excess of 8MB/sec. Try to move the same file through finder and file sharing, nothing. Movies won't stream. Can control the other computer, and watch video on screen sharing with amazing clarity, so speed of the connection seems not to be my problem.

    Finally, some light.

    For records:
    File transfers plugged in to the host computer ethernet directly, OK.
    iChat across network, OK
    Internet, OK
    Screen Sharing, OK
    File transfer across local network, useless.
    10.5.2 on both computers
  • matthew.e Level 1 (10 points)
    i have just posted a bug report, thanks for the tip!
  • Murpheous Level 1 (0 points)
    I'm seeing this problem too (slow LAN, fast internet). I listen to iTunes music wirelessly (802.11n) over a network share and intermittently, though often, the songs will start to skip or halt. iTunes often times out as it waits for the artwork to load at ~36 KB/s. The problem goes away if I'm wired.

    The music files are stored on an external HDD, connected to a Mac mini which is sharing the music over AFP. The mini also has 10.5.2.

    I'm 100% certain this did not happen until I installed 10.5.2.
  • kodafox Level 1 (5 points)
    This is a pretty big problem. I hope Apple's working on a (quick) fix. I don't think I can wait for 10.5.3 to come out.
  • Paul A. van der Zwan Level 1 (20 points)
    Same problem for me, starting after the 10.5.2 update I am seeing wireless file copy operations drop in speed after a while.
    Normally when the copy starts I get about 2.5-2.7 MB/s according to menumeters but after a few minutes it drops to about 50 kB/s. Sometimes it speeds up again.
    This is between a macbook (c2d 2.0 GHZ) and an iMac G5, both running 10.5.2.
    The iMac is connected using ethernet and the macbook is wireless.
    There is a Linksys WRT54G in between.
    Nothing has changed in this setup, except for the upgrade to 10.5.2, and this problem NEVER happened before the upgrade.
    If I hookup the macbook to the ethernet cable I get normal speed ( 11 MB/s) , if it survives the location switch because starting with 10.5.0 it has a nasty habbit of completely locking up most of the times I switch between ethernet and wireless, and I mean lockup, not even the mouse cursor moves and a hard power down is the only option.
  • donaciano Level 1 (5 points)
    I've got it too. iBook on 10.5.2 and intel iMac on 10.5.2. Internet is nice and fast, but file transfers between the computers over wireless (Airport Express) starts out fine for 1 or 2MB then drops to around 35k.
  • JOHN ALBERGO Level 2 (235 points)
    donaciano wrote:
    I've got it too. iBook on 10.5.2 and intel iMac on 10.5.2. Internet is nice and fast, but file transfers between the computers over wireless (Airport Express) starts out fine for 1 or 2MB then drops to around 35k.

    Those numbers are very familiar to me. I share my itunes music folder from my mac pro to a macbook-pro. Worked well under Tiger, though I had to give admin rights to the other account.

    Now I get the familiar symptom -- an initial burst of speed, followed by about 35KB/sec. Not too good when my Wife is trying to put a movie onto her iPhone.

    It's hard for me to say when it started, as there were a number of upgrades on both machines in a short period of time. But I didn't notice problems until after the Graphics Update, which I applied to the Mac Pro, but not the MBP. All my transfers are from the Mac Pro to the MBP, though they are initiated on the MBP, either by iTunes, or a direct Finder copy -- both show the same traits.

    I also find that wiring the Mac Pro into the router gives much better results (the MBP is strictly on Airport). With the Mac Pro wired, we can get multiple Gigabytes across at high speed, but even this eventually succumbs to the slowdown -- back to the same 35KB/s crawl.

    One other airport weirdness, which I'm pretty sure was introduced by the Graphics Update -- I can no longer connect to our router on channels 9 or 10, but internet speeds and airport signal are fine on channel 4. On those other 2 channels I can see our neighbors from across the street but my local router never shows up. I mention it here even though it isn't directly related to the specific topic, because maybe it is somehow related.
  • Joshua Metts Level 1 (5 points)
    Finally found a thread that states exactly the problem that I have been having. It started right after the upgrade to 10.5.2. Before I use to stream videos from my iMac G5 to my iBook G4 without any problems at all. Then I noticed that while watching the first few minutes the video would freeze and my download speed would drop to 20 KB/s-60 KB/s. I also have the same results with trying to transfer any large file.

    Please Apple read this thread and get it fixed, it was working before get it going again.
  • JOHN ALBERGO Level 2 (235 points)
    OK, maybe this is a return of a bug that I ran across just about 2 years ago? It had to do with the TCP setting "delay_ack". I have changed delay_ack from 3, to 0 on both machines and it seems to have done the trick. I hesitate to call it "cured", but so far so good, with both machines on wireless I am back to the speeds I would expect and the transmission rate seems rock solid.

    Here is a website which has a downloadable script you can use to install a "startup item" that puts this setting into effect at startup time. This makes it easy to remove.

    or if you just want to try it out for test purposes you can enter this command from Terminal, which will stay in effect only until reboot:

    sudo sysctl -w net.inet.tcp.delayed_ack=0

    you'll need to enter the admin password.

    Try this on both machines involved in the LAN transfers and see if it helps you. I suspect the delayed ACKs were being delayed inordinately long.
  • Troy Pickett Level 1 (15 points)
    I just tried the fix above, and it works for me too. I'll try some other things, test wise, but at the moment this seems like a working fix.

    The terminal line:
    sudo sysctl -w net.inet.tcp.delayed_ack=0

    The downloadable script:
  • FlashYourWeb Level 1 (0 points)

    I noticed you are running a G4. This startup item says it is for Intel Macs. Did you get it to work on your G4? I am running a Powerbook G4 and a Dual G5 and I want to know if I can safely use this as well, since I am having the same issue.

    Your thoughts are appreciated.

    Here is my history of the issue.

    GDL3D at the bottom.
  • Troy Pickett Level 1 (15 points)
    I didn't need to. When I installed it on my MBP, my problem went away. I am not downloading from the G4, so I wouldn't see it. I will try it and see, but I have a feeling that it might still be there. I did see something on the page with the downloadable script about PPC's but I don't remember what it was.

    Hope you find a solution to your problem.

    Message was edited by: Troy Pickett
  • FlashYourWeb Level 1 (0 points)
    Thanks Troy. Yes, it does mention in the comments that it's useless for PPC. This is soooo frustrating. When ever I am using Dreamweaver or Photoshop with files and directories over the wireless network, I get sooo many hangs during work. File transfers cause the same issue. I am going to have to get my Admin involved to diagnose what is going on. If i find out anything i will report back.
  • FlashYourWeb Level 1 (0 points)
    Small Update: I have yet another G4 933MHz running 10.4.11. It's just a media server for me. Movies, Music, Photos etc... It is connected to my Linksys via ethernet. I connect to it fine with my Powerbook and G5 and it doesn't drop. Plus file transfers to my Powerbook (Wireless) from the 933 (Ethernet) are at G speeds from the Linksys. The speeds are just as they should be. Just finished transferring 700MB file in about 12 Min. That is decent. From my G5 that would take over 2 hours!

    The problem ONLY seems to occur when attempting to transfer files and connect to the G5 which is wirelessly connected to the router. So wireless (G4) to wireless (G5) connections seem to only have this problem everyone is describing. Though it may just be the version of Tiger that my G4 933MHz is running doesn't have this problem. Not really sure what this means, but I wanted to add this functionality update to the issue.

    Hope this helps Apple troubleshoot this. I hope this issue is keeping someone up at Apple tonight! Cause I am sure not getting any sleep.
  • mattsigal Level 1 (0 points)
    I just installed the script on both my iMac and MacBook (both Intel)... and, you are right! It seems to have solved the problem.

    A 1.5 GB file transferred from the iMac to the MacBook in ~10-15 minutes (about right), with no brutal slowdowns. I also tested MediaLink (media streaming from iMac to PS3 - which wasn't working before) and that works again too!

Previous 1 2 3 4 5 Next