2 Replies Latest reply: Feb 16, 2008 8:02 AM by skiphunt
skiphunt Level 1 Level 1 (10 points)
I don't know if this is related.. but I've been battling multiple problems ever since I upgraded my G5 to Leopard a week ago. Everything was perfect under Tiger.

Well, I think I've got everything solved except two last things.

1. My 750GH Maxtor Firewire drive... when I plug it in... does not show in the desktop and it causes both my internal drive and two other Firewire enclosures to disappear from the desktop. I can see all of them mounted in the disk utility, but if this one drive is plugged in.. all icons disappear from the desktop. If I unplug or unmount the 750GB drive.. everything comes back.

I've reformatted this drive, etc. This does not happen on my MacBookPro. The drive mounts fine on that. I've tried different cables, I've tried USB (it's a triple interface Maxtor) and nothing seems to work. I would assume there's something wrong with the drive and not my desktop... but the drive works fine on the MacBookPro.

PLEASE!! Any clues would help...

The other problem that only occurred directly after upgrading to Leopard... is that my graphics now get corrupted and garbled. I've got two video cards running two LCD monitors. The card giving me problems is the ATI Radeon 9800 Pro (256MB). What happens is.. first all the window shadows and top menu bar start getting checkerboard patterns.. then the whole screen starts getting variants of different colors and checkerboard patterns. After awhile and refreshing the screen a few times... the problem goes away for a bit. Then comes back.

Again, this card and my entire system and drives were working fine under Tiger. Now, I don't know if I have a bad card? Is there something wrong with Leopard on my G5 2Ghz DP? Did my Maxtor 750GB triple interface drive just go bad with the upgrade?

I don't know where else to look, I'm guessing the "geniuses" at the Apple store won't help me since this machine is out of warranty. Any help would be HUGELY appreciated. I've been battling all these problems ever since I started the Leopard upgrade 4 days ago and have not got much sleep.

G5 2Ghz Dual, Mac OS X (10.5.2)