2 Replies Latest reply: Feb 16, 2008 10:17 AM by skiphunt
skiphunt Level 1 (10 points)
I don't know if this is related.. but I've been battling multiple problems ever since I upgraded my G5 to Leopard a week ago. Everything was perfect under Tiger.

Well, I think I've got everything solved except two last things.

1. My 750GH Maxtor Firewire drive... when I plug it in... does not show in the desktop and it causes both my internal drive and two other Firewire enclosures to disappear from the desktop. I can see all of them mounted in the disk utility, but if this one drive is plugged in.. all icons disappear from the desktop. If I unplug or unmount the 750GB drive.. everything comes back.

I've reformatted this drive, etc. This does not happen on my MacBookPro. The drive mounts fine on that. I've tried different cables, I've tried USB (it's a triple interface Maxtor) and nothing seems to work. I would assume there's something wrong with the drive and not my desktop... but the drive works fine on the MacBookPro.

PLEASE!! Any clues would help...

Did my Maxtor 750GB triple interface drive just go bad with the upgrade?

I don't know where else to look, I'm guessing the "geniuses" at the Apple store won't help me since this machine is out of warranty. Any help would be HUGELY appreciated. I've been battling all these problems ever since I started the Leopard upgrade 4 days ago and have not got much sleep.

G5 2Ghz Dual, Mac OS X (10.5.2)
  • Thomas Bryant Level 6 (13,865 points)
    Hi! For starters do all the firewire enclosures have separate power supplies and are they daisy chained together or connected to onboard ports? Tom
  • skiphunt Level 1 (10 points)
    I have 3 Firewire drives. All FW800. I have a Lacie, an aftermarket enclosure with a Seagate drive, and a Maxtor triple interface 750GB drive. I also bought a Buffalo 1T Duo drive to backup through this.

    ALL drives would perfectly on my MacBookPro Intel Dual Core machine running Leopard.

    ALL drives EXCEPT the Maxtor 750GB work perfectly on my Desktop 2Ghz DP. What happens is, everything is fine... everything is mounted... then I plug in the Maxtor 750GB, there's a delay, then all icons disappear from my desktop. I have Disk Utility open and can see they are ALL there and ALL mounted. Then, I unmount or unplug JUST the Maxtor 750 and everything comes back.

    They all have their own power supplies and I have 3 daisy-chained with the Maxtor 750 last. The Buffalo I just bought to back up to while I figure this out.. so It's just mounted on my laptop for now. I have reformatted ALL the drives, I've tried a different cable for the Maxtor 750 and even tried FW400 and USB as well. Does the same thing regardless.

    At this point, I'd say that the Maxtor 750GB has something wrong with it... it's under warranty so I could just get a replacement. What get's me is that it worked fine before he Leopard upgrade and still works fine mounted on my MacBookPro.

    I haven't tried powering everything down, unplugging, etc. since everything else still works fine. Maybe I should?