Previous 1 2 Next 23 Replies Latest reply: Mar 3, 2009 4:48 PM by hellyski
Dave Marsh Level 2 Level 2
I upgraded to 10.5.2 this week and was posting a future event in iCal (several years out) and wanted to see if it posted correctly. So, I clicked in the search field in the upper right corner of the window and typed in the text I entered for the event. The columnar listing area appeared at the bottom of the window, but displayed no contents. I then manually went to the future date and found the event just fine.

In Tiger when I entered text in the search field, the columnar area at the bottom of the screen actually listed the results of my search, but I can get no results in Leopard.

I searched this forum for comments on this issue and found a similar thread from last fall, but none of the suggestions made at that time work for me in 10.5.2.

Can anyone here confirm that iCal is not displaying search results for them? I'd like to know if it's my system, or the application itself.

I find it's working on my upgraded G5 iMac, but not on this new Intel iMac.

Thanks for listening...

2.8GHz 24" iMac w/4GB RAM/750GB HD, Mac OS X (10.5.2)
  • Dave Marsh Level 2 Level 2
    Ok, I've tried it on my other Macs running Leopard (G5 iMac, MacBook, G4 PowerBook) and search works as expected, displaying the results in the list at the bottom of the main window. It's just this new Intel iMac that's not working properly.

    I've tried exporting one of my calendars (although search doesn't work with any of my calendars on this iMac), deleting it, then importing it back in, but that doesn't help.
  • Ferd II Level 7 Level 7

    Find works for me in iCal 3.0.2.

    Try refreshing the iCal plist file.

    Quit iCal and find the file in your Macintosh HD/Users/yourusername/Library/Preferences Folder. Drag the file to your Desktop, log out/in or restart and check iCal for normal behavior.

    Another troubleshooting step which has been successful for many users has been to quit iCal and drag Macintosh HD/Users/yourusername/Library/Application Support/iCal/Sources Folder to the desktop. Once again restart iCal and check for normal behavior. I removed this file from my system because I found that it only contains remnants of iCal 2.0.X.

    Additionally, you may try deleting any cache files in your Macintosh HD/Users/yourusername/Library/Calendars Folder.

    If iCal works properly after either step you can discard the files/folders on the Desktop.


  • Dave Marsh Level 2 Level 2
    Thanks for the reply.

    I tried the plist rebuild, with no effect. Leopard no longer has an iCal folder in the user Library, so no way to remove a corrupted index to rebuild. I also tried deleting the Calendar cache file and letting iCal rebuild it, but that also didn't help.

    I believe the problem is at the application or system level. I logged into another admin account on this Mac and tried posting an event then searching for it, with the same blank/negative results, so the issue affects all users on this Mac.

    I'm going to rerun the 10.5.2 Combo updater to see if that helps.
  • Dave Marsh Level 2 Level 2
    Reinstalling the 10.5.2 patch didn't help, neither did Repair Permissions, nor copying over another copy of iCal from our MacBook. So, it must be something in the System that's specific to supporting iCal's search/indexing feature.
  • Dave Marsh Level 2 Level 2
    I couldn't find a specific iCal mdimporter in the /Library/Spotlight folder, so I'm trying a complete reindexing of the startup volume to see if that will force an iCal index rebuild.
  • Dave Marsh Level 2 Level 2
    OK, issue resolved. Since I knew the issue had to be at the system level, and I couldn't find a specific iCal mdimporter, I simply went to System Preferences/Spotlight and added/deleted my startup volume from the "do not index" list to force a complete reindexing of the hard drive. When that was done, both Spotlight and iCal easily found my search items and displayed them in the list area at the bottom of the window.

    Thanks for your feedback.
  • Jorn Ake Level 1 Level 1
    Dave Marsh:

    Thanks for following through with this thread and giving your final solution. It cured my 10.5.2 iCal ills as well. Saved me a lot of hair pulling. iCal is only my life blood. So thanks again.
  • nigbo Level 1 Level 1
    It sounded great: I had (have) the same problem and trief your solution: no change, still the same problem. Did I forget something? Did you restart your computer at any point? Some other idea?
  • Hendo08 Level 1 Level 1
    All very good stuff and I've tried everything I can, but Spotlight (and the search on ICAL itself) still refuses to show any results. MY Macbook, also running 10.5.2 has no problems at all. Anybody got any other ideas?
  • Thierry Rayna Level 1 Level 1
    I had a similar problem. The symptoms were:
    - Search in iCal did not work at all (no result, what so ever, returned)
    - Search in Spotlight worked (the same search that did not return anything in iCal would return To-Dos and events in Spotlight)

    I started by backing up and restoring, but this did not work.

    I then read a lot about potential solutions involving quite extreme things (such as reinstalling Leopard). I then found out that I could solve this issue by simply exporting each calendar and then reimporting them without deleting anything.

    For example, I had a "Home" calendar that I exported. I then chose "Import" then picked the exported "Home" calendar and chose my "Home" calendar in iCal as destination calendar. I feared that I would end up with duplicate events and to-dos, but no, iCal is smart.

    Once this is done, my search in iCal started to work again and searching items on this calendar would return correct results (as did spotlight).

    I then did the same with all my other calendars, and voilà!

    Hope this helps
  • Michel_IT Level 1 Level 1
    My iCal search doesn't work.
    10.5.4 (but also previously).
    None of these techniques worked out.
    I confirm that creating a new account from scratch (admin)does not resolve the problem. So it is really at root level.
    Destroying the spotlight index folder (root level), thus forcing full reindexing, doesn't resolve the problem either.

    Hope someone can help.
    I really hope Apple will enhance iCal on many aspects(the version 2 was much better).

  • lubner Level 1 Level 1
    I'm having the same problem. I just updated my OS to 10.5.4 on an Intel MacBook Pro. I can look at my current calendar and type titles of items in view and nothing shows up in the search column. Let's hope for a remedy soon.
  • Easyofff Level 1 Level 1
    Just go to system preference, spotlight and uncheck ical, quit ical and restart ical.
  • lsnewton Level 1 Level 1
    Thank you, Easyofff

    More simple then that is impossible. And it works!!!
Previous 1 2 Next