1 2 3 4 5 Previous Next 156 Replies Latest reply: Jun 13, 2014 7:30 PM by Michjimz Go to original post Branched to a new discussion.
  • 30. Re: No AirPort card installed!??
    Hershal Level 1 Level 1 (0 points)
    Bought a new 2009 17" macbook pro a few days ago. This is about the 5th time I have had the machine turned on. I was sitting doing some work, the cursor froze. I rebooted. Then I noticed I was not connected to my WiFi. I went into preferences and tried to turn my Airport card on and it refused. I restarted the computer and now it say "no airport card installed".

    Clueless to why this is happening. Apparently $3100 buys you something that breaks in few days. Will take back to the store tomorrow. Any thoughts on how to fix this with these new mbps that don't allow you to take the battery out?

    Thanks,
    Matt
  • 31. Maybe this will help
    Hardkraft Level 1 Level 1 (0 points)
    I had the same problem and I followed all the tips listed here and more from other threads to no avail. It happened to me after I updated to 10.5.6. I didn't notice the problem until I rebooted a few days later. In addition to no airport card being recognized I was getting "AppleAirPortBrcm4311.kext' was installed improperly and cannot be used." on bootup. I reinstalled the system from disk and then realized that even though it took almost an hour it didn't really install anything. So I deleted the whole /System/Library/Extensions/IO80211Family.kext and reinstalled the system again. This time it worked
  • 32. Re: No AirPort card installed!??
    Embryo Level 1 Level 1 (0 points)
    I'm 6 months into the same problem except when I move the Macbook, I get a grey screen of death. Took it to the Apple Store in Victoria Gardens 2 hours away. They kept it for three days. Said it was fine. Crashed before I even took it out of the store. They did not assist me further other than to say do a new OS install. I did. Worked for 2 days. Lost airport again and again. Figured the movement thing was a bad "smart" sensor on the HDD crashing due to sensing movement. I just replaced the HDD and there is again, no Airport Card Installed. Fresh HDD, fresh OS 10.5.6. Reset the PRAM, etc. I LOVE macs. I have spend over $2 million dollars in my lifetime on them. But, I can't even use my own now. Apple, you really need to address this problem, Please!
  • 33. Re: No AirPort card installed!??
    nam230 Level 1 Level 1 (0 points)
    Hi. I alternate between using my Airport card and the Ethernet cable. I have never encountered this problem until recently... when I decided to go wireless. "No airport card installed" is shown when I click the Airport icon. I haven't done the rebooting suggestions posted here, because it doesn't seem to be a final solution to the problem.

    Has anyone noticed if Apple has issued any official information on this matter? This doesn't seem like a fluke as it's widespread.
  • 34. Re: No AirPort card installed!??
    neandertal Level 1 Level 1 (0 points)
    Took mine in to the local Apple Store Monday, as it was freezing completely requiring a hard reboot. When it would come back up the computer would either say No AirPort Card Installed or I would have a blank pie slice which when clicked would let me try to turn the AirPort on, just to no avail.

    The Store took it for an instore repair saying it is a faulty AirPort card...we'll see. I'll update when I get it back.
  • 35. Re: No AirPort card installed!??
    David Hamilton1 Level 1 Level 1 (5 points)
    Same issue, Hershal. Did you find out what was wrong?

    David
  • 36. Re: No AirPort card installed!??
    David Hamilton1 Level 1 Level 1 (5 points)
    Was it a card problem? Did they get you a new one?
  • 37. Re: No AirPort card installed!??
    neandertal Level 1 Level 1 (0 points)
    So far...it sat at the apple store for 1 week, until a genius installed a new card. Didn't work.

    They have sent it to a repair center, which took 3-4 days and has been in "repair" status with them over the holiday weekend. Called today to see what's going on and was told a genius would be calling me in twenty minutes with an update...it's been 3 hours...

    Needless to say I'm getting a little ******.
  • 38. Re: No AirPort card installed!??
    neandertal Level 1 Level 1 (0 points)
    I picked it up from the Apple Store on Friday the 29th, in all the process took 19 days. They had overnighted it to the store on Wednesday and it arrived Thursday and hadn't received a call so I just went to the cashier and asked her to give it to me.

    The work they ended up doing was replacing the logic board and the airport card.

    It's working fine now. Not the best customer service experience I have had, but the store was a madhouse, so I can slightly understand.
  • 39. Re: No AirPort card installed!??
    RossMcRoss Level 1 Level 1 (0 points)
    Just got my 15" 2.53 Unibody MacBook Pro back from the AppleStore in London...took it in to get the known issue of the Nvidia 9600GT graphics card problems looked at...

    They replaced the logicboard. Got it home. "No AirPort Card Installed" and no Bluetooth either. And it doesn't always sleep when the lid is closed.

    One problem fixed (well, i hope so) and another problem appears!!

    A £1500 paperweight.

    Gotta take another trip back to the other side of the city to get it fixed tomorrow...called them up and i was politely told that i should've checked before i left the shop. So next time i'm going to thoroughly check every port, test burn a dual-layer DVD, record some audio with a FireWire interface, set-up an ethernet network... oh, i think Apple should have done that...

    And the 'Genius' bar is closed on friday because of the bloody iphone launch.
  • 40. Re: No AirPort card installed!??
    RossMcRoss Level 1 Level 1 (0 points)
    ...so i took another trip to the Apple Store and they were wonderfully helpful. Offered to replace my computer entirely. So we chose the config and i'm just need to wait for it to arrive....

    nice service.
  • 41. Re: No AirPort card installed!??
    Josh Snavely Level 1 Level 1 (0 points)
    Wife's 13 inch Japanese MB just suffered the same problem. Followed the CMDOPT+PR and worked great. I just hope this is the first and last time I see this. Her MB is Japanese and 3 years old. Any fix would result in flying it out the Japan.....
  • 42. Re: No AirPort card installed!??
    ColinWhitworth Level 1 Level 1 (0 points)
    I solved this issue by downloading the combo 10.5.8 installer from Apple and installing it. My issue began after installing 10.5.8 update from Software Update.
  • 43. Re: No AirPort card installed!??
    jolly1312 Level 1 Level 1 (0 points)
    I encountered the same issue. Just remove the extension cache and mac will rebuild it. Simple and got it working in 2 min ( I still don't know the root cause of the problem)

    Just do this
    sudo rm -rf /System/Library/Extensions.mkext

    Enter the password and after a minute reboot the system. Good to go!!
  • 44. Re: No AirPort card installed!??
    JoshMSaul Level 1 Level 1 (0 points)
    This worked perfectly for me.

    Thanks so much for your help.
1 2 3 4 5 Previous Next