6 Replies Latest reply: Feb 21, 2008 9:27 AM by violasebastian
violasebastian Level 1 Level 1 (0 points)
I have an Earthlink email account that is set up on my IPhone. When I am at home I can send and received emails. When I'm away from home, I can received emails but cannot send them. I contacted Earthlink and no one there seems to know how to make the settings work. Does anyone know what I need to do?

MacBookPRO
  • DaVBMan Level 6 Level 6 (9,265 points)
    It is because they block outgoing smtp unless you are on their network. When at home on Wifi, your WiFi is on their network. When out, you are on Edge. Many "cheaper" ISPs do this as a restriction as well as to protect their mail servers from being taken over for sending spam (though there are better ways).

    Search here for CPMX.COM (or something like that) to see threads of how to use a free SMTP server to send when on Edge, but note, when at home, you won't be able to send while on Wifi (catch 22)

    Message was edited by: DaVBMan
  • Allan Sampson Level 10 Level 10 (123,370 points)
    Are you using Earthlink's authenticated SMTP server which is required for this?

    Server Name: smtpauth.earthlink.net

    Server Port: 587

    Use SSL: Off or not selected.

    Authentication: MD5 Challenge-Response

    User Name: Your entire Earthlink email address.

    Password: Your Earthlink account password - the same password used to check the incoming mail server for new messages.
  • Allan Sampson Level 10 Level 10 (123,370 points)
    It is the other way around.

    It is the ISP used for connecting to the internet (if other than your own) that blocks the use of SMTP servers that are outside of their network or not provided by the ISP. Some block the use on Port 25 but will allow if on a different port such as 587. Some block all SMTP servers that are outside of their network unless the SMTP server is authenticated. Some block its use regardless which is rare.

    Apple is not an ISP but is an email account provider with .Mac account. .Mac has an authenticated SMTP server which is why I can send with my .Mac account regardless the ISP used for connecting to the internet - unless I'm connected to an ISP that blocks the use of all SMTP servers that are outside of their network (or not provided by the ISP) regardless if authenticated or not.

    This is also why the folks with a Gmail account can send regardless the ISP used for the internet connection since Gmail has an authenticated SMTP server.
  • violasebastian Level 1 Level 1 (0 points)
    I changed all the outgoing settings to the ones given and still get the message Cannot Send Mail, check the account settings for the outgoing server "smtpauth.earthlink.net"
  • Allan Sampson Level 10 Level 10 (123,370 points)
    Try using Password for the authentication type instead of MD5 Challenge-Response.
  • violasebastian Level 1 Level 1 (0 points)
    Not to look a gift horse in the mouth but I'd thought I'd share this.

    When the new settings didn't work, I'd tried putting in earthlink.net:587 in the host name, which is how it got set up when I first brought earthlink to the IPHONE. Instead of 587, however, it was 25. I went to my earthlink account and tried to send an email -- which was successful. I went back to settings to double check them and found that there were no settings for the Outgoing Mail Server. I went back to my email and tried sending another email and that too was successful. I have no idea why this works but I can now send and receive earthlink emails on my IPhone.