Previous 1 2 3 4 5 Next 90 Replies Latest reply: Jun 13, 2008 6:55 AM by bookmanjb Go to original post
  • manuwj Level 1 Level 1 (0 points)
    I found this and it works for me:

    1. Open print/fax pref
    2. Go to + (add printer)
    3. Go to IP and drag down to HP Jetdirect.
    4. Open Airport Utility and click on express to get IP address (mine was
    5. Type this in "Address" back in Fax/print.
    6. Change the "Name" to whatever you want (for example Samsung ML).
    7. Print Driver to use is ML-2010 (look in M's), not any Samsung listed driver (in the S's).
    8. Restart Airport and the Printer
    8. Try it! It should work!!

  • Jan M Level 1 Level 1 (70 points)
    manu, you´re great. that procedure fixed the printing error.
    when searching I saw the hint to reset the printing system somewhere already, but didn´t understood what to do in the IP tab - thank you for your description!
  • BeckyFiedler Level 1 Level 1 (0 points)

    Your fix worked for me, too. Of course, that was only after I spent about an hour on the phone with Apple. <sigh> And then a call to Samsung. They didn't even pretend to help - just said check back for an updated driver and no clue for an ETA. Worthless.
  • Sinna Level 1 Level 1 (0 points)
    I think it is also. Look at my recent post about my problems printing & discussion with Samsung
  • greatwhitenorth Level 1 Level 1 (0 points)
    Manu- thank you very much- this worked for me and I can now print from my Imac and my Macbook Pro- Apple should pay you.
  • oru-art Level 1 Level 1 (0 points)
    Hello thanks this worked for me also both macbook and macpro with airport thanks again
  • rwn in sf Level 1 Level 1 (0 points)
    Many thanks Manu! This worked like a charm and I can finally print with my new TC and Samsung ML.
  • Lee Sachs Level 1 Level 1 (110 points)
    Well, I'm glad some of us were able to print...anything out there for us HP users? I've got an officejet 6210xi and it used to work with the Extreme, but no more. Why now? And also, is there any way to do this using IP? I know the IP of the Extreme, but what's the IP of a printer connected to it?
  • BeckyFiedler Level 1 Level 1 (0 points)
    The IP address of the USB printer attached to an Airport Extreme is the same as what you see for your Extreme (I think). You can get it from the Airport Utility. Mine is I think that's the default so yours might be the same. You can find it by opening the Airport Utility. It's on the first screen if you're using Airport Utility 5.3.1.
  • AtmakuriNY Level 1 Level 1 (0 points)
    wow ! i have been trying to find this solution for the last few days..tried it on a HP LaserJet connected to Time Capsule. Works like a charm.

    Thank you !
  • Lee Sachs Level 1 Level 1 (110 points)
    I understand, but that's not working for me. The IP in my case is different b/c of the router scheme ( but it shouldn't matter as long as you have a valid IP, which I do. The driver's just not running. Keep thinking....
  • saridt Level 1 Level 1 (0 points)
    Essentially, the Airport Express will not work with all printers. I've spoken to tech support about it. It could have been and most likely is the new firmware. There is no commitment to fixing the problem and Apple doesn't really see it as their problem, but rather a printer problem. Actually it is a poor execution on partnerships between Apple and companies like HP. It is an industry problem that extends past this product and into the areas of standards and cooperation.

    I will be returning my Airport Express and Time Capsule.
  • saridt Level 1 Level 1 (0 points)
    For windows users there might be one other solution. Once the printer is setup and then fails on you:

    1. Go into Control Panel
    2. Select Printers
    3. Select the printer at issue
    4. Open Properties
    5. Go to ports
    6. Select Configure Ports
    7. Change the "printer name", not the port name, from the one given by Bonjour to the IP Address for the AE ( or whatever it is for you

    This worked for me on an XP machine. There seems to be a problem with the name furnished by the AE and Bonjour and it is not translating it to the right location.
  • TxWranglr Level 1 Level 1 (0 points)
    Wow, this solution worked for me too! I have an Epson Stylus CX4600 that printed beautifully through my Airport Express for 4 years. I just upgraded my OX to 10.5.2, and then it wouldn't. Printed when connected directly to my laptop via USB, but no longer through the Airport.

    However... it may be just my imagination, but it seems to print a little more slowly. Not that I'm complaining, as I'm not in any hurry!

    My only complaint is that someone at Apple should have been able to tell me this. Either that, or Leopard should have just "made it work."
  • Ravenflight Level 1 Level 1 (0 points)
    I have a Samsung Color Laser Printer CLP-300 which did not work when using the ML-2010 driver. However when I followed steps 1-8 and selected the correct driver CLP-300 (in the C's) instead of ML-2010 in step 7 I was finally able to print color wireless to my Airport Extreme under OS 10.5.2
    Thank you manuwj!

    P.S. I also installed AirPrintFix and lowered the speed down to 2Mbit/sec. I don't know if this was useful in making the printer work with my ancient Airport Extreme- I will now be experimenting with raising the speed up to 12Mbit/sec.
Previous 1 2 3 4 5 Next