10 Replies Latest reply: Jul 17, 2008 3:17 AM by Jagdeep Thukral
LGJ001 Level 1 Level 1 (20 points)
I know a lot of people are having trouble with MBA and Airport, but my problem didn't seem the same as theirs, so I', starting a new topic in case this info is useful to anyone.

I got my MBA (1.8 SSD) on Saturday, and right off I noticed that the Airport didn't seem to be as good as my MacBook Pro. It wouldn't connect in my home office (where the Airport Extreme Access Point is) at all. Other parts of the house were OK but not brilliant. Then on Wednesday I couldn't get it to connect at all. It would see the SSID, but not connect to it (error message was "Connection Timeout"). I tried everything to resolve it: Security Off / WEP / WPA, swapping out the Airport Extreme for my old Netgear 824, restricting the connection to 102.11g only/ b only. None of these worked. But through all the changes my MBP and my work IBM Thinkpad worked flawlessly. Eventually I rolled back the MBA to a timemachine backup from before it stopped working but still no joy. So now I'm thinking hardware fault.

Eventually I rang Apple support, who were really good. The second level engineer got me to create an an hoc network on the MBA which the MBP COULD connect to, but the reverse was not true (the MBA could not connect to an ad hoc network created on the MBP). They concluded hardware fault and I took the Air back to the Apple store and got another machine... which we checked in store, but displayed exactly the same problem when I got home!

So now I'm thinking less hardware fault than interference, so I started turning off any appliance that could interfere (Cinema Display, cellphone, cordless phone etc). But still the MBA would not connect but the MBP always would.

FINALLY I reconfigured the Airport Extreme for 5Ghz 802.11n only, and hey presto - the MBP and the MBA both work flawlessly! Problem solved! (With hindsight I should have tried this earlier). Of course nothing else in the house (Airport Express for AirTunes, Media Centre, work Thinkpad) will talk 802.11n, so I have had to set the old Netgear up to use the Airport Extreme as an internet gateway, and so I now have both 5Ghz 802.11n and 2.4Ghz 802.11g in the house and everything works!

So, in conclusion, even though (the Apple store assure me) the MBA uses the same Airport hardware as the MBP, there is something about its implementation that makes it more susceptible to certain types of interference (although I haven't yet tracked down the source).

If you're experiencing odd Airport failures with your MBA, try different frequencies / channels to check for interference.

MacBook Pro 1." C2D, Macbook Air 1.8 SSD, Mac Pro 2.8, Mac OS X (10.5)
  • psendeavor Level 1 Level 1 (10 points)
    Yes, that's what happened to me too... My MBA's airport refuses to work in my home office, on my desk just besides my 24" iMac, two external lacie HDs and external boxes, but works like a charm everywhere else in my home. Took me two days to find out that the problem is nothing else than interference.... I'm now using the ethernet dongle in my office.
  • kp12 Level 1 Level 1 (0 points)
    My problem is in reverse, everything works fine in 2.4 Ghz, but I have problems when I switch to 5ghz.
  • Ken Stone Level 3 Level 3 (500 points)
    I had a very similar circumstance as the OP. I returned a MBA for replacement due to wifi problems at home. Brought home the replacement machine and same problem. Then realized that it's interference. I went into Time Capsule (I use this as a wifi router) and checked the Use Interference Robustness setting. No problems since then (and I don't have to exclude my non-802.11n devices.)
    ken

    Message was edited by: Ken Stone
  • Kim Kwan Level 1 Level 1 (5 points)
    I can say for certain that my MacBook Air (which is lent to me) has the same problem with a 2.4GHz AirPort Express (the old 802.11g one, not the new one). Unfortunately I don't have any 802.11n base stations handy so I can't test your solution.

    Great work though. I hope Apple takes notice of this.
  • boltz Level 1 Level 1 (5 points)
    None of the solutions described herein worked, so I called Apple today and spent a couple of hours on the phone discussing the timeout problem. They suspect my MBA may have a defective Airport card and told me to take it to an AppleStore or they could send a box to have it shipped. The really bad news is that the nearest store requires taking two days off work (one to deliver the computer and one to collect it). The store representative said it would take 7-10 business days plus shipping time to and from the store! However, using the direct shipping option would be 5-7 weeks! This is with AppleCare! Both the store and Apple technical support folks were polite but I find this degradation in service to be unacceptable. I have returned many Apple products for service and none has taken longer than 5 days. So my choice is to try to make do with no wireless connection or lose an enormous amount of time.
  • zerock Level 1 Level 1 (85 points)
    I have the same issue. if I set it to 802.11n(2.4GHz) it works fine, if I use 5GHz, it can't connect.

    I dont think it's the card but maybe it could be...
  • SchoonerMBM Level 1 Level 1 (0 points)
    Brilliant, similar problem - your fix works like a charm. In brief: MacBook Pro maintains AirTunes connection, identically configured MacBook Air fades/fails as distances approach 12 feet. Switch AirPort Express to 5MHz WLAN-N "only" instantly resolves (extends range to other rooms & distance ~40 feet, making all the difference. Environment: bungalow 2x4/drywall with three routers running: Linksys WLAN-N, Linksys WLAN-G, APEx, cordless phones. Problem detail: MBA/APE WLAN runs just fine until either Config APE or AirTunes attempted, whereupon menubar signal indicator shows rapid decay, times out; can config or play tunes only when MBA immediately proximate to APE (<4 feet), IFR (packet size) immaterial, APE power set to 100%, WEP2 security, BT off. MacBook Pro has no such difficulty, even with BT on. Instant "fix" by setting APE to "5MHz WLAN-N ONLY". Hoping I can extend that to a more impressive range with other switches & less noisy environment.

    Thanks!
  • Todd Brun Level 1 Level 1 (0 points)
    I may be having a similar problem--I am trying to share Internet connectivity from my rather old G5 desktop with an airport extreme card to my new MacBook Air. The MacBook doesn't even see my desktop's wireless network, though it sees many other wireless networks, and is able to connect to my wireless router at home. My old laptop had no problem connecting to the desktop's wireless network.

    Perhaps reconfiguring my airport card in some way would help. Does anyone know how to do that?

    Thanks a lot for your help.
  • konspyr Level 1 Level 1 (0 points)
    I have a similar problem. In my office network (windows nt server plus 5-6 pc with windows xp and a wifi access point zyxel G-507s) everything was working all right for 3 months. I could connect with my MBA and have both internet connection and server connection (file and printing sharing). After a power failure (i was not in my office) my MBA stop connecting to network. All the time a got this message "connection timeout" and some times after a lot of tries a got connected with a self-assigned IP (169.....) but no internet and no network sharing. At that time pc with a wifi card connected just fine as well as an iphone and some Hp palms. I bought a new access point (just in case something happened during power failure) but nothing. Yesterday i bought an airport extreme. At the everything seemed to be OK. I connected to internet and to my server but when i was trying to connect with a second MBA at the same time, the connection got lost. And from that time nothing happened.

    I forgot to tell you that all that time, my MBA worked excellent in my home wifi network (phillips wifi router) and both technicians from Apple and from the server installation company could not figure out what is happening......

    On Monday i am going to try your solution and if it works then i am obliged to you for a lifetime!!!!!
  • Jagdeep Thukral Level 1 Level 1 (5 points)
    THANKS. Exact same problem was on my MBP and more so on MBA. Ask me what I didn't do. From changing routers, settings, connecting directly via ethernet, changing ethernet cables connecting modem and router. I spent the whole night fixing the problem. Finally I googled the problem on my MBP and found your post. THANKS again.

    It would see the SSID, but not connect to it (error message was "Connection Timeout"). MBP worked a bit but not as good as it used to.

    After reading your post I realized that I had installed 4- 2.4GHz wireless cameras around my home. I unplugged all of them and Voila!!! My MBA worked as smoothly as ever. 2.4GHz cordless phones can also interfere. But if 802.11 n can resolve it too, I'll have my cameras back on. I'll buy the new router with 802.11 n support. Which one will be the best?