7 Replies Latest reply: Jun 16, 2008 11:39 AM by George Skarpelos
Gregory McBride Level 1 Level 1 (15 points)
Hello. I have a 23" Cinema Display that I connect to at work with my MacBook Pro. Recently, I got a second 23" Cinema Display for home. Ever since, whenever I connect my laptop to either monitor, all of my icons rearrange. They usually move to the right side of my laptop, even though I have the monitors preferences set to have the 23" as the main display. Whenever I try to move the icons, they snap back into place. And, when I click once on any icon and then click on the desktop, that icon moves to a new, seemingly random, location.

I know there are options to organize icons by name, date, etc. and I am assuming that I selected one of those preferences. But, I do not see an option to organize by "none." How can I keep my icons from constantly relocating?

Thanks, Greg

MacBook Pro 17", Mac OS X (10.5.2), iPhone 8gb, 20 iMac Intel (original release), MacBook Pro 2.33 GHz Core Duo
  • 1. Re: Icons Keep Moving
    Gregory McBride Level 1 Level 1 (15 points)
    Actually, I just noticed that the icon relocation is not random. No matter what icon I click on, it immediately moves to the last location on my desktop. It has made it so I can no longer double click on an icon because it moves immediately.
  • 2. Re: Icons Keep Moving
    Francine Schwieder Level 6 Level 6 (19,040 points)
    The behavior sounds very strange. There should indeed by a "none" option, although I don't know if that will fix your problem. Click on the Desktop, then access the Finder's View menu and select "Show View Options"--you should get a little dialog window titled "Desktop" with an icon size slider at the top, and at the bottom the Arrange by entry with a drop down menu accessed by clicking the double arrows. The very first entry is for None.
    Francine


    Francine
    Schwieder
  • 3. Re: Icons Keep Moving
    Gregory McBride Level 1 Level 1 (15 points)
    Thanks for the post. I didn't make myself clear. I do actually have a "none" option, but that then gets rid of the "snap to grid" option. I was thinking that maybe it was defaulting to placing the icons in order from oldest to newest since the icon moves the second I click on it. But, I do want to snap to grid with manual icon placement.

    For what it's worth, I restarted and the problem seems to have gone away. However, I have not hooked up to the home monitor yet. So, we'll see what happens.

    Thanks, Greg
  • 4. Re: Icons Keep Moving
    Gregory McBride Level 1 Level 1 (15 points)
    Problem stopped happening. Not sure what was causing it, but it's gone now.
  • 5. Re: Icons Keep Moving
    R C-R Level 6 Level 6 (14,175 points)
    The "none" option doesn't actually get rid of the "snap to grid" option (which is now something you can't turn off for the Desktop, just set the spacing for with the second slider). However, when you first change from some 'arrange by' order to "none," the current "snap to grid" setting isn't immediately enforced & the Desktop items may revert to some former locations, including (I think) those set while the OS allowed the "snap to grid" option to be turned off. I suspect this is what was happening to you.

    Had you followed setting the "none" option with even the slightest nudge on the grid spacing slider, you would have seen the icons jump to that spacing. The same would have happened with the icon size slider, since either one would have applied the view option settings immediately.

    The same would have been true if you had relaunched the Finder, logged out & back in, or restarted the Mac, which is what you did.

    The jumping around icon thing was I think the result of the Finder "noticing" that the selected icon wasn't on a current grid intersection & 'helpfully' moving it to one.

    Anyway, the main point is that should it happen again in the future, you can fix this just by nudging the grid spacing slider. You don't have to restart or log out.
  • 6. Re: Icons Keep Moving
    Captnjimi Level 1 Level 1 (0 points)
    I have the same problem. After playing SOF2 or my wife logs on to her Account, realy anything that would cause screen to totally refresh when it comes back icons have moved. I have view options set on none tried the snap to grid, nothing seems to work it appears to be a problem with 10.5.2. I have had my icons set this way for 20 years its nothing new to me but its new to 10.5.2... Waiting for Apple to fix this bug its not fun fixing icons on desktop everyday.
  • 7. Re: Icons Keep Moving
    George Skarpelos Level 1 Level 1 (5 points)
    I was able to fix it by running cocktail:
    http://www.maintain.se/cocktail/download.php