8 Replies Latest reply: Mar 18, 2008 12:22 AM by Davey G.
bloodreddmoon Level 1 Level 1 (0 points)
OK I'm trying to text my boyfriend and its telling me invalid # re-send using valid 10 digit mobile # or valid short code? i have the area code in and every thing and it still wont let me text!!!??!!??! this is really stupid!!! please help!

iphone, bla
  • Earless Puppy Level 4 Level 4 (1,905 points)
    do not text with a 1... remove the 1 from your phonebook

    (xxx)xxx-xxxx is 10 digits

    1-(xxx)xxx-xxxx is 11 digits

    hope this helps
  • jnaftzger Level 1 Level 1 (0 points)
    Have the same problem texting 1 number (that happens to be a Verizon number). This happens WHEN REPLYING to said number, as well as correctly entering it. So far 2 hours on he phone with AT&T has not resolved anything.
  • bloodreddmoon Level 1 Level 1 (0 points)
    i understand the 10 digit thing... the phone's just stupid.... and the person im texting is a at&t customer too so i dont understand why its giving me a hard time.... under his contact info i have the whole # on there and the error message is only showing the 7 digit #.... it doesnt make sense!

    i even tryed clearing our whole conversation but nope.... he's the one i talk to the most
    i dont know how many times ive cleard his #
  • Christap Level 1 Level 1 (0 points)
    Hitting the same problem... only when the person is in my contacts. Think the iPhone/ATT is stripping the (area code) from the 10 digits as entered into contacts. Pretty bad that this was not found in testing... I can only get SMS to work if I enter numbers manually and I can't reply to someone that is in my contacts list.

    Bummer...
  • Tenth Level 1 Level 1 (0 points)
    I was having the same problem and here is how I fixed it.

    I have fixed this problem on my iphone.

    1. Delete all record of the problem number that will not except text messages.
    Including contact, favorites, call log, text log...

    2. send a text message to the phone number manually make sure to include the area code, no 1 needed.

    3. click the sms button on your home screen, then select the number you just sent the message to and create a new contact from there.

    4. Done!!
  • ChrisJ4203 Level 8 Level 8 (36,755 points)
    I have read a couple of posts in the past regarding texting to Verizon customers. I believe the solution, and you can search to find out, was something to do with the Verizon customer not having the current firmware. They have to do something like dialing *228 on their phone and that will update them. Once they did that, the texts would go through. Don't take my information for gospel though, search the issue here and get the exact data.

    Hope this helps you.
  • ChrisJ4203 Level 8 Level 8 (36,755 points)
    I'm not sure that is has to do with Contacts. I am using my contacts to send my SMS messages to other AT&T customers and I'm not having any problems. I don't believe that AT&T is stripping the area code. It may have to do with something corrupt in the contact database. What are you using to sync your contact data with, Outlook? If you are, you can check your pst file with a program that resides on your computer called scanpst. That will verify if there are any errors in the pst file. Fixing that could help.

    Hope this helps you.
  • Davey G. Level 1 Level 1 (0 points)
    I also, sadly, had this problem too. Or else why would I be blogging on this site,... lol, JK

    The only fast, but not so easy way I figured out how to fix this was to add the right kind of area code for each phone number in your contacts. (I felt the computer was easiest, unless you don't sync your iPhone with your computer)

    Strangely enough, I didn't us a PC to do this. I used Address Book on my iMac to sync my contacts to my phone through iTunes. There are some settings that will put your contacts in (AREA) ###-### format in Address Book. Though, the will not fix the existing ones...

    So, just add those area codes in the begging of ur numbers, though NOT IN SMS itself, or else it would make it 2 numbers because of the new multi-text iPhone SMS has. No need to delete all contacts (though, it would help u go through all those people who u don't talk to any more... lol, JK) Oh, and yes, did work with replying to text (for any separate person who came for help)

    P.S. Did restore my phone though, which may, for some reason, have caused INTERNATIONAL ASSIST to fail, even though I have it ON! Unless it doesn't matter?!?