Previous 1 2 Next 24 Replies Latest reply: Mar 25, 2008 1:33 PM by Keebler
JScott Level 2 (220 points)
I see LOTS of posts on this issue. This is something that is torturing my husband, but not me. We both have sbcglobal accounts, dotmac accounts, and gmail accounts, and both have a Mac on Leopard and a Mac on Tiger. We have compared our mail settings to one another's for differences and have everything set up the same.

The problem VERY rarely happens to me (being asked for my email password) and constantly happens to him... whether in Tiger or Leopard. What I have noticed when it happens to me is that I have Mail up on both my iMac and my laptop. Whichever is the computer I started Mail on first usually doesn't complain, it is the one I started Mail on second.

My husband has an iPhone...

My theory is... Mail is up and going on the iPhone all the time. So when he uses his laptop or desktop, his mail accounts are already actively being accessed from the phone, so the computer wants to validate his password.

So I would be interested in knowing how many other uses with this issue have an iPhone. I saw posts from several who do.

Has anyone with an iPhone overcome this issue?

iMac 2.8 gHz 24" display, 2 gig RAM, Mac OS X (10.5.1)
  • Michael Maslar Level 1 (5 points)
    I have an iPhone and am having the same issue with mail always asking for my password. I don't have my iPhone set to automatically check for mail. I'm not sure what's causing this issue, but there does seem to be a correlation.
  • Valerie Anderson Level 1 (5 points)
    Hi, I've just resolved this same password issue on my Mail account (v 3.1), and it seems to have to do with whether your server offers web email. If it does, you need to logon to your web mail and confirm your passwords on your server, and then open Apple Mail and make sure the passwords match what's on your web mail. You may have to call the tech people at your server (mine is Bellsouth) to have them help you with this, but as soon as I did this the password requests stopped. Hope this helps.
  • project7 Level 1 (5 points)
    I also have an iphone - collecting my mail fine - and I have major problems since migrating to a new mail server - mac mail password rejected 60% of the time. What I don't understand is how it can accept 40% of the time.No pattern to it. Created a new user and new mail account - same thing.
    Changing to Thunderbird helps immensely - until it gets an error from pop server "Unable to lock maildrop". What does that mean??
    Put in password again and it goes ok - mostly!
    iphone and mac are both collecting mail from the same server using the same password etc.

    There is something not right here between client and server. iphone works fine, Thunderbird not bad at all, Mac mail hopeless.
    I am checking to see if switching iphone off changes things..........will post back later.

    Any other ideas out there? I will be trying the password check on my webmail when they send me a login for it.
  • project7 Level 1 (5 points)
    Following my previous post -

    iphone seems to be the issue......
    I have turned off my mail account on the iphone at midday. My powerbook mail has been fine - checking every minute all afternoon - thats around 240 pop password runs with no problem.
    I turn on the mail account on the iphone.
    It picks up all my mail fine. I check my mail on my PB - and guess what - pop server rejects password
    I turn off the mail account on the iphone and my PB mail works fine again.
    I turn it on again - and pop server rejects again..............etc etc etc

    any suggestions?
    I shall call apple (who previously suggested an archive and install!)
  • chrisklee18 Level 1 (20 points)
    I had a similar problem and might have a solution. It for sure sounds like this is an ISP problem, and not something with your mac. You said you still run the Mail App on Tiger. On Tiger, go to Mail->preferences-> Accounts. All of you accounts should be there. On the .Mac account check that the "Port" field is NOT 25. Most ISPs will not let you use mail if it is. This is a problem that was corrected on later models, but since you said you still run tiger, it might not have changed and your .mac mail might be getting confused between accounts. The correct number should be 993. This field is not change-able for later models. If your Tiger lists 587 change it to 993. SSL Should be checked. If you do not use SSL, it should be 143.
    If that doesn't work, please give which mail accounts are not working or are being asked the password, i.e. .mac, sbc etc etc., give versions of Tiger and Leopard, and the wording of the error messages or the like.
    Also, do the standard repair permissions in disk utility. Again, it could be a problem with the application. Software update also. Last suggestion i can think of is to go to the the window bar in mail app, click on connection doctor when the account goes offline to get details on where the connection is going bad.
    Hope this helps, good luck!
  • Jay Koller Level 1 (10 points)
    This may be 'voodoo' but it worked for me so I thought I would post it.

    Here is what I did:
    I went to Mail--> Preferences--> Accounts--> Advanced

    Under port settings my authentication type was set to "APOP" I do not know how this got this way but I changed it back to "password" what is should have been and it worked. I had another POP account that uses the same ISP and that one was set correctly but still not working. I changed the authentication setting, saved it, then returned it to the correct settings.

    Why that worked... I know not.

    I am using the most recent updates to Mail and Leopard for reference.
  • mickek Level 1 (10 points)
    I'm researching about this issue.

    Vhat ISP do you have?

    Other ISP:s affected are: Verizon, Demon and Glocalnet

  • JScott Level 2 (220 points)
    I am wondering if it is.... not Leopard, not Tiger, not the iPhone, maybe not even the ISP... but... something inherent to using e-mail and having more than one e-mail client actively contacting the mail server looking for mail. Occasionally at work (a PC, Exchange server world) if I have my Outlook open on my desktop PC and then open Outlook on a laptop to access the same exchange account, it's not quite right, either.

    We are experimenting with having the iPhone set to manually look for mail (instead of every hour) to see if that helps with the password prompting on the computer. (I'm not sure since it's not my phone, but I don't think the phone is ever prompting him for a password, which is interesting, but maybe that's because it was on all the time)
  • project7 Level 1 (5 points)
    Seems as you say - mail cannot be running on iphone and on my PB at the same time without getting pop password requests on the PB.
    iphone gets mail without any problem. If I turn the iphone mail account on, the pop server immediately rejects the password. I turn the iphone mail account off again and all is fine on the PB.
    iphone is set to auto-pickup mail every 15mins. That means it only sends a request to the pop server every 15 mins. But it blocks out (all??) other requests from my PB whether they are made every minute or 10 minutes.....?
    Does this mean iphone is ok away from the office to pick up mail on the hop, but should just be switched off while in the office?? Strange but reasonably workable. Easier than contacting my isp yet again about the problem!
  • Jay Koller Level 1 (10 points)
    I use Comcast as my ISP, however the problem presented itself when I was out of town. I believe the ISP for the hotel is Cox. My email service (POP, and SMTP) is provided through my website hosting company. They are called Webhero (

    Hope this helps.

  • Whats the use Level 1 (0 points)
    I have a new 17" macbook pro (2 months old) running OS 10.4.11. I have no iPhone.
    I've been prompted for my password probably 68 times today! (NOT an exageration.) Although I can go days without problems, this is something that happens quite often. At least one day a week. Often more.
    My old macbook pro (purchased 3 yrs. ago) had the same problem.
    I doubt it's an iPhone issue.
    I'm going nuts.
  • JScott Level 2 (220 points)
    Is the MacBookPro your only computer?
  • billbonz Level 1 (0 points)
    This has begun to happen to me -- maybe the last week. I don't have iPhone. Mail has always checked every 5 minutes for me without a hitch. I would love an answer to this. There seem to be no changes to my settings.
  • Edna20 Level 1 (0 points)
    I had the same issue after using Mail without any problems for weeks. I have an iPhone as well and another laptop up and running exchange. This issue was what someone explained earlier in this thread, I went into the advance mail settings and checked the port authentication which had been changed to something other than password. Once I fixed that it resolved the issue. I had just installed some updates so maybe one of them changed my mail settings. Hope this helps! I never did anything different with my iPhone or other laptop.
Previous 1 2 Next