10 Replies Latest reply: Apr 3, 2008 2:31 PM by cwizz792
Xavier-bcn Level 1 Level 1 (0 points)
Hello to all,

I have recently updated my computer (MacBook Pro 15 inch) to Leopard; now I am on OS X 10.5.2.
Some keys on my keyboard are not responding: the volume control, the space bar, the delete key . . .
I have tried with all firmware and software updates in the Apple support page but the problem is there.
Can someone give any idea?.
Thanks in advance

MacBook Pro 2Gz 15 Inch, Mac OS X (10.5.2), Mac Pro
  • Baloo Level 1 Level 1 (5 points)
    Is it a selected group of keys or is the entire keyboard and trackpad not registering?
  • Xavier-bcn Level 1 Level 1 (0 points)
    Hi Baloo,

    I have some keys not responding: the delete key, the space bar, the volume keys and some of the Function Keys.
    The trackpad is working correctly.

    Thanks again,
  • Baloo Level 1 Level 1 (5 points)
    It's probably a software glitch then. Does it go away when you reboot the computer?

    I have had the same problem on both my macbook pro and my macbook at random times and rebooting usually fixes it.
  • taijuan1 Level 1 Level 1 (0 points)
    I have the same problem. I usually, but not always, use an apple bluetooth keyboard at my home, but today when I tried to use the built in keyboard, the space bar and delete key wouldn't work. The letters work fine and everything works fine on the bluetooth keyboard. Any thoughts?
  • pienmac Level 1 Level 1 (0 points)
    Same here: spacebar, backspace, tab and arrowkeys freeze. It helps when I press the fn-key, but after a minute the keys are frozen again! All other keys work perfect. And ofcourse I 've rebooted and tried every software and firmware-update Apple offered before posting this..
    The problem started when using the new iMovie so it seems not a hardware-problem. Any help would be grately apreciated because this makes working with my beloved Macbook really anoying!
  • Tilo_Spyder Level 1 Level 1 (0 points)
    Hi there,

    i've got the same problem with a macbook white. Does anyone have any solutions or do i have to buy a new topcase/keyboard.... but it seems to me, that this is a software problem, cause the keys are not always without function.

    Thx for any posts...
  • hotsugar3x Level 1 Level 1 (0 points)
    Hi Everyone,

    I have the same issue but in a different way..

    I bought the latest macbook pro 4.1 with leopard 10.5.2, it works fine and the keyboard functions perfectly until i migrate my back up from my time machine back up disk!!

    Once i log on to the user on which i have my migrated files and apps, the keyboard will not respond at all! all function keys works, the delete button works, and the touchpad does work but none of the number / alphabetic keys works!!t

    I am re-installing the OS for the third time now decided not to migrate any files / apps as it messes everything up..

    please help if someone have any idea what is going on..

    Thanks and regards in advance.
  • Christian Fries Level 1 Level 1 (60 points)
    Hi.

    I had the same problem from time to time. Reboot helped.
    The issue started a week ago.

    Yesterday the keyboard and trackpad died completely. It is a MacBook Pro 3,1 with latest OS (10.5.2) and the MBP Keyboard Update.

    Nothing brought the keyboard back so far. I tried reset of PM, system reinstall. The firmware restauration cd was not aceppted. I brought the book in for service.

    Best
    Christian
  • Christian Fries Level 1 Level 1 (60 points)
  • cwizz792 Level 1 Level 1 (0 points)
    Hi everyone, I was having a similar problem with my brand new MacBook Pro. None of the letter keys would work. Instead, it was as if num lock was on. When i would press the keys where the numerical keypad used to be on the previous generation macbooks and macbook pros, the numbers would show up on the screen. Also, whenever i pressed the space bar, the computer would freeze and the only way to unfreeze it was to press command option escape.

    This is what fixed it for me:

    go to ~/library/preferences and delete all the contents, and then turn of mouse keys. If mouse keys is already off, turn it on and then off again. After this my keyboard was working normal.

    Also, if this does not work and you need your keyboard to type in a password or something, go to the international pane in system preferences, then to the input menu tab and check Keyboard Viewer. Once you do this, you can click on the flag in the menu bar and click show keyboard viewer and this will activate the onscreen keyboard.