Skip navigation

self-assigned IP address

16235 Views 21 Replies Latest reply: Jul 25, 2012 1:37 PM by RyanN77 RSS
1 2 Previous Next
wdrath Calculating status...
Currently Being Moderated
Feb 27, 2008 3:34 PM
My Macbook Pro is unable to connect to the Internet at my home and gives me the message, "AirPort has a self-assigned IP address and may not be able to connect to the Internet". Here is what's going on...

I got this refurbished MBP for Christmas and it hasn't connected to the internet at my home since. I have a cable modem (Cox Communications) and a D-Link wireless router (WBR-2310). My wife's iBook G4 has no problem connecting to our wireless network and neither did my previous iBook or my iPhone. In the "Network Preferences" Menu the AirPort status says "On" and below it it says "AirPort has a self-assigned IP address and may not be able to connect to the Internet".

My MBP has no trouble connecting wirelessly to other networks but for some reason I can't get it to work at home. I have tried everything I can think of to solve the problem (reseting the router and modem and trying a different modem). I have gotten no help from Apple Phone Support and both times I have talked with them been put on hold to talk with a specialist only to be hung up on after 45 minutes of waiting.

Any help would be much appreciated!

Thanks!
Macbook Pro, Mac OS X (10.5.2), Refurbished Macbook Pro
  • BillC37 Calculating status...
    Currently Being Moderated
    Feb 27, 2008 3:59 PM (in response to wdrath)
    There's some thought out there that Dlink wireless doesn't play well with intel Macs. Putting that aside for the moment, here are a few things to check. Self-assigned IP means the Mac is not getting an IP through DHCP.

    - Right click the airport icon in the menu bar. Does your network SSID show up? Can you select it?
    - Try manually assigning an IP address in the right subnet and see if you can connect that way.
    - Turn off encryption and see if that makes a difference.
    - Do you have MAC address filtering turned on in the router? If so, make sure you've entered the correct MAC address for your MBP's Airport adapter.
    - See if the router logs show a connection attempt. That may give you a clue as to why it's not linking properly.

    Let us know what happens and ask if there's anything you don't understand about the above.
    MP 2.8 Octo, MBP 15" LED, Al iMac20, Mac OS X (10.5.2)
  • Nessa4189 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 4, 2008 11:34 AM (in response to wdrath)
    I am having the same problem with a "self assigned IP address"...working with DLINK, i still have no connection at home. DLINK has been no help whatsoever...
    MacBook pro, Mac OS X (10.5)
  • Scott Devoid Calculating status...
    Currently Being Moderated
    Mar 4, 2008 1:11 PM (in response to wdrath)
    Hi there,

    You shouldn't assign your IP address manually to the same address as on your wife's computer ( your wife's computer has already claimed that address). Instead give it the next address in the sequence. So if your wife's address was 192.168.0.101 then pick 192.168.0.102.

    To check encryption, open System Pref. > Network > Airport > Advanced
    Under the "Airport" tab, double click your wireless network. Select "None" for "Security"

    To check if you have mac filtering on, plug one of the laptops into the router via an ethernet cable and visit http://192.168.1.1 ( The last two digits vary by model, so run a google search for "D-Link [Router model] ip address" ). You may be asked for a password, at which point you should again google for the default passwords.

    After you've gotten past the password, you'll be at the configuration page for the router. Look around at the various options you have. If MAC address filtering is enabled, there should be a page with a list of addresses that look something like this: "00:16:cb:f6:20:b0" ( Your MAC address is viewable at System Pref. > Network > Airport > Advanced and is called "Airport ID" (it's at the bottom of the pop-down window).

    If, after all of that you still can't figure it out, open up the Terminal ( Utilities > Terminal ) and type:
    "ifconfig -a" and paste what it returns back here.
    MacBook Pro 15" 1.83Ghz, Mac OS X (10.5.2)
  • alaurenc Calculating status...
    Currently Being Moderated
    Mar 19, 2008 8:29 AM (in response to wdrath)
    Same problem here.
    My husband can connect with the wireless router (belkin) without a problem. I get with my macbook the same message about a self-assigned ip address and the computer not being able to connect the internet. And indeed it is not connecting. Depressing....
    Anyone got an idea?
    MacBook
  • mac_paint Calculating status...
    Currently Being Moderated
    Apr 2, 2008 10:30 PM (in response to alaurenc)
    First time I got struck by the self-assigned IP address 'bug'. Fortunately I had a back up of my system on an external HD and I was able to boot and connect through that without this 'bug'. I checked my network settings and DHCP had assigned an address. Booting back to my Macbook Pro HD I got the self-assigned IP address 'bug' again. I finally resorted to using a manually entered address under the TCP/IP tab in the network preferences. You have to enter the server address which I think should be 10.0.1.1 for the AE then enter a server address, using your server address but with the last digit changed to some other number. I stream internet radio at night and sometimes I'll lose then regain the connection. In the morning the Airport Utility window will be open with a message that the connection problem was solved. Could be connected??? I'll see if I get the same message with this manually configured address.
    2008 MacBook Pro, Mac OS X (10.5.2)
  • iflyskyhigh Calculating status...
    Currently Being Moderated
    Apr 17, 2008 6:00 PM (in response to wdrath)
    I have been searching the net for hours for an answer to this problem. My situation is a little different though. I don't have a problem connecting to my home net work, but I am a pilot and am on the road a lot. I would say that I get the "self-assigned IP address" from about 1/2 to 3/4 of the public networks (airports, hotels, etc) I try to connect to. I build PC's and am pretty techie when comes to computers so there isn't much I haven't tried, but to no avail. I had a Windows based laptop up until last year an never had any problems connecting to the same spots, not only that but my co-workers can get an IP address when sitting right next to me and I can't so I know it has something to do with the communication between the Mac and the public router. I obviously can't unplug or reset the public router so I'm not sure what else to do. I have a hard time believing that Apple doesn't know about this issue or that I'm the only one affected. I wish apple would at least acknowledge the issue on their support site and say they are looking for a solution.
    Macbook, Mac OS X (10.4.11)
  • a procrastinator Calculating status...
    Currently Being Moderated
    Apr 17, 2008 7:57 PM (in response to iflyskyhigh)
    As far as recognizing a problem, Apple has acknowledged that some AirPort issues will be addressed in the 10.5.3 update.

    While I haven't had any trouble in public access points, and this won't help there, at home my network wasn't giving my MBP an IP address so I had to hook up the modem to the MBP via ethernet, and it make me go through some stupid login hokum the local IP had, and it's worked fine since then. For your home network, you might see what happens if you connect directly to the modem. After that, the best option is to try a different brand router.

    Best regards,
    Will
    MacBook Pro 17" 3,1, Mac OS X (10.5.2), Intel 2.4GHz, 160GB 7200 RPM HDD; 2GB Memory
  • BGcharlie Calculating status...
    Currently Being Moderated
    Apr 27, 2008 6:48 PM (in response to wdrath)
    OK,

    I had the same problem with my Imac G4. All other machines and my Iphone connecting fine. I upgrade the old Imac with an airport card and can't connect after sleep. Error message of a self assigned IP. I tried everything to clear this problem up and this is the only thing that worked. Hope it helps.

    Delete your for airport preference file then restart. (also tested this a few times by putting the system to sleep, reconnects fine every time. good luck)

    Here is the file that you can try and delete:

    Macintosh HD>Library>Preferences>SystemConfiguration>com.apple.airport.preferences.plist
    imac G4 1 GHz powerPC, imac G5 2.4 GHz intel duo, Mac OS X (10.5.2)
  • risingstar Calculating status...
    Currently Being Moderated
    May 9, 2008 1:52 PM (in response to BGcharlie)
    I am having extreme trouble with this since upgrading to Leopard. At home, I connect to my Airport Express WEP network with no problem. However, at my university and work, which have open wireless networks, I get the "self-assigned ip address and may not be able to connect to the network problem." The same thing happens at a cafe I frequent which has a WEP network.

    I brought my computer to my university's tech support and they couldn't figure it out, though some other macbooks running Leopard have come in with the exact same problem--he said something like the computers are acting as if they are using PPoP or something though they are not set to do so.

    However, I walk across the street to our sister university, and I can access their network! Does anyone have an explanation or a fix? I've deleted my preferences and my keychain passwords several times in several different combinations. I have all the latest updates and firmware installed.

    Is there anything to do from the terminal? I noticed from the terminal, though I am very much a novice at this, that for the networks that I can't connect to, it reports "802.11 OPEN" even if they are not open networks. I don't know if this is a problem.
    Macbook, Mac OS X (10.5.1)
  • Mike the IT man Calculating status...
    Currently Being Moderated
    Jun 26, 2008 7:37 AM (in response to wdrath)
    This is one nasty bug, I have had the issue on 2 apple computer in my home and many other friend have had the issue. I say bug because the issue does not show up on Tiger or Panther. I have found out that you can do the normal fix for a few times but after so many times you can not get on the internet and must reinstall Mac OS X 10.5. I am planing on ordering Mac OS X 10.4 to install on my system, and have told friend to do the same. So if you try the normal I would reformat reinstall or go out and buy a apple router as some friend have had luck with this fix but for 129.00 buck I'll stick with tiger in till apple get it head on right.
    Apple Emac, Mac OS X (10.5.3)
  • FUNK1196 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 28, 2008 8:51 PM (in response to iflyskyhigh)
    i have this problem too, its so frustrating because PC's never have this problem.

    only happens for me with public routers.. and it's only the ones with login pages.

    a lot of public routers have a sign in screen where you just click 'connect me' or something to that effect when you first open your browser.

    but my macbook won't pull up that screen sometimes.. and just fails to connect because of it.

    and i get the "airport has a self-assigned ip address and may not be able to connect to the internet" in the internet setting, tried renewing the dhcp release, no luck.
    only..... at one point, i tried for 30 minutes straight at burger king, and it finally worked....

    there's got to be a way to induce that login page!
    Macbook, Mac OS X (10.5.3)
  • gladvlad Calculating status...
    Currently Being Moderated
    Aug 28, 2008 10:31 PM (in response to wdrath)
    I have had this problem several times with my MBP, running OSX4, regardless of the wireless router I am using. What Apple tech support has told me is that the message indicates a security issue. Whenever a security issue arises, OSX assigns an IP address, rather than allowing your router to assign one. I have frequently found that when the network goes down, or the ISP goes down, my MBP loses the password for my network and I must manually re-enter the password. For some reason, Apple telephone support doesn't grasp this issue, although Windows support services usually do. A first step is to connect to your router using an ethernet cable. If you can browse using an ethernet connection, but not wirelessly, the problem may be that OSX has lost the password that your network requires for wireless internet access. If your network does not use a password, I can't help you. If it does, go to System Preferences, click on Network, then click on Airport. In the drop down menu opposite "Show", click on the name of your network to highlight it, then click "Edit", a drop down window will appear showing the name of your network. Click to drop down the menu for "Wireless Security" and choose the type of security your network uses, usually WEP 40/128 bit ASCII. In the drop down that appears enter your password. That should solve the problem.
    I have had this problem much less frequently lately, and suspect that a security patch may have helped. So I would be sure that you have all the current updates installed.
    Macbook Pro
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.