Previous 1 2 3 4 Next 56 Replies Latest reply: Jan 18, 2010 8:49 AM by Frank Scallo Jr
Please try something else. Level 1 Level 1 (0 points)
My minimize button turns grey and become unavailable when I use Spaces sometimes.

When I switch to Space 2 and then switch back,the windows in Space 1 are all unable to be minimized.
The button turned grey while the other two remain in color.

This most occurs when Space 2 is running Windows Xp in Vmware Fusion.

Any suggestions?

macbook pro 2.0GHz, Mac OS X (10.5.2)
  • smiams Level 1 Level 1 (0 points)
    I am running VMWare Fusion (which is running Windows XP in full screen mode) on Space #2 via "spaces".

    If I toggle to space #2 and then toggle back, the minimize button on my Adium (IM client) contact list window window is grayed out. If I close the Adium window and open it back up, the minimize button will return.
  • Please try something else. Level 1 Level 1 (0 points)
    So it might be Vmware Fusion`s problem. It seems that when Space2 is running other softwares no such problem happens.
  • jbformby Level 1 Level 1 (0 points)
    This issue occurs for me when using other apps such as DVD player or Parallels in full-screen mode. It appears to be related to the dock issue(s) that full-screen apps cause.
  • macjack Level 9 Level 9 (50,670 points)
    Try starting in "Safe Mode" If that works go to System Preferences >> Accounts >> Login Items and remove them. Boot normally and test. If not go to ~(yourHome)/Library/Contextual Menu Items and move whatever is there to the desktop. Then do the same with /Library/Contextual Menu Items. Lastly, try moving ~(yourHome)/Library/Fonts to your desktop and restarting.

    Safe Mode will take a bit more time to startup because it runs a directory check, first.

    Log out/in or restart, if that sorts it start putting items back one at a time until you find the culprit.

  • tmelander Level 1 Level 1 (0 points)
    I see this post is pretty old, but the issue still exists. I am using the latest version of VMWare to date, 1.1.2. If I am using VMWare Fusion to run Windows in combination with Spaces on Leopard (10.5.3), I can consistently reproduce the issue where if I go to the space running Windows with VMWare Fusion and then back to the Mac window my minimize button disappears in FireFox. It does not seem to affect other applications; only FireFox. Seems pretty odd, but this seems to be more of an issue with VMWare Fusion. I have no idea how to deal with this except post something with Apple and VMWare.
  • onelittlemonkey Level 1 Level 1 (0 points)
    I've got the same VERY FRUSTRATING "minimize button disappears" problem.

    My issues:
    - Multiple applications affected (Safari, Mailplane, NetNewsWire, etc)
    - ONLY seems to happen when i use keyboard shortcuts to switch spaces.
    - ONLY happens when an application stays in full-screen mode during a space switch. (ie, if you activate the spaces application and change by clicking one of the spaces with the mouse, the minimize button doesn't become disabled)
    - VMware Fusion is NOT the only culprit--VLC player in full screen mode also causes the same behavior. Other apps such as Quicktime and Aperture drop out of full screen mode when changing spaces, which is undesirable but avoids the minimize button problem

    Seriously, spaces is better in 10.5.3 but PLEASE fix this issue!!
  • PeterO2 Level 1 Level 1 (40 points)
    I am experiencing the same bug. Every time I have FireFox or NetNewsWire maximized in Space 1, and then use keyboard shortcuts to switch to VMWare running full screen in another Space, the minimize button disappears from FireFox and NetNewsWire.

    This is obviously a bug that Apple needs to fix. In the meantime, I have found a couple of tricks for bringing back the minimize button (and maybe give the programmers a hint on how to reproduce and fix). In FireFox, if you press the red quit button but then cancel in the confirmation window, its amber button will be reactivated. In NetNewsWire, you need to play a movie in QuickTime (I have put a short .mov file in my dock) and that will reactivate its amber minimize button. Not a long-term solution... but a temporary fix for those wanting to get their amber buttons back.

    Peter O.
  • andrew1234 Level 1 Level 1 (0 points)
    I'm experiencing this issue as well. At first I thought it was VMWare but as others have mentioned, other apps cause it too.

    I called Apple support but they were less than helpful. The support tech would not acknowledge that this was a known issue and blamed it on VMWare. My free support has since expired but I encourage anyone with Apple support to contact Apple. It's possible it will get resolved if they get enough complaints.
  • Eliézer M de Campos Level 1 Level 1 (0 points)
    It's quite simple.
    Whenever an application hides the Dock, the minimize button is disabled on every other un-minimized application.
    Applications that won't minimize to the Dock (such as iTunes) are obviously not affected.

    I suppose the Dock tells every maximized application that it is unavailable. The bug is that it should tell them all that it's available again.

    Message was edited by: Eliézer M de Campos
  • LFirth Level 1 Level 1 (0 points)
    I have the same problem - hopefully with your explanation Apple can make a bug-fix and we can all move along.

    Incidentally - I've noticed even with the minimise button hidden, you can still minimise the application using the shortcut keys, so the Panel can obviously accept minimisations, even if the application window doesn't realise it...

    I'm a new mac user who needs vmware because I program .NET for a living (for now) - so the fact Apple are ignoring this problem and blaming a third party rather than working with them to solve it (even though I doubt it is VMWare's fault) is pretty annoying.

    Why spend so much time on the bells and whistles of Spaces, like smooth switching and application dragging etc, when they haven't fixed some basic bugs. If I wanted that sort of experience I would have stuck with Beryl on Linux for free!!

    So far loving OSX, but hating some of the niggles.
  • Fabiano Arruda Level 1 Level 1 (0 points)
    Same problem here... In my case, Im using Microsoft Remote Desktop Connection in full screen. Apps afected so far are Firefox 3, VP UML and Adium. First I thought its was a firefox bug, then that it could be a RDP bug... but seems like its a very old bug of OS X related to fullscreen apps, still not solved. Apple please fix this!
  • Bobby V. Level 1 Level 1 (20 points)
    I have a workaround. Sorry it does not solve the button, but I found something that does work.

    Double-click on the top of the window, in the title bar, and it will still work. The button, now that's for Apple and VMWare to figure out.

    (I'm just thrilled the my new AExpress will talk to my XBox 360, eventually Apple will get to the 3rd party developer).
  • Fabiano Arruda Level 1 Level 1 (0 points)
    Doesn't work for me.

    Also I've noticed that now Safari is having the same problem... and again, its not only related to VMware. As I said before, for me it happens with Microsoft RDP. I dont even have VMware installed here.
  • Dr. No One Level 1 Level 1 (0 points)
    If you want to minimize again, there is a different way to minimize. The skin of the window is gray. double-click on it and it will minimize.
Previous 1 2 3 4 Next