Skip navigation
This discussion is archived

fn key not working on MacBook?

3459 Views 6 Replies Latest reply: Mar 11, 2008 1:46 PM by LukeD RSS
LukeD Level 4 Level 4 (3,115 points)
Currently Being Moderated
Feb 28, 2008 11:05 AM
Does anyone have any ideas on how to get the "fn" key working on a MacBook?

Thanks so much!
MacBook Pro 3.1, 2.4GHz, 2GB RAM, 160 GB HDD/MacBook 2.2GHz, 120GB/ThinkPad T42, Mac OS X (10.5.2)
  • bdkjones Level 4 Level 4 (1,330 points)
    Currently Being Moderated
    Feb 28, 2008 11:08 AM (in response to LukeD)
    What are you trying to do with it that's not working? (In other words, how have you determined that it's broken?) You have the 2.2Ghz Macbook, so I'm assuming you've got the new keyboard layout (Where Expose is launched with F3, Dashboard with F4, volume keys over on the right, etc).

    Hit Fn+F4. If the dashboard does NOT come up, your function key is not broken. (If you don't have the new keyboard layout, hit Fn+F12 instead.)
    2.4 Ghz Macbook, 2GB RAM, Mac OS X (10.5.2)
  • bdkjones Level 4 Level 4 (1,330 points)
    Currently Being Moderated
    Feb 28, 2008 11:23 AM (in response to LukeD)
    Does the function key on the MacBook work correctly in OS X?
    2.4 Ghz Macbook, 2GB RAM, Mac OS X (10.5.2)
  • dzaazd Calculating status...
    Currently Being Moderated
    Mar 11, 2008 12:59 AM (in response to LukeD)
    I'm having the same problem, I think. My fn key does work in Windows XP, since the function keys (f1 - f10) act differently depending on whether I'm holding fn or not. However, other advertised key strokes don't work. Specifically, fn + delete acts like backspace (not windows delete). Similarly, fn + left is not home, nor is fn + right the same as end.

    My current solution is to use http://www.autohotkey.com/ as has been mentioned elsewhere on the forum. I am using the script:

    #Backspace::Send {Delete}
    #Left::Send {Home}

    to map command-delete to (in place) delete, and command-left to home.

    For the record, my MacBook was purchased in mid February, before the very recent new rollout. I'm running XP with service pack 2, and the install is fresh as of today. I've installed the drivers that came with OS X, and have also tried reinstalling the keyboard drivers. I have updated my keyboard firmware, but I still have issues with keystrokes occasionally being lost when I switch points of focus. This information is provided to help people find a pattern as to what causing the problem.
    MacBook, Mac OS X (10.5.2), 2.2 GHz, 4 GB RAM

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.