10 Replies Latest reply: Jan 26, 2006 1:01 PM by MacDuffee
John Hoin Level 1 (5 points)
For the past few days I have been unable to get any of my companies G4's and G5's to install certain items using Software Update. The error given on multiple machines is:

The Update (various) cannot be installed.
The Digital Signature is incorrect.
This package have been tampered with or
corrupted since being signed by Apple.

Since this is happening on multiple machines we can rule out any of the obvious things to try such as repairing permissions. Also selecting the option of having Software Update download to a file also results in the same error.

Any suggestions?
  • Andrew Kimmel Level 1 (0 points)
    I am getting this same issue with a brand new Dual 2.5 G5. Out of the box is has 10.3.7 and included is a drop in DVD updater to 10.4. Once the update is done I have tried to use the software update to make the OS current and I get the same error.
    I contacted Apple about this and they had never heard of this error nor did they have a solution, after 75 mins and a transfer to a Product Specialist, except to take it to a local retail store for a "Genius" to look at. I havent done this due to the restrictions of my comany.

    Any suggestions from anyone on this specific problem would be a life saver!
  • juliette Level 1 (5 points)
    I just received the new iMac and got the same message when I tried to do the software update. I just did each update from here where it says 'Important Software Updates' close to the top of this page. I don't know if the same error message will happen the next time I try to update but this solved the problem for now.
  • daehl Level 1 (50 points)
    I am having the same problem. I noticed it over the weekend, but didn't give it much thought until I tried it again yesterday and today. I am running Mac OS 10.4.2 and it has updated without any problems until this issue. Now that I see others have the same problem on a variety of hardware configs I am beginning to suspect a bug in the software updater. I've tried rebooting and fixing permissions on my startup disk but to no avail. Right now I'm trying to install the Security Update 2005-008 along with Quicktime 7.0.3 and iTunes 6.0.1. The last successful update I performed was Quicktime 7.0.2, iTunes 5, Safari Update 2.0.1, the iTunes Phone Driver and Security Update 2005-007.

    My console includes the following:

    2005-10-26 20:18:57.904 Software Update[261] session:product:061-2149 didFailWithError:NSError "Error SUSessionErrorDomain 2" Domain=SUSessionErrorDomain Code=2 UserInfo={
    Destination = "/Library/Packages";
    Path = "/private/var/tmp/folders.501/Cleanup At Startup/com.apple.SoftwareUpdate.74wnwq/Chewable/QuickTime703.pkg.tar";

    This is a bummer, Apple!

    UPDATE: I just manually downloaded and installed the Security Update 2005-008 from Apple.com and encountered no problems whatsoever. However, software Update still gives me the digital signature errors on the remaining available updates. So again, I think there is some bug triggered in Software Update. I'm going to try and install Quicktime 7.0.3 manually now...
  • daehl Level 1 (50 points)
    Well, I installed the Quicktime 7.0.3 update manually without problem, but still no success with other updates via Software Update. So next I tried installing the iTunes 6.0.1 update manually. And it didn't seem to work... odd.

    The thing I noticed was that the installer icon would bounce in the Dock for and instant and then disappear without any error. I tried this over again a few times each time without success. Then I tried launching the installer packages inside. no joy.

    Finally I tried launching the Apple Installer itself and choosing the iTunes 6.0.1 update package. That worked!!!

    Even better, now my Software Updater works as it used to! There was only one update left remaining to try: The 9-23 iPod Updater. But that one definitely wouldn't update before I upgraded iTunes 6.0.1. It gave the same "digital signature is incorrect" error over and over, but not anymore... Yay!

    So it looks like iTunes was the culprit! Not sure exactly how, but now that iTunes is upgraded everything seems fine. So if you are having problems with Software Update, manually upgrade to iTunes 6.0.1 by launching the Installer first (in your ":Applications:Utilities" folder) and maybe that will do the trick for you as well!

    Good Night...that's enough messing around with my Mac for the evening...

    ps. saw the suggestion about Directway on another thread. I am not using Directway, so that is not an issue with this problem.
  • Reid Sorenson Level 1 (70 points)
    I had the same problem today with a fresh-from-the-box iMac. Based on a suggestion in another thread, I deleted the "com.apple.SoftwareUpdate.plist" file from ~/Library/Preferences/.

    That seemed to do the trick; after a restart, all is working normally.
  • John Hoin Level 1 (5 points)
    Thanks guys, nothing that has been suggested seems to correct the problem. At least now I see other threads on this same problem so I know I am not alone here. Let's see what gets done to fix it. I doubt the problem is on my end.
  • ksapple Level 1 (0 points)
    i am having the same problem with a brand new mac. on top of that i am unable to chat with mac help as they don't recognize my serial number even tho i've faxed it in.

    My apple experience so far has been sub-par. Makes Bill Gates look good.
  • Fumiaki Kawashima Level 6 (11,765 points)
    With regard to a Digital signatures inconsistency, you may want to check it out with Digital Signatures in Security Concept for Mac OS X Security Architecture.

    For examples of troubleshooting, collate the error message with any third-party applications (e.g., a P2P related) that could attempt any modifications to a system configuration files, or available logs listed on console.log that could imply something to it shortly before the message was generated, or looking back on when if there were any chance to get an odd runtime environment for the Internet connection.

    In one of the parent documents for Apple' Digital Signature, it describes as follows:

    Aspects of Security
    The fundamental purpose of security is to control who has access to valuable property, whether physical or intellectual. This is the reason we have locks on the doors of our houses, why the military encrypts classified information, and why Mac OS X enables you to require a password every time someone logs on to your computer.

    Security features on a personal computer can be classified into two general groups: those designed to protect programs and data on the computer from unauthorized access by users on the system (“local security”); and those designed to protect the system, programs, and data from unauthorized access over a network or other transport medium, such as removable disks (“remote transport security”).

    When considering local security, you must be aware of whether access is being controlled by the operating system or by the application itself.
  • Jim Brandt Level 1 (15 points)
    I spoke to Apple support on this one and it appears the download files have a date associated with them. After a period of time, the date expires so the digital signature appears incorrect. It seems this happens with systems that need the older updates.

    If you install all of the older updates by hand from the Apple site, it works. Once you get up-to-date, more recent ones will start working again because the dates are correct.

    17 Powerbook   Mac OS X (10.4.3)  
  • MacDuffee Level 1 (0 points)
    I have the same problem on my BRAND NEW G5 Quad Core. I even re-installed Tiger from scratch. I too spoke with Apple, they claimed (4 days ago) that they had not heard of this problem. The answer, as most have stated, is to download them manually and install. I sure miss my Software update! Hope they can fix it. I plan on calling in to Apple everyday during my 90 day support period.