14 Replies Latest reply: May 30, 2008 10:36 PM by jamarican
natewill2 Level 1 Level 1 (0 points)
hello,
I put in a dvd movie in my mac to watch. When I was done I tryed ejected it is trying to come out but it won't. Does any one know any short cuts to get it out with out taking it apart or taking it in to the shop. Any info or input I would love.

20in alum. 2.4ghz, Mac OS X (10.5.2)
  • mrtotes Level 6 Level 6 (11,815 points)
    When you next restart hold down the left mouse button immediately after the start-up chime.

     

    cheers

     

    mrtotes

  • PTT Level 1 Level 1 (0 points)
    I just attempted the restart/after the chime/hold the left button on the mouse suggestion. It definitely went to the CD that is stuck in the drive. However, it did not eject. Now the Mac is making a noise from the drive every 10 seconds or so. . .

    I think I am going to need to call customer support and I anticipate having to have someone take a look at it. . .
  • natewill2 Level 1 Level 1 (0 points)
    Thanks for the info but the disc did not come out. So I called apple and they are coming to look at. thanks
  • gmktng Level 1 Level 1 (0 points)
    Hello,

    Twice now, my Intel based iMac wouldn't boot while I had a DVD in the superdrive. On both occasions, I went through every suggested action, including holding down the mouse button, holding down various keys, tipping the computer on its side, etc.

    None of these worked.

    What DID work was unplugging the computer (not just turning it off) for an hour. Then I turned it on while holding the "Eject" button on the keyboard (it's right above the delete key on the main part of the keyboard and the icon looks like a triangle stacked on a line). Both times, much to my amazement, the DVD came out and my iMac proceeded to boot with no problems.

    I hope this helps someone. BTW, the "one hour" unplugged time was just my random choice. Maybe a shorter time works but I can't say for sure.
  • °°Sushi°° Level 1 Level 1 (0 points)
    I really hope this is going to work out for me tonight, I have the same problem with a music CD on my comp and I didn't know what to do.

    I'll try these couple of tricks and let you know the outcome!!

    Thanks!
  • °°Sushi°° Level 1 Level 1 (0 points)
    in the end nothing suggested above has worked for me...

    I'll have to call Apple for technical support...
    Feel free to let me know if ou have any other suggestions to make!!
  • GoKayak Level 1 Level 1 (5 points)
    Try the Terminal interface. That's what worked for me.

    Finder/Go/Utilities/Terminal

    When the terminal window appears type in the following in the command line:

    drutil tray eject
  • Barbara Brundage Level 7 Level 7 (22,075 points)
    I don't know about the alumacs, but with previous models, if a DVD was physically bumping against the edge when trying to come out, sometimes pinching the computer together around the DVD slot would realign things long enough to get the disk out. If that works, take the computer in to have it fixed.
  • Lee Meadows Level 1 Level 1 (5 points)
    Barbara: Thank you, thank you, thank you! Your simple solution of pinching the computer together worked the first try, and this disk has been stuck for a long time. I just didn't want to haul my computer into the Apple store, and you've saved me much time! Lee
  • Wackers Level 1 Level 1 (0 points)
    Hi

    I've a similar problem with a thinner, more flexible DVD that came free with a magazine and it's now stuck in m slot-loading intel iMac. The slot is too narrow to get a pair of tweezers inside, although I can't see the edge of the DVD coming into view when the drive tries ejecting it. Instead, it just goea back in and mounts again.

    Looks like I'll have to take it to my local Apple dealer. He-ho.
  • Barbara Brundage Level 7 Level 7 (22,075 points)
    Great, glad that did it for you. But when you have time you probably should get it properly taken care of while it's still under warranty.
  • Tamade Level 1 Level 1 (0 points)
    I have a similar but not exact issue. I don't have a problem ejecting cd's as long as the cd icon is on my desktop. My problem is sometimes when I put a CD into the drive, the cd icon pops up with the default AUDIO CD text and disappear within a second. When I hit eject, nothing happens because I believe the system doesn't think there's anything inside since there is no CD icon on my desktop. I hit all the eject button possible, from the menu to the one on the keyboard. Also, since the icon does not exist, when I go to the Finder or HD icon, I don't see the disc icon to eject from there also. The only way to eject is if I reboot, then it pops up right away on my desktop. Please help.
  • Tania-Brazil Level 1 Level 1 (0 points)
    I inserted a DVD on my Mac OSX 10.5.2 and the icon won't appear anywhere, just as if there is no DVD at all, and it won't eject either. It keeps making noises as if it's trying to eject, but can't. I restarted it several times, unplugged it, but nothing seems to work.

    What should I do?
  • jamarican Level 1 Level 1 (0 points)
    Exactly!! Mine is doing the same thing. Please help somebody.